Microblaze: added architecture support for both big endian and low endian
[buildroot-gz.git] / package / wget / wget.mk
blobb14cd92bb37a88b047ebb9695b0d41b0a362eb1a
1 #############################################################
3 # wget
5 #############################################################
7 WGET_VERSION = 1.13.4
8 WGET_SITE = $(BR2_GNU_MIRROR)/wget
10 # Prefer full-blown wget over busybox
11 ifeq ($(BR2_PACKAGE_BUSYBOX),y)
12 WGET_DEPENDENCIES += busybox
13 endif
15 ifeq ($(BR2_PACKAGE_GNUTLS),y)
16 WGET_CONF_OPT += --with-ssl=gnutls \
17 --with-libgnutls-prefix=$(STAGING_DIR)
18 WGET_DEPENDENCIES += gnutls
19 endif
21 ifeq ($(BR2_PACKAGE_OPENSSL),y)
22 WGET_CONF_OPT += --with-ssl=openssl --with-libssl-prefix=$(STAGING_DIR)
23 WGET_DEPENDENCIES += openssl
24 endif
26 # --with-ssl is default
27 ifneq ($(BR2_PACKAGE_GNUTLS),y)
28 ifneq ($(BR2_PACKAGE_OPENSSL),y)
29 WGET_CONF_OPT += --without-ssl
30 endif
31 endif
33 $(eval $(call AUTOTARGETS))