1 ################################################################################
5 ################################################################################
8 IRSSI_SOURCE
= irssi-
$(IRSSI_VERSION
).
tar.xz
9 # Do not use the github helper here. The generated tarball is *NOT* the
10 # same as the one uploaded by upstream for the release.
11 IRSSI_SITE
= https
://github.com
/irssi
/irssi
/releases
/download
/$(IRSSI_VERSION
)
12 IRSSI_LICENSE
= GPLv2
+
13 IRSSI_LICENSE_FILES
= COPYING
14 IRSSI_DEPENDENCIES
= host-pkgconf libglib2 ncurses openssl
18 --with-ncurses
=$(STAGING_DIR
)/usr \
21 ifeq ($(BR2_PACKAGE_IRSSI_PROXY
),y
)
22 IRSSI_CONF_OPTS
+= --with-proxy
23 # If shared libs are disabled, 'proxy' has to go in the list of built-in
25 ifeq ($(BR2_STATIC_LIBS
),y
)
26 IRSSI_CONF_OPTS
+= --with-modules
=proxy
29 IRSSI_CONF_OPTS
+= --without-proxy
32 ifeq ($(BR2_PACKAGE_IRSSI_TRUE_COLOR
),y
)
33 IRSSI_CONF_OPTS
+= --enable-true-color
35 IRSSI_CONF_OPTS
+= --disable-true-color
38 # Cross-compiling irssi with the perl interpreter enabled doesn't work
39 # yet. So, remove scripts as they are useless in that case.
40 define IRSSI_REMOVE_SCRIPTS
41 rm -rf
$(TARGET_DIR
)/usr
/share
/irssi
/scripts
/
44 IRSSI_POST_INSTALL_TARGET_HOOKS
+= IRSSI_REMOVE_SCRIPTS
46 $(eval
$(autotools-package
))