python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / irssi / irssi.mk
blob7df7bbc445e3b8478f636e6a3b8bc541bc144af1
1 ################################################################################
3 # irssi
5 ################################################################################
7 IRSSI_VERSION = 1.0.2
8 IRSSI_SOURCE = irssi-$(IRSSI_VERSION).tar.xz
9 # Do not use the github helper here. The generated tarball is *NOT* the
10 # same as the one uploaded by upstream for the release.
11 IRSSI_SITE = https://github.com/irssi/irssi/releases/download/$(IRSSI_VERSION)
12 IRSSI_LICENSE = GPLv2+
13 IRSSI_LICENSE_FILES = COPYING
14 IRSSI_DEPENDENCIES = host-pkgconf libglib2 ncurses openssl
16 IRSSI_CONF_OPTS = \
17 --disable-glibtest \
18 --with-ncurses=$(STAGING_DIR)/usr \
19 --without-perl
21 ifeq ($(BR2_PACKAGE_IRSSI_PROXY),y)
22 IRSSI_CONF_OPTS += --with-proxy
23 # If shared libs are disabled, 'proxy' has to go in the list of built-in
24 # modules.
25 ifeq ($(BR2_STATIC_LIBS),y)
26 IRSSI_CONF_OPTS += --with-modules=proxy
27 endif
28 else
29 IRSSI_CONF_OPTS += --without-proxy
30 endif # proxy
32 ifeq ($(BR2_PACKAGE_IRSSI_TRUE_COLOR),y)
33 IRSSI_CONF_OPTS += --enable-true-color
34 else
35 IRSSI_CONF_OPTS += --disable-true-color
36 endif
38 # Cross-compiling irssi with the perl interpreter enabled doesn't work
39 # yet. So, remove scripts as they are useless in that case.
40 define IRSSI_REMOVE_SCRIPTS
41 rm -rf $(TARGET_DIR)/usr/share/irssi/scripts/
42 endef
44 IRSSI_POST_INSTALL_TARGET_HOOKS += IRSSI_REMOVE_SCRIPTS
46 $(eval $(autotools-package))