package/cwiid: add optional dependency to bluez5_utils
[buildroot-gz.git] / package / cwiid / cwiid.mk
blob5bccebe872769b69cb65db4a1be091c2505702d0
1 ################################################################################
3 # cwiid
5 ################################################################################
7 CWIID_VERSION = fadf11e89b579bcc0336a0692ac15c93785f3f82
8 CWIID_SITE = $(call github,abstrakraft,cwiid,$(CWIID_VERSION))
9 CWIID_LICENSE = GPLv2+
10 CWIID_LICENSE_FILES = COPYING
12 CWIID_AUTORECONF = YES
13 CWIID_INSTALL_STAGING = YES
15 CWIID_DEPENDENCIES = host-pkgconf host-bison host-flex
17 # Disable python support. This disables the 2 following things:
18 # - wminput Python plugin support
19 # - cwiid Python module
20 CWIID_CONF_OPTS = --without-python --disable-ldconfig
22 ifeq ($(BR2_PACKAGE_BLUEZ5_UTILS),y)
23 CWIID_DEPENDENCIES += bluez5_utils
24 else
25 CWIID_DEPENDENCIES += bluez_utils
26 endif
28 ifeq ($(BR2_PACKAGE_CWIID_WMGUI),y)
29 CWIID_DEPENDENCIES += libgtk2 libglib2
30 CWIID_CONF_OPTS += --enable-wmgui
31 else
32 CWIID_CONF_OPTS += --disable-wmgui
33 endif
35 $(eval $(autotools-package))