8 .
/usr
/share
/dpkg
/sh
/dpkg-error.sh
14 local origin
="$DPKG_ROOT/etc/dpkg/origins/default"
17 if [ -n "$DEB_VENDOR" ]; then
19 elif [ -e "$origin" ]; then
20 vendor
=$
(sed -ne 's/^Vendor: *\([^ ]\+\) */\1/p' "$origin" |
tr A-Z a-z
)
23 echo "${vendor:-default}"
26 check_merged_usr_via_aliased_dirs
()
34 # In Debian some people have gotten so offended by the following _warning_
35 # that they have resorted to bullying and abuse. Life's too short, sorry.
39 # Ubuntu does not seem interested in it.
44 for d
in /bin
/sbin
/lib
/lib32
/libo32
/libx32
/lib64
; do
45 linkname
="$(readlink $DPKG_ROOT$d || true)"
46 if [ "$linkname" = "usr$d" ] ||
[ "$linkname" = "/usr$d" ]; then
47 warning
"This system uses merged-usr-via-aliased-dirs, going behind dpkg's"
48 warning
"back, breaking its core assumptions. This can cause silent file"
49 warning
"overwrites and disappearances, and its general tools misbehavior."
50 warning
"See <https://wiki.debian.org/Teams/Dpkg/FAQ#broken-usrmerge>."
58 local prog
=start-stop-daemon
60 # Add a backward compatibility symlink alias for s-s-d, which is now
61 # installed in its canonical location.
62 if [ ! -f "$DPKG_ROOT/sbin/$prog" ]; then
63 ln -s "/usr/sbin/$prog" "$DPKG_ROOT/sbin/$prog"
69 check_merged_usr_via_aliased_dirs
72 abort-upgrade|abort-deconfigure|abort-remove
)
75 error
"called with unknown argument '$1'"
79 # Due to #932360 in debhelper we need to explicitly tell systemd to reload.
81 configure|abort-upgrade|abort-deconfigure|abort-remove
)
82 if [ -d /run
/systemd
/system
]; then
83 systemctl
--system daemon-reload
>/dev
/null || true