games-action/vintagestory: add 1.20.0_rc2, drop 1.20.0_rc1
[gentoo-zh.git] / media-gfx / unityhub / unityhub-3.10.0.ebuild
blob785a022a51d54d25796c4f4dfa1e5a3cd5ab2abb
1 # Copyright 2022-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit xdg desktop unpacker
8 DESCRIPTION="The official unity tool for manager Unity Engines and projects"
9 HOMEPAGE="https://unity.com/"
10 SRC_URI="https://hub.unity3d.com/linux/repos/deb/pool/main/u/unity/unityhub_amd64/${PN}-amd64-${PV}.deb"
11 S=${WORKDIR}
13 LICENSE="unity-EULA"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE="+appindicator legacy"
17 RESTRICT="mirror strip"
19 DEPEND="
20         appindicator? (
21                 dev-libs/libdbusmenu
22                 legacy? (
23                         dev-libs/libayatana-appindicator
24                         x11-misc/appmenu-gtk-module[gtk2]
25                 )
26         )
27         app-arch/cpio
28         dev-libs/nss
29         dev-util/lttng-ust:0/2.12
30         x11-libs/gtk+
31         app-crypt/libsecret
32         || ( <dev-libs/openssl-3 dev-libs/openssl-compat )
34 RDEPEND="${DEPEND}"
36 src_unpack(){
37         unpack_deb ${PN}-amd64-${PV}.deb
39 src_install(){
40         insinto "/opt"
41         doins -r "${S}/opt/unityhub"
42         dosym -r /opt/unityhub/unityhub /usr/bin/unityhub
43         for si in 16 32 48 64 128 256 512; do
44                 doicon -s ${si} usr/share/icons/hicolor/${si}x${si}/apps/${PN}.png
45         done
46         domenu "${WORKDIR}/usr/share/applications/unityhub.desktop"
47         fperms 0755 -R "/opt/unityhub"