1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
5 inherit go-module systemd
7 DESCRIPTION
="A DNS forwarder"
8 HOMEPAGE
="https://github.com/IrineSistiana/mosdns"
10 https://github.com/IrineSistiana/mosdns/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
11 https://github.com/peeweep/gentoo-go-deps/releases/download/${P}/${P}-vendor.tar.xz
16 KEYWORDS
="~amd64 ~arm64 ~riscv"
21 -X main.version=${PV} \
23 ego build
-o ${P} -trimpath -ldflags "${ldflags}"
24 .
/${P} config gen config.yaml
28 use systemd
&& systemd_dounit
"${FILESDIR}/mosdns.service"