1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit git-r3 meson xdg
8 DESCRIPTION
="A lightweight compositor for X11 (previously a compton fork)"
9 HOMEPAGE
="https://github.com/jonaburg/picom"
10 EGIT_REPO_URI
="https://github.com/jonaburg/picom.git"
14 IUSE
="+config-file dbus +doc +drm opengl pcre"
16 RDEPEND
="dev-libs/libev
22 x11-libs/xcb-util-image
23 x11-libs/xcb-util-renderutil
26 dev-libs/libxdg-basedir
28 dbus? ( sys-apps/dbus )
29 drm? ( x11-libs/libdrm )
30 opengl? ( virtual/opengl )
31 pcre? ( dev-libs/libpcre )
36 BDEPEND
="virtual/pkgconfig
37 doc? ( app-text/asciidoc )"
39 DOCS
=( README.md picom.sample.conf
)
43 $
(meson_use config-file config_file
)
45 $
(meson_use doc with_docs
)
47 $
(meson_use pcre regex
)