1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 inherit autotools flag-o-matic git-r3
8 DESCRIPTION="PCMan is a gtk+ based free BBS client"
9 HOMEPAGE="https://github.com/pcman-bbs/pcmanx"
11 EGIT_REPO_URI="https://github.com/pcman-bbs/pcmanx.git"
15 IUSE="+libnotify +proxy iplookup +wget"
18 libnotify? ( x11-libs/libnotify )
25 wget? ( net-misc/wget )
34 DOCS=( TODO README.md NEWS ChangeLog AUTHORS )
37 [[ ! -e ChangeLog && -e ./build/changelog.sh ]] && \
38 ./build/changelog.sh > ChangeLog
42 # this flag crashes CTermData::memset16()
43 filter-flags -ftree-vectorize
48 econf $(use_enable proxy) \
49 $(use_enable libnotify) \
51 $(use_enable iplookup)