remove ia64 keywords
[gentoo-zh.git] / app-shells / zsh-theme-powerlevel10k / zsh-theme-powerlevel10k-1.20.0.ebuild
blob7b329d99c86f4c93d1fdbe2b748d0395adceba3a
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 MY_PN="${PN##zsh-theme-}"
8 DESCRIPTION="Theme for Zsh that emphasizes speed, flexibility and out-of-the-box experience"
9 HOMEPAGE="https://github.com/romkatv/powerlevel10k"
10 SRC_URI="https://github.com/romkatv/powerlevel10k/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
16 DEPEND="app-shells/zsh
17 app-shells/gitstatus[zsh-completion]"
18 RDEPEND="${DEPEND}"
20 S="${WORKDIR}/${MY_PN}-${PV}"
22 src_prepare() {
23 sed -i Makefile -e '/gitstatus/d' || die
25 default
28 src_compile() {
29 emake pkg
32 src_install() {
33 dodoc {README,font}.md
35 insinto "/usr/share/zsh/site-functions/${MY_PN}"
37 doins -r config/
38 doins -r internal/
39 doins prompt_*_setup
40 doins powerlevel*.zsh-theme{,.zwc}
42 dosym ../../../gitstatus \
43 "/usr/share/zsh/site-functions/${MY_PN}/gitstatus"
46 pkg_postinst() {
47 elog "To use this theme, source /usr/share/zsh/site-functions/powerlevel10k/powerlevel10k.zsh-theme in your ~/.zshrc"
48 elog "The full choice of style options is available only when using Nerd Fonts. For example: media-fonts/nerd-fonts"