remove ia64 keywords
[gentoo-zh.git] / media-plugins / osdlyrics / osdlyrics-0.5.15.ebuild
blob329dcfea07564600bef756065ea67dbd108851de
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 PYTHON_COMPAT=( python3_{12..13} )
7 inherit python-r1 autotools optfeature xdg
9 DESCRIPTION="Standalone lyrics fetcher/displayer (windowed and OSD mode)."
10 HOMEPAGE="https://github.com/osdlyrics/osdlyrics"
12 LICENSE="GPL-3"
13 SLOT="0"
15 if [[ "${PV}" == 9999 ]]; then
16 inherit git-r3
17 EGIT_REPO_URI="https://github.com/osdlyrics/osdlyrics.git"
18 else
19 KEYWORDS="~amd64"
20 SRC_URI="https://github.com/osdlyrics/osdlyrics/archive/${PV}.tar.gz -> ${P}.tar.gz"
23 IUSE="gnome indicator"
24 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
26 RDEPEND="
27 ${PYTHON_DEPS}
28 x11-libs/libnotify
29 x11-libs/gtk+:2
30 x11-themes/hicolor-icon-theme
31 dev-libs/dbus-glib
32 dev-db/sqlite
33 dev-util/desktop-file-utils
34 dev-python/chardet[${PYTHON_USEDEP}]
35 dev-python/dbus-python[${PYTHON_USEDEP}]
36 dev-python/pygobject[${PYTHON_USEDEP}]
37 dev-python/pycurl[${PYTHON_USEDEP}]
38 gnome? ( dev-libs/gobject-introspection )
39 indicator? ( dev-libs/libayatana-appindicator )
42 DEPEND="
43 dev-util/intltool
44 dev-vcs/git
45 ${RDEPEND}
48 src_prepare() {
49 default
50 eautoreconf
51 python_copy_sources
54 src_configure() {
55 configuring() {
56 local myconf=(
57 --prefix="${EPREFIX}/usr" PYTHON="${PYTHON}"
58 $(use_enable indicator appindicator)
60 econf "${myconf[@]}"
62 python_foreach_impl run_in_build_dir configuring
65 src_compile() {
66 python_foreach_impl run_in_build_dir default
69 src_install() {
70 python_foreach_impl run_in_build_dir default
73 pkg_postinst() {
74 xdg_pkg_postinst
75 if has_version media-sound/mpd; then
76 optfeature "to interface with MPD" dev-python/python-mpd2