1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 USE_RUBY="ruby31 ruby32 ruby33"
8 RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
10 RUBY_FAKEGEM_TASK_TEST=""
12 RUBY_FAKEGEM_GEMSPEC="net-scp.gemspec"
16 DESCRIPTION="A pure Ruby implementation of the SCP client protocol"
17 HOMEPAGE="https://github.com/net-ssh/net-scp"
18 SRC_URI="https://github.com/net-ssh/net-scp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
22 KEYWORDS="amd64 ~arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
24 RESTRICT="!test? ( test )"
27 doc? ( dev-ruby/net-ssh:7 )
29 <dev-ruby/mocha-2.2.0:2
33 ruby_add_rdepend "dev-ruby/net-ssh:7"
36 sed -e "s:_relative ': './:" \
37 -e 's/git ls-files -z/find -print0/' \
38 -i ${RUBY_FAKEGEM_GEMSPEC} || die
40 sed -e '/mocha/ s/setup/test_unit/' \
41 -i test/common.rb || die
45 ${RUBY} -Ilib:test test/test_all.rb || die