3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
17 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
23 configure
: configure-stamp
26 # Add here commands to configure the package.
34 build-stamp
: configure-stamp
37 # Add here commands to compile the package.
39 #docbook-to-man debian/irreco-backend-telnet.sgml > irreco-backend-telnet.1
46 rm -f build-stamp configure-stamp
48 # Add here commands to clean up after the build process.
59 # Add here commands to install the package into debian/irreco-backend-telnet.
60 $(MAKE
) DESTDIR
=$(CURDIR
)/debian
/irreco-backend-telnet
install
63 # Build architecture-independent files here.
64 binary-indep
: build
install
65 # We have nothing to do by default.
67 # Build architecture-dependent files here.
68 binary-arch
: build
install
71 dh_installchangelogs ChangeLog
98 binary
: binary-indep binary-arch
99 .PHONY
: build
clean binary-indep binary-arch binary
install configure