dev-lua/luafilesystem: placate repoman
[lua-alt-overlay.git] / app-text / sile / sile-0.9.5.1-r1.ebuild
blob67e9ec1441bfa1a9b1a69c155de6a5d8589ae53b
1 # Copyright 1999-2019 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit autotools git-r3
8 DESCRIPTION="Simon's Improved Layout Engine "
9 HOMEPAGE="http://sile-typesetter.org"
10 EGIT_REPO_URI="https://github.com/simoncozens/sile"
11 EGIT_SUBMODULES=()
13 if [[ ${PV} == 9999 ]]
14 then
16 else
17 EGIT_COMMIT="v${PV}"
20 LICENSE="MIT"
21 SLOT="0"
22 KEYWORDS="~amd64 ~arm ~hppa ~sparc ~x86"
24 RDEPEND="
25 dev-libs/libtexpdf
26 dev-lua/lpeg
27 dev-lua/luaexpat
28 dev-lua/luafilesystem
29 dev-lua/luasocket
30 dev-lua/lua-zlib
33 src_prepare(){
34 default
35 eautoreconf
36 rm -rf vendor
39 src_configure() {
40 ECONF_SOURCE="${S}" econf \
41 --with-system-libtexpdf \
42 --with-system-lpeg \
43 --with-system-zlib \
44 --with-system-socket \
45 --with-system-filesystem \
46 --with-system-expat
49 src_install() {
50 emake DESTDIR="${D}" install