dev-lua/stdlib: add
[lua-alt-overlay.git] / dev-lua / bit32 / bit32-0.3.ebuild
blob669f59a0c1b9f16761f5fee0d88ba1af5fa19c69
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 # building fine, but not needed for Lua5.2 and Lua5.3
7 LUA_COMPAT=( lua5_1 luajit2 )
8 EGIT_REPO_URI="https://github.com/keplerproject/lua-compat-5.2"
9 EGIT_COMMIT="v${PV}"
11 inherit git-r3 lua-alt
13 DESCRIPTION="A Lua5.2+ bit manipulation library"
14 HOMEPAGE="https://github.com/keplerproject/lua-compat-5.2"
15 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
17 LICENSE="MIT"
18 SLOT="0"
19 IUSE=""
21 DOCS=(README.md)
23 src_prepare() {
24         cp "${FILESDIR}/Makefile" "${S}"
25         lua-alt_src_prepare
26         eapply_user