dev-lua/stdlib: add
[lua-alt-overlay.git] / dev-lua / epnf / epnf-0.3.ebuild
blob58edec2a254d59a39be1049fa5edce36ae8de9dd
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 LUA_COMPAT=( lua5_1 lua5_2 lua5_3 lua5_4 luajit2 )
7 inherit eutils git-r3 lua-alt
9 DESCRIPTION="The luaepnf module provides syntax sugar for defining LPeg grammars with error handling and AST building"
10 HOMEPAGE="http://siffiejoe.github.io/lua-luaepnf/"
11 EGIT_REPO_URI="https://github.com/siffiejoe/lua-luaepnf/"
12 if [[ ${PV} == 9999 ]]
13 then
14         :
15 else
16         EGIT_COMMIT="v${PV}"
17         KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
20 LICENSE="MIT"
21 SLOT="0"
22 DEPEND="${LUA_DEPS}
23         >=dev-lua/lpeg-0.8
24         virtual/pkgconfig
27 src_install() {
28         this_install() {
29                 insinto "${INSTALL_LMOD}/"
30                 doins "src/epnf.lua"
31         }
32         lua_foreach_impl this_install