dev-lua/stdlib: add
[lua-alt-overlay.git] / dev-lua / lua-cURLv3 / lua-cURLv3-0.3.11.ebuild
blob87333cbd5e05580fa638a86b537954d8be4c73ba
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 LUA_COMPAT=( lua5_1 lua5_2 lua5_3 lua5_4 luajit2 )
7 inherit lua-alt git-r3
9 DESCRIPTION="Lua binding to libcurl"
10 HOMEPAGE="https://github.com/Lua-cURL/Lua-cURLv3"
11 EGIT_REPO_URI="https://github.com/Lua-cURL/Lua-cURLv3"
13 if [[ ${PV} == 9999 ]]
14 then
15         :
16 else
17         EGIT_COMMIT="v${PV}"
18         KEYWORDS="~amd64 ~arm ~hppa ~sparc ~x86"
21 LICENSE="MIT"
22 SLOT="0"
23 IUSE=""
25 RDEPEND="${LUA_DEPS}
26         net-misc/curl"
27 DEPEND="${RDEPEND}
28         virtual/pkgconfig"
30 DOCS=( doc examples )
32 src_prepare() {
33         cp "${FILESDIR}/Makefile" "${S}"
34         lua-alt_src_prepare