dev-lua/stdlib: add
[lua-alt-overlay.git] / dev-lua / lua-term / lua-term-0.7.ebuild
blob4d8a23834ab205e2a229432b0913e07132cbe764
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 LUA_COMPAT=( lua5_1 lua5_2 lua5_3 lua5_4 luajit2 )
8 inherit lua-alt git-r3
10 DESCRIPTION="a Lua module for manipulating a terminal"
11 HOMEPAGE="https://github.com/hoelzro/lua-term"
12 EGIT_REPO_URI="https://github.com/hoelzro/lua-term"
14 if [[ "${PV}" == *999* ]]; then
15         :
16 else
17         EGIT_COMMIT="0.07"
18         KEYWORDS="~amd64"
21 LICENSE="MIT"
22 SLOT="0"
24 DEPEND="
25         ${LUA_DEPS}
27 RDEPEND="
28         ${DEPEND}
31 DOCS=(README.md)
33 src_prepare() {
34         cp "${FILESDIR}/Makefile" "${S}"
35         lua-alt_src_prepare