dev-lua/stdlib: add
[lua-alt-overlay.git] / dev-lua / lunajson / lunajson-1.2-r1.ebuild
blob039f40a74b84f1e9ee182e77e016ccc62ec9e5fe
1 # Copyright 1999-2019 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 LUA_COMPAT=( lua5_1 lua5_2 lua5_3 lua5_4 luajit2 )
8 inherit lua-alt git-r3
10 DESCRIPTION="A strict and fast JSON parser/decoder/encoder written in pure Lua."
11 HOMEPAGE="https://github.com/grafi-tt/lunajson"
12 EGIT_REPO_URI="https://github.com/grafi-tt/lunajson"
14 if [[ "${PV}" == *999* ]]; then
15         :
16 else
17         EGIT_COMMIT="${PV}"
18         KEYWORDS="~amd64"
21 LICENSE="MIT"
22 SLOT="0"
24 DEPEND="
25         ${LUA_DEPS}
27 RDEPEND="
28         ${DEPEND}
31 DOCS=(README.md)
33 src_install() {
34         this_install() {
35                 mkdir -p "${ED}/${INSTALL_LMOD}/lunajson"
36                 cp "${BUILD_DIR}/src/lunajson.lua" "${ED}/${INSTALL_LMOD}"
37                 cp "${BUILD_DIR}/src/lunajson/decoder.lua" "${ED}/${INSTALL_LMOD}/lunajson"
38                 cp "${BUILD_DIR}/src/lunajson/encoder.lua" "${ED}/${INSTALL_LMOD}/lunajson"
39                 cp "${BUILD_DIR}/src/lunajson/sax.lua" "${ED}/${INSTALL_LMOD}/lunajson"
40         }
41         lua_foreach_impl this_install