dev-lua/vstruct: add
[lua-alt-overlay.git] / app-text / sile / sile-0.9.5.1-r2.ebuild
blob23a19a2587d6a342e3f40783d57c1bab57e80ac5
1 # Copyright 1999-2019 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit autotools git-r3
8 DESCRIPTION="Simon's Improved Layout Engine "
9 HOMEPAGE="http://sile-typesetter.org"
10 EGIT_REPO_URI="https://github.com/simoncozens/sile"
11 EGIT_SUBMODULES=()
13 if [[ ${PV} == 9999 ]]
14 then
15         :
16 else
17         EGIT_COMMIT="v${PV}"
20 LICENSE="MIT"
21 SLOT="0"
22 KEYWORDS="~amd64 ~arm ~hppa ~sparc ~x86"
24 RDEPEND="
25         dev-libs/libtexpdf
26         dev-lua/lpeg
27         dev-lua/luaexpat
28         dev-lua/luafilesystem
29         dev-lua/luasec
30         dev-lua/luasocket
31         dev-lua/lua-zlib
34 src_prepare(){
35         default
36         eautoreconf
37         rm -rf vendor
40 src_configure() {
41         ECONF_SOURCE="${S}" econf \
42                 --with-system-libtexpdf \
43                 --with-system-lpeg \
44                 --with-system-zlib \
45                 --with-system-socket \
46                 --with-system-filesystem \
47                 --with-system-expat
50 src_install() {
51         emake DESTDIR="${D}" install