1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 LUA_COMPAT=( lua5_1 lua5_2 lua5_3 lua5_4 luajit2 )
7 inherit eutils git-r3 lua-alt
9 DESCRIPTION="This is a lua port of the cassowary constraint solving toolkit"
10 HOMEPAGE="https://github.com/sile-typesetter/cassowary.lua"
11 EGIT_REPO_URI="https://github.com/sile-typesetter/cassowary.lua"
12 if [[ ${PV} == 9999 ]]
17 KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
29 # When this upgrades to 2.3, you'll want
30 # insinto "${INSTALL_LMOD}/cassowary"
31 # doins "cassowary/init.lua"
33 insinto "${INSTALL_LMOD}"
36 lua_foreach_impl this_install