dev-lua/vstruct: add
[lua-alt-overlay.git] / dev-lua / cassowary / cassowary-2.2.ebuild
blobdd183e3514792c36d718373705b6329a9f9229fc
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 LUA_COMPAT=( lua5_1 lua5_2 lua5_3 lua5_4 luajit2 )
7 inherit eutils git-r3 lua-alt
9 DESCRIPTION="This is a lua port of the cassowary constraint solving toolkit"
10 HOMEPAGE="https://github.com/sile-typesetter/cassowary.lua"
11 EGIT_REPO_URI="https://github.com/sile-typesetter/cassowary.lua"
12 if [[ ${PV} == 9999 ]]
13 then
14         :
15 else
16         EGIT_COMMIT="v${PV}"
17         KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
20 LICENSE="Apache-2.0"
21 SLOT="0"
22 DEPEND="${LUA_DEPS}
23         dev-lua/penlight
24         virtual/pkgconfig
27 src_install() {
28         this_install() {
29                 # When this upgrades to 2.3, you'll want
30                 # insinto "${INSTALL_LMOD}/cassowary"
31                 # doins "cassowary/init.lua"
33                 insinto "${INSTALL_LMOD}"
34                 doins "cassowary.lua"
35         }
36         lua_foreach_impl this_install