1 # Copyright 1999-2020 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
6 LUA_COMPAT=( lua5_1 lua5_2 lua5_3 lua5_4 luajit2 )
9 DESCRIPTION="Stackable Continuation Queues"
10 HOMEPAGE="http://25thandclement.com/~william/projects/cqueues.html"
11 EGIT_REPO_URI="https://25thandClement.com/~william/projects/cqueues.git"
13 if [[ "${PV}" == *999* ]]; then
16 EGIT_COMMIT="rel-${PV}"
17 KEYWORDS="~amd64 ~arm ~x86"
29 DOCS=(doc/cqueues.pdf)
31 "${FILESDIR}/${P}-makefile.patch"
32 "${FILESDIR}/${P}-version-detection.patch"
33 "${FILESDIR}/${P}-no-pragma.patch"
34 "${FILESDIR}/${P}-5.3-deprecations.patch"
35 "${FILESDIR}/${P}-5.4-lua_resume.patch"
41 cp config.h.guess config.h
44 m4 errno.c.m4 > errno.c
47 cp config.h src/config.h
48 cp config.h src/lib/config.h