dev-lua/vstruct: add
[lua-alt-overlay.git] / dev-lua / cqueues / cqueues-20161215.ebuild
blob056591a83ec1737a25452ef3aa292b617ca6a30b
1 # Copyright 1999-2020 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 LUA_COMPAT=( lua5_1 lua5_2 lua5_3 lua5_4 luajit2 )
7 inherit lua-alt git-r3
9 DESCRIPTION="Stackable Continuation Queues"
10 HOMEPAGE="http://25thandclement.com/~william/projects/cqueues.html"
11 EGIT_REPO_URI="https://25thandClement.com/~william/projects/cqueues.git"
13 if [[ "${PV}" == *999* ]]; then
14         :
15 else
16         EGIT_COMMIT="rel-${PV}"
17         KEYWORDS="~amd64 ~arm ~x86"
20 LICENSE="MIT"
21 SLOT="0"
22 IUSE="doc examples"
24 DEPEND="
25         ${LUA_DEPS}
27 RDEPEND="${DEPEND}"
29 DOCS=(doc/cqueues.pdf)
30 PATCHES=(
31         "${FILESDIR}/${P}-makefile.patch"
32         "${FILESDIR}/${P}-version-detection.patch"
33         "${FILESDIR}/${P}-no-pragma.patch"
34         "${FILESDIR}/${P}-5.3-deprecations.patch"
35         "${FILESDIR}/${P}-5.4-lua_resume.patch"
38 src_prepare() {
39         eapply_user
41         cp config.h.guess config.h
43         pushd src
44         m4 errno.c.m4 > errno.c
45         popd
47         cp config.h src/config.h
48         cp config.h src/lib/config.h
50         lua-alt_src_prepare