dev-lua/vstruct: add
[lua-alt-overlay.git] / dev-lua / lgetopt / lgetopt-2.0.2-r1.ebuild
blob19a159ebd9a6d65c4906bf9d41d0a87c403ea8a3
1 # Copyright 1999-2019 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 LUA_COMPAT=( lua5_1 lua5_2 lua5_3 lua5_4 luajit2 )
7 inherit eutils git-r3 lua-alt
9 DESCRIPTION="lgetopt is a command-line argument parser for Lua 5.3."
10 HOMEPAGE="http://lgetopt.daelvn.ga"
11 EGIT_REPO_URI="https://github.com/daelvn/lgetopt"
12 if [[ ${PV} == 9999 ]]
13 then
14         :
15 else
16         EGIT_COMMIT="v${PV}"
17         KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
20 LICENSE="MIT"
21 SLOT="0"
22 DEPEND="${LUA_DEPS}
23         virtual/pkgconfig
26 src_install() {
27         this_install() {
28                 insinto "${INSTALL_LMOD}"
29                 doins lgetopt.lua
30         }
31         lua_foreach_impl this_install