1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 LUA_COMPAT=( lua5_1 lua5_2 lua5_3 lua5_4 luajit2 )
7 inherit eutils git-r3 lua-alt
9 DESCRIPTION="A reusable REPL component for Lua, written in Lua"
10 HOMEPAGE="https://github.com/hoelzro/lua-repl"
11 EGIT_REPO_URI="https://github.com/hoelzro/lua-repl"
12 if [[ ${PV} == 9999 ]]
17 KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
32 insinto "${INSTALL_LMOD}/repl"
34 doins "repl/utils.lua"
36 doins "repl/console.lua"
37 doins "repl/compat.lua"
39 insinto "${INSTALL_LMOD}/repl/plugins"
40 doins "repl/plugins/autoreturn.lua"
41 doins "repl/plugins/completion.lua"
42 doins "repl/plugins/example.lua"
43 doins "repl/plugins/history.lua"
44 doins "repl/plugins/keep_last_eval.lua"
45 doins "repl/plugins/linenoise.lua"
46 doins "repl/plugins/pretty_print.lua"
47 doins "repl/plugins/rcfile.lua"
48 doins "repl/plugins/semicolon_suppress_output.lua"
49 doins "repl/plugins/filename_completion.lua"
50 doins "repl/plugins/rlwrap.lua"
52 lua_foreach_impl this_install