dev-lua/luaexpat: bump to 1.3.3
[lua-alt-overlay.git] / dev-lua / luasec / luasec-0.9.ebuild
blob54655e41ae03f4795c728ea55573144ce0d4b6f1
1 # Copyright 1999-2019 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 LUA_COMPAT=( lua5_1 lua5_2 lua5_3 lua5_4 luajit2 )
7 inherit lua-alt git-r3
9 DESCRIPTION="LuaSec is a binding for OpenSSL library to provide TLS/SSL communication."
10 HOMEPAGE="https://github.com/brunoos/luasec/wiki"
11 EGIT_REPO_URI="https://github.com/brunoos/luasec"
12 if [[ ${PV} == 9999 ]]
13 then
14         :
15 else
16         EGIT_COMMIT="v${PV}"
17         KEYWORDS="~amd64 ~arm ~x86"
20 LICENSE="MIT"
21 SLOT="0"
22 IUSE="libressl"
24 RDEPEND="
25         ${LUA_DEPS}
26         dev-lua/luasocket
27         !libressl? ( dev-libs/openssl:0= )
28         libressl? ( dev-libs/libressl:0= )
30 DEPEND="
31         ${RDEPEND}
34 PATCHES=(
35         "${FILESDIR}/${P}-bad-cflags.patch"
38 src_compile() {
39         this_compile() {
40                 emake LD='$(CC)' LUAPATH="${INSTALL_LMOD}" LUACPATH="${INSTALL_CMOD}" linux
41         }
42         lua_foreach_impl this_compile
45 src_install() {
46         this_install() {
47                 emake DESTDIR="${D}" LUAPATH="${INSTALL_LMOD}" LUACPATH="${INSTALL_CMOD}" install
48         }
49         lua_foreach_impl this_install