1 # Copyright 1999-2019 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
6 LUA_COMPAT=( lua5_1 lua5_2 lua5_3 lua5_4 luajit2 )
9 DESCRIPTION="LuaSec is a binding for OpenSSL library to provide TLS/SSL communication."
10 HOMEPAGE="https://github.com/brunoos/luasec/wiki"
11 EGIT_REPO_URI="https://github.com/brunoos/luasec"
12 if [[ ${PV} == 9999 ]]
17 KEYWORDS="~amd64 ~arm ~x86"
27 !libressl? ( dev-libs/openssl:0= )
28 libressl? ( dev-libs/libressl:0= )
35 "${FILESDIR}/${P}-bad-cflags.patch"
40 emake LD='$(CC)' LUAPATH="${INSTALL_LMOD}" LUACPATH="${INSTALL_CMOD}" linux
42 lua_foreach_impl this_compile
47 emake DESTDIR="${D}" LUAPATH="${INSTALL_LMOD}" LUACPATH="${INSTALL_CMOD}" install
49 lua_foreach_impl this_install