22 hostname = config.networking.hostName;
26 www-urls = config.lib.wwwURLs or { };
28 get-url = url-or-attrs:
29 if ! isAttrs url-or-attrs then url-or-attrs
30 else url-or-attrs.url;
32 get-cfg = url-or-attrs:
33 if ! isAttrs url-or-attrs then ""
37 if k == "url" then acc
38 else acc + "${k} ${v};\n"
43 services.nginx = maybe' {
44 enable = trace "Nginx for www.func.xyz Enabled" true;
45 virtualHosts."www.func.xyz" = {
49 (location: url-or-attrs:
50 nameValuePair location {
51 proxyPass = "${get-url url-or-attrs}$is_args$args";
54 proxy_ssl_trusted_certificate ${pkgs.cacert}/etc/ssl/certs/ca-bundle.crt;
55 proxy_ssl_session_reuse on;
56 proxy_ssl_server_name on;
57 proxy_set_header Host $host;
58 proxy_set_header X-Real-IP $remote_addr;
59 proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
60 proxy_set_header X-Forwarded-Proto $scheme;
61 proxy_set_header X-Forwarded-Host $host;
62 proxy_set_header X-Forwarded-Server $host;
64 '' + get-cfg url-or-attrs;
69 security.acme = maybe' {
72 "www.func.xyz".email = "thomas.cat@func.xyz";