update dev300-m58
[ooovba.git] / package / util / makefile.mk
blob0b8d2d7604af07b021d7d645ddadaf965187813c
1 #*************************************************************************
3 # DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
4 #
5 # Copyright 2008 by Sun Microsystems, Inc.
7 # OpenOffice.org - a multi-platform office productivity suite
9 # $RCSfile: makefile.mk,v $
11 # $Revision: 1.13 $
13 # This file is part of OpenOffice.org.
15 # OpenOffice.org is free software: you can redistribute it and/or modify
16 # it under the terms of the GNU Lesser General Public License version 3
17 # only, as published by the Free Software Foundation.
19 # OpenOffice.org is distributed in the hope that it will be useful,
20 # but WITHOUT ANY WARRANTY; without even the implied warranty of
21 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
22 # GNU Lesser General Public License version 3 for more details
23 # (a copy is included in the LICENSE file that accompanied this code).
25 # You should have received a copy of the GNU Lesser General Public License
26 # version 3 along with OpenOffice.org. If not, see
27 # <http://www.openoffice.org/license.html>
28 # for a copy of the LGPLv3 License.
30 #*************************************************************************
32 # 2 == Unicode
33 MAJOR_VERSION=2
35 PRJ=..
36 PRJNAME=package
37 TARGET=package
39 ENABLE_EXCEPTIONS=TRUE
40 USE_DEFFILE=TRUE
41 NO_BSYMBOLIC=TRUE
44 # --- Settings -----------------------------------------------------
46 .INCLUDE : settings.mk
48 # --- General ----------------------------------------------------
50 LIB1TARGET= $(SLB)$/$(TARGET).lib
51 LIB1FILES= \
52 $(SLB)$/zipapi.lib \
53 $(SLB)$/zippackage.lib \
54 $(SLB)$/manifest.lib
56 # --- Shared-Library -----------------------------------------------
58 SHL1TARGET=$(TARGET)$(MAJOR_VERSION)
59 SHL1IMPLIB=i$(TARGET)
60 SHL1VERSIONMAP=$(SOLARENV)$/src$/component.map
62 SHL1STDLIBS=\
63 $(CPPULIB) \
64 $(UCBHELPERLIB) \
65 $(CPPUHELPERLIB) \
66 $(COMPHELPERLIB) \
67 $(SALLIB) \
68 $(ZLIB3RDLIB)
70 SHL1DEF=$(MISC)$/$(SHL1TARGET).def
71 SHL1LIBS=$(LIB1TARGET)
72 DEF1NAME=$(SHL1TARGET)
74 # --- Targets ----------------------------------------------------------
76 .INCLUDE : target.mk