Add app-i18n/yaft and media-fonts/tewi
[sgilles-overlay.git] / media-fonts / tewi-font / tewi-font-9999.ebuild
blob2b7babb39972859834fe9ad46432acb1ed1ae541
1 EAPI=6
3 PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
5 inherit font python-any-r1
7 DESCRIPTION="a bitmap font"
8 HOMEPAGE="https://github.com/lucy/tewi-font"
9 if [[ ${PV} != *9999* ]]; then
10         SRC_URI="https://github.com/lucy/tewi-font/archive/${PV}.tar.gz -> ${P}.tar.gz"
11         KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
12 else
13         EGIT_REPO_URI="https://github.com/lucy/tewi-font.git"
14         inherit git-r3
17 LICENSE="MIT"
18 SLOT="0"
20 IUSE="+pcf bdf"
22 DEPEND="
23         ${PYTHON_DEPS}
24         x11-libs/libX11
25         pcf? ( x11-apps/bdftopcf )"
26 RDEPEND="x11-libs/libX11"
28 src_compile() {
29         if use pcf; then
30                 emake
31         fi
33         if use bdf; then
34                 emake var
35         fi
38 src_install() {
39         insinto "/usr/share/fonts/${PN}"
40         if use pcf; then
41                 doins out/*
42         fi
44         if use bdf; then
45                 doins *.bdf
46         fi
47         font_src_install