Remove RDEPEND from tewi-font
[sgilles-overlay.git] / media-fonts / tewi-font / tewi-font-9999.ebuild
blobf227890a372f3f77a3199b1e58fc2dbeeabcbd6f
1 EAPI=6
3 PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
5 inherit font python-any-r1
7 DESCRIPTION="a bitmap font"
8 HOMEPAGE="https://github.com/lucy/tewi-font"
9 if [[ ${PV} != *9999* ]]; then
10         SRC_URI="https://github.com/lucy/tewi-font/archive/${PV}.tar.gz -> ${P}.tar.gz"
11         KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
12 else
13         EGIT_REPO_URI="https://github.com/lucy/tewi-font.git"
14         inherit git-r3
17 LICENSE="MIT"
18 SLOT="0"
20 IUSE="+pcf bdf"
22 DEPEND="
23         ${PYTHON_DEPS}
24         x11-libs/libX11
25         pcf? ( x11-apps/bdftopcf )"
27 src_compile() {
28         if use pcf; then
29                 emake
30         fi
32         if use bdf; then
33                 emake var
34         fi
37 src_install() {
38         insinto "/usr/share/fonts/${PN}"
39         if use pcf; then
40                 doins out/*
41         fi
43         if use bdf; then
44                 doins *.bdf
45         fi
46         font_src_install