2 # OBS SPEC file to generate a RPM for pidgin-sipe.
6 # RedHat family (CentOS, Fedora, RHEL, ScientificLinux)
7 # SUSE family (openSUSE, SLED, SLES)
9 # Windows (mingw32, mingw64)
13 %undefine build_telepathy
15 # Check for mingw32 cross compilation build
17 # Manually add this repository to your private OBS project:
19 # <repository name="mingw32">
20 # <path repository="openSUSE_13.2" project="windows:mingw:win32"/>
24 %if "
%{_repository}"
== "mingw32"
25 %define purple_sipe_mingw32
1
26 %define mingw_prefix mingw32
-
27 %define mingw_cache
%{_mingw32_cache}
28 %define mingw_configure
%{_mingw32_configure}
29 %define mingw_datadir
%{_mingw32_datadir}
30 %define mingw_debug_package
%{_mingw32_debug_package}
31 %define mingw_ldflags MINGW32_LDFLAGS
32 %define mingw_libdir
%{_mingw32_libdir}
33 %define mingw_make
%{_mingw32_make}
34 %define mingw_makeinstall
%{_mingw32_makeinstall}
35 %define __strip
%{_mingw32_strip}
36 %define __objdump
%{_mingw32_objdump}
37 %define _use_internal_dependency_generator
0
38 %define __find_requires
%{_mingw32_findrequires}
39 %define __find_provides
%{_mingw32_findprovides}
40 %define __os_install_post
%{_mingw32_debug_install_post} \
41 %{_mingw32_install_post}
44 # Check for mingw64 cross compilation build
46 # Manually add this repository to your private OBS project:
48 # <repository name="mingw64">
49 # <path repository="openSUSE_13.2" project="windows:mingw:win64"/>
53 %if "
%{_repository}"
== "mingw64"
54 %define purple_sipe_mingw64
1
55 %define mingw_prefix mingw64
-
56 %define mingw_cache
%{_mingw64_cache}
57 %define mingw_configure
%{_mingw64_configure}
58 %define mingw_datadir
%{_mingw64_datadir}
59 %define mingw_debug_package
%{_mingw64_debug_package}
60 %define mingw_ldflags MINGW64_LDFLAGS
61 %define mingw_libdir
%{_mingw64_libdir}
62 %define mingw_make
%{_mingw64_make}
63 %define mingw_makeinstall
%{_mingw64_makeinstall}
64 %define __strip
%{_mingw64_strip}
65 %define __objdump
%{_mingw64_objdump}
66 %define _use_internal_dependency_generator
0
67 %define __find_requires
%{_mingw64_findrequires}
68 %define __find_provides
%{_mingw64_findprovides}
69 %define __os_install_post
%{_mingw64_debug_install_post} \
70 %{_mingw64_install_post}
73 %define purple_plugin
%{?mingw_prefix:%{mingw_prefix}}libpurple
-plugin
-sipe
74 %define telepathy_plugin
%{?mingw_prefix:%{mingw_prefix}}telepathy
-plugin
-sipe
75 %define nsis_package
%{?mingw_prefix:%{mingw_prefix}}pidgin
-sipe
-nsis
76 %define common_files sipe
-common
77 %define empathy_files empathy
-sipe
78 %define ktp_files ktp
-accounts
-kcm
-sipe
81 %define has_make_install
1
85 # Mageia requires a lot of special case handling...
90 %define dbus_devel dbus
-1-devel
91 %define nss_develname mozilla
-nss
-devel
92 # SLES11 defines suse_version = 1110
93 %if 0%{?suse_version} > 1110
96 %define has_gstreamer
1
97 %define build_telepathy
1
98 %define nice_gstreamer gstreamer
-0_10
-libnice
100 %if 0%{?suse_version} >= 1315
101 %define has_gstreamer1
1
102 %define has_farstream
1
103 %undefine has_gstreamer
104 %undefine nice_gstreamer
108 %define nss_develname nss
-devel
111 %if 0%{?suse_version} || 0%{?sles_version}
112 %define pkg_group Productivity
/Networking
/Instant Messenger
114 %define pkg_group Applications
/Communications
117 # workaround for Fedora Rawhide
118 %if 0%{?fedora_version}
121 %define fedora
%{?fedora_version}
126 %define dbus_devel dbus
-devel
127 %define has_libnice
1
128 %define has_gstreamer
1
129 %define build_telepathy
1
131 %if 0%{?fedora} >= 20
132 %define has_farstream
1
133 %define nice_gstreamer libnice
-gstreamer
134 %if 0%{?fedora} >= 21
135 %define has_appdata
1
136 %define has_gssntlmssp
1
137 %if 0%{?fedora} >= 22
138 %define has_gstreamer1
1
139 %undefine has_gstreamer
140 %undefine nice_gstreamer
146 %if 0%{?centos_version} || 0%{?scientificlinux_version}
147 %define dbus_devel dbus
-devel
148 %define rhel_base_version
%{?centos_version}%{?scientificlinux_version}
149 %if %{rhel_base_version} < 600
150 %define has_make_install
0
152 %if %{rhel_base_version} >= 600
153 %define has_gstreamer
1
154 %define has_libnice
1
155 %if %{rhel_base_version} >= 700
156 # pidgin has been removed, but libpurple still exists
162 %if 0%{?purple_sipe_mingw32}
163 Name: mingw32
-pidgin
-sipe
165 %if 0%{?purple_sipe_mingw64}
166 Name: mingw64
-pidgin
-sipe
171 Summary: Pidgin protocol plugin to connect to MS Office Communicator
174 Source: pidgin
-sipe
-%{version}.tar.gz
177 URL: http
://sipe.sourceforge.net
/
179 BuildRoot: %{_tmppath}/%{name}-%{version}-build
181 %if 0%{?mingw_prefix:1}
183 # Windows cross-compilation build setup
186 #!BuildIgnore: post-build-checks
188 BuildRequires
: %{mingw_prefix}filesystem
>= 23
189 BuildRequires
: %{mingw_prefix}cross
-gcc
190 BuildRequires
: %{mingw_prefix}cross
-binutils
191 BuildRequires
: %{mingw_prefix}gettext
-runtime
192 BuildRequires
: %{mingw_prefix}cross
-pkg
-config
193 BuildRequires
: %{mingw_prefix}glib2
-devel
>= 2.18.0
194 BuildRequires
: %{mingw_prefix}libxml2
-devel
195 BuildRequires
: %{mingw_prefix}mozilla
-nss
-devel
196 BuildRequires
: %{mingw_prefix}libpurple
-devel
>= 2.4.0
197 BuildRequires
: %{mingw_prefix}cross
-nsis
199 # For directory ownership
200 BuildRequires
: %{mingw_prefix}pidgin
202 # Make sure telepathy is disabled for Windows builds
203 %undefine build_telepathy
207 # Standard Linux build setup
209 # Special case handling for Mageia
211 BuildRequires
: intltool
212 BuildRequires
: pkgconfig
(dbus
-1)
213 BuildRequires
: pkgconfig
(farstream
-0.2)
214 BuildRequires
: pkgconfig
(gio
-2.0)
215 BuildRequires
: pkgconfig
(glib
-2.0) >= 2.28.0
216 BuildRequires
: pkgconfig
(gstreamer
-1.0)
217 BuildRequires
: pkgconfig
(krb5
)
218 BuildRequires
: pkgconfig
(nice
)
219 BuildRequires
: pkgconfig
(nss
)
220 BuildRequires
: pkgconfig
(purple
)
221 BuildRequires
: pkgconfig
(libxml
-2.0)
223 # It seems linking against -lpurple is severely broken on Mageia...
224 BuildRequires
: pkgconfig
(libgadu
)
228 BuildRequires
: libpurple
-devel
>= 2.4.0
229 BuildRequires
: %{dbus_devel}
230 BuildRequires
: libxml2
-devel
231 BuildRequires
: %{nss_develname}
232 BuildRequires
: gettext
-devel
233 # The following two are required to enable Voice & Video features
234 %if 0%{?has_libnice:1}
235 BuildRequires
: libnice
-devel
236 %if 0%{?nice_gstreamer:1}
237 # Dependency required when gstreamer support is split into two packages
238 Requires: %{nice_gstreamer}
241 %if 0%{?has_gstreamer1:1}
242 BuildRequires
: pkgconfig
(gstreamer
-1.0)
244 %if 0%{?has_gstreamer:1}
245 BuildRequires
: pkgconfig
(gstreamer
-0.10)
248 %if 0%{?has_farstream:1}
249 BuildRequires
: pkgconfig
(farstream
-0.2)
250 BuildRequires
: pkgconfig
(gio
-2.0)
252 # Requirements for telepathy backend
253 %if 0%{?build_telepathy:1}
254 BuildRequires
: pkgconfig
(telepathy
-glib
) >= 0.18.0
255 BuildRequires
: pkgconfig
(gio
-2.0) >= 2.32.0
256 BuildRequires
: gmime
-devel
257 BuildRequires
: pkgconfig
(glib
-2.0) >= 2.32.0
260 # Configurable components
261 # Use "--without kerberos" to disable krb5
262 %if !0%{?_without_kerberos:1}
263 BuildRequires
: krb5
-devel
264 %if 0%{?has_gssntlmssp}
265 BuildRequires
: gssntlmssp
-devel
>= 0.5.0
266 Requires: gssntlmssp
>= 0.5.0
270 # For directory ownership
272 BuildRequires
: pidgin
275 %if 0%{?build_telepathy:1}
276 BuildRequires
: empathy
281 # End Windows cross-compilation/Linux build setup
284 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
285 BuildRequires
: libtool
286 BuildRequires
: intltool
287 BuildRequires
: glib2
-devel
>= 2.18.0
291 A third
-party plugin
for the Pidgin multi
-protocol instant messenger.
292 It implements the extended version of SIP
/SIMPLE used by various products
:
295 * Microsoft Office
365
296 * Microsoft Business Productivity Online Suite
(BPOS
)
297 * Microsoft Lync Server
298 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
299 * Microsoft Live Communications Server
(LCS
2003/2005)
301 With this plugin you should be able to replace your Microsoft Office
302 Communicator client with Pidgin.
304 This package provides the icon
set for Pidgin.
307 %package -n
%{purple_plugin}
308 Summary: Libpurple protocol plugin to connect to MS Office Communicator
311 Obsoletes
: purple
-sipe
312 %if 0%{?build_telepathy:1}
313 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
316 %description -n
%{purple_plugin}
317 A third
-party plugin
for the Pidgin multi
-protocol instant messenger.
318 It implements the extended version of SIP
/SIMPLE used by various products
:
321 * Microsoft Office
365
322 * Microsoft Business Productivity Online Suite
(BPOS
)
323 * Microsoft Lync Server
324 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
325 * Microsoft Live Communications Server
(LCS
2003/2005)
327 This package provides the protocol plugin
for libpurple clients.
330 %if 0%{?build_telepathy:1}
331 %package -n
%{empathy_files}
332 Summary: Telepathy connection manager to connect to MS Office Communicator
336 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
338 %description -n
%{empathy_files}
339 A Telepathy connection manager that implements the extended version of
340 SIP
/SIMPLE used by various products
:
343 * Microsoft Office
365
344 * Microsoft Business Productivity Online Suite
(BPOS
)
345 * Microsoft Lync Server
346 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
347 * Microsoft Live Communications Server
(LCS
2003/2005)
349 This package provides the icon
set for Empathy.
353 %package -n
%{ktp_files}
354 Summary: Telepathy connection manager to connect to MS Office Communicator
357 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
359 %description -n
%{ktp_files}
360 A Telepathy connection manager that implements the extended version of
361 SIP
/SIMPLE used by various products
:
364 * Microsoft Office
365
365 * Microsoft Business Productivity Online Suite
(BPOS
)
366 * Microsoft Lync Server
367 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
368 * Microsoft Live Communications Server
(LCS
2003/2005)
370 This package provides the profile
for KTP account manager.
374 %package -n
%{telepathy_plugin}
375 Summary: Telepathy connection manager to connect to MS Office Communicator
378 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
380 %description -n
%{telepathy_plugin}
381 A Telepathy connection manager that implements the extended version of
382 SIP
/SIMPLE used by various products
:
385 * Microsoft Office
365
386 * Microsoft Business Productivity Online Suite
(BPOS
)
387 * Microsoft Lync Server
388 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
389 * Microsoft Live Communications Server
(LCS
2003/2005)
391 This package provides the protocol support
for Telepathy clients.
394 %package -n
%{common_files}
395 Summary: Common files
for SIPE protocol plugins
400 %description -n
%{common_files}
401 This package provides common files
for the SIPE protocol plugins
:
407 %if 0%{?mingw_prefix:1}
408 %package -n
%{nsis_package}
409 Summary: Windows Pidgin protocol plugin to connect to MS Office Communicator
413 %description -n
%{nsis_package}
414 A third
-party plugin
for the Pidgin multi
-protocol instant messenger.
415 It implements the extended version of SIP
/SIMPLE used by various products
:
418 * Microsoft Office
365
419 * Microsoft Business Productivity Online Suite
(BPOS
)
420 * Microsoft Lync Server
421 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
422 * Microsoft Live Communications Server
(LCS
2003/2005)
424 This package contains the NSIS installer package of the protocol plugin
425 for Pidgin on Windows.
429 %{mingw_debug_package}
433 %setup -q
-n pidgin
-sipe
-%{version}
436 %if 0%{?mingw_prefix:1}
438 # Windows cross-compilation build
441 echo "lt_cv_deplibs_check_method
='pass_all'"
>>%{mingw_cache}
442 autoreconf
--verbose
--install --force
443 %{mingw_ldflags}="
-Wl
,--exclude
-libs
=libintl.a
-Wl
,--exclude
-libs
=libiconv.a
-lws2_32"
446 %if 0%{?build_telepathy:1}
451 %{mingw_make} %{?_smp_mflags} || %{mingw_make}
455 # Standard Linux build
457 # Special case handling for Mageia
468 %if !0%{?_without_kerberos:1}
472 %if 0%{?build_telepathy:1}
478 make %{?_smp_mflags} check
481 # End Windows cross-compilation/Linux build setup
486 %if 0%{?mingw_prefix:1}
488 # Windows cross-compilation install
491 rm -f
%{buildroot}%{mingw_libdir}/purple
-2/*.dll.a
493 # generate .dbgsym file
494 rm -f
%{buildroot}%{mingw_libdir}/purple
-2/libsipe.dll.dbgsym
496 %{buildroot}%{mingw_libdir}/purple
-2/libsipe.dll \
497 %{buildroot}%{mingw_libdir}/purple
-2/libsipe.dll.dbgsym
498 %{__strip} --strip
-unneeded \
499 %{buildroot}%{mingw_libdir}/purple
-2/libsipe.dll.dbgsym \
500 -o
%{buildroot}%{mingw_libdir}/purple
-2/libsipe.dll \
502 # generate NSIS installer package
503 perl contrib
/opensuse
-build
-service
/generate_nsi.pl po
/LINGUAS \
504 <contrib
/opensuse
-build
-service
/pidgin
-sipe.nsi.template \
505 >%{buildroot}/pidgin
-sipe.nsi
510 -DPIDGIN_VERSION
=UNKNOWN \
511 -DVERSION
=%{version} \
512 -DMINGW_LIBDIR
=%{buildroot}%{mingw_libdir} \
513 -DMINGW_DATADIR
=%{buildroot}%{mingw_datadir} \
516 rm -f
%{buildroot}/pidgin
-sipe.nsi
520 # Standard Linux install
522 %if 0%{?has_make_install}
528 # End Windows cross-compilation/Linux build setup
531 find
%{buildroot} -type f
-name "
*.la"
-delete
-print
532 # SLES11 defines suse_version = 1110
533 %if 0%{?suse_version} && 0%{?suse_version} < 1120
534 rm -r
%{buildroot}/%{_datadir}/pixmaps
/pidgin
/protocols
/scalable
536 # Pidgin doesn't have 24 or 32 pixel icons
538 %{buildroot}%{_datadir}/pixmaps
/pidgin
/protocols
/24/sipe.png \
539 %{buildroot}%{_datadir}/pixmaps
/pidgin
/protocols
/32/sipe.png
540 %if !0%{?has_appdata:1}
541 # We don't have AppStream, so we can't package metadata file at all
542 rm -r
%{buildroot}/%{_datadir}/appdata
545 # We don't have Pidgin, so we can't package icons at all
546 rm -r
%{buildroot}/%{_datadir}/pixmaps
/pidgin
548 %if 0%{?build_telepathy:1}
549 %if !0%{?build_ktp:1}
550 rm -r
%{buildroot}%{_datadir}/telepathy
553 %find_lang pidgin
-sipe
560 %if 0%{?build_telepathy:1}
561 %files -n
%{purple_plugin}
563 %files -n
%{purple_plugin} -f pidgin
-sipe.lang
565 %defattr(-,root
,root
,-)
566 %doc AUTHORS ChangeLog COPYING NEWS README TODO
567 %if 0%{?mingw_prefix:1}
568 %{mingw_libdir}/purple
-2/libsipe.dll
569 %{mingw_libdir}/purple
-2/libsipe.dll.dbgsym
571 %{_libdir}/purple
-2/libsipe.so
575 %if 0%{?build_telepathy:1}
576 %files -n
%{empathy_files}
577 %defattr(-,root
,root
,-)
578 %{_datadir}/empathy
/icons
/hicolor
/*/apps
/im
-sipe.png
579 %{_datadir}/empathy
/icons
/hicolor
/*/apps
/im
-sipe.svg
583 %files -n
%{ktp_files}
584 %defattr(-,root
,root
,-)
586 %{_datadir}/telepathy
/profiles
/sipe.profile
590 %files -n
%{telepathy_plugin}
591 %defattr(-,root
,root
,-)
592 %doc AUTHORS ChangeLog COPYING NEWS README TODO
593 %{_datadir}/dbus
-1/services
/*.sipe.service
594 %{_libexecdir}/telepathy
-sipe
597 %files -n
%{common_files} -f pidgin
-sipe.lang
598 %defattr(-,root
,root
,-)
603 %defattr(-,root
,root
,-)
605 %if 0%{?mingw_prefix:1}
606 %if 0%{?has_appdata:1}
607 %{mingw_datadir}/appdata
/pidgin
-sipe.metainfo.xml
609 %{mingw_datadir}/pixmaps
/pidgin
/protocols
/*/sipe.png
610 %{mingw_datadir}/pixmaps
/pidgin
/protocols
/*/sipe.svg
613 %if 0%{?has_appdata:1}
614 %{_datadir}/appdata/%{name}.metainfo.xml
616 %{_datadir}/pixmaps
/pidgin
/protocols
/*/sipe.png
617 # SLES11 defines suse_version = 1110
618 %if !0%{?suse_version} || 0%{?suse_version} >= 1120
619 %{_datadir}/pixmaps
/pidgin
/protocols
/*/sipe.svg
625 %if 0%{?mingw_prefix:1}
626 %files -n
%{nsis_package}
627 %defattr(-, root
, root
)
628 /pidgin
-sipe
-%{version}.exe
633 * DDD MMM DD
2017 J. D. User
<jduser@noreply.com
> 1.23.0
635 - raise BR glib
-2.0 >= 2.18.0
637 * Fri Aug
11 2017 J. D. User
<jduser@noreply.com
> 1.22.1-*git
*
639 - fix incorrect BR gstreamer
-0.10 when gstreamer
-1.0 is selected
641 * Sun Jun
11 2017 J. D. User
<jduser@noreply.com
> 1.22.1
644 * Wed Feb
01 2017 J. D. User
<jduser@noreply.com
> 1.22.0
647 * Sun Dec
18 2016 J. D. User
<jduser@noreply.com
> 1.21.1-*git
*
650 * Wed Jun
15 2016 J. D. User
<jduser@noreply.com
> 1.21.1-*git
*
651 - add BR farstream
-0.2
653 * Sat May
28 2016 J. D. User
<jduser@noreply.com
> 1.21.1
656 * Sat Apr
23 2016 J. D. User
<jduser@noreply.com
> 1.21.0
659 * Tue Apr
05 2016 J. D. User
<jduser@noreply.com
> 1.20.1-*git
*
660 - align with Fedora SPEC file
662 * Fri Jan
01 2016 J. D. User
<jduser@noreply.com
> 1.20.1-*git
*
663 - add AppStream metadata file
665 * Sun Nov
08 2015 J. D. User
<jduser@noreply.com
> 1.20.1-*git
*
666 - add dependency on pkgconfig
(gstreamer
-1.0) for F22
+ & Leap
42.1+
668 * Sat Oct
24 2015 J. D. User
<jduser@noreply.com
> 1.20.1
671 * Thu Sep
03 2015 J. D. User
<jduser@noreply.com
> 1.20.0-*git
*
672 - we also support "Skype
for Business"
674 * Sat Aug
29 2015 J. D. User
<jduser@noreply.com
> 1.20.0
677 * Sat Apr
04 2015 J. D. User
<jduser@noreply.com
> 1.19.1
680 * Sat Feb
07 2015 J. D. User
<jduser@noreply.com
> 1.19.0
683 * Tue Jan
06 2015 J. D. User
<jduser@noreply.com
> 1.18.5-*git
*
684 - add dependency on gssntlmssp
(-devel
) >= 0.5.0 for F21
+
686 * Mon Jan
05 2015 J. D. User
<jduser@noreply.com
> 1.18.5-*git
*
687 - remove support
for obsolete distributions
692 * Mon Dec
29 2014 J. D. User
<jduser@noreply.com
> 1.18.5
695 * Thu Dec
18 2014 J. D. User
<jduser@noreply.com
> 1.18.4-*git
*
696 - improve support
for CentOS
& Scientific Linux
698 * Sat Oct
18 2014 J. D. User
<jduser@noreply.com
> 1.18.4
701 * Sat Aug
16 2014 J. D. User
<jduser@noreply.com
> 1.18.3
704 * Sat Jun
07 2014 J. D. User
<jduser@noreply.com
> 1.18.2
707 * Sat Apr
12 2014 J. D. User
<jduser@noreply.com
> 1.18.1
710 * Tue Mar
04 2014 J. D. User
<jduser@noreply.com
> 1.18.0-*git
*
711 - F20
+/openSUSE
12.2+ require libnice gstreamer
-0.10 plugin
713 * Sat Jan
11 2014 J. D. User
<jduser@noreply.com
> 1.18.0
716 * Wed Dec
11 2013 J. D. User
<jduser@noreply.com
> 1.17.3
719 * Sat Nov
30 2013 J. D. User
<jduser@noreply.com
> 1.17.2
722 * Sat Nov
16 2013 J. D. User
<jduser@noreply.com
> 1.17.1
725 * Sat Sep
21 2013 J. D. User
<jduser@noreply.com
> 1.17.0
728 * Sat Jul
13 2013 J. D. User
<jduser@noreply.com
> 1.16.1
731 * Fri Jun
14 2013 J. D. User
<jduser@noreply.com
> 1.16.0
734 * Sun Apr
07 2013 J. D. User
<jduser@noreply.com
> 1.15.1
737 * Fri Mar
29 2013 J. D. User
<jduser@noreply.com
> 1.15.0-*git
*
738 - update package description texts
740 * Sat Mar
09 2013 J. D. User
<jduser@noreply.com
> 1.15.0
743 * Wed Dec
26 2012 J. D. User
<jduser@noreply.com
> 1.14.1
746 * Sun Dec
16 2012 J. D. User
<jduser@noreply.com
> 1.14.0
749 * Tue Sep
25 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
750 - change BR gstreamer
-devel to pkgconfig
(gstreamer
-0.10)
752 * Sun Sep
09 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
753 - BR telepathy
-glib
-devel
>= 0.18.0
755 * Wed Sep
05 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
756 - BR telepathy
-glib
-devel
>= 0.14.0
758 * Sun Sep
02 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
759 - really disable telepathy
for Windows cross
-compilation builds
761 * Thu Aug
30 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
762 - updates to
enable telepathy build
764 * Sun Aug
19 2012 J. D. User
<jduser@noreply.com
> 1.13.3
767 * Sun Jun
10 2012 J. D. User
<jduser@noreply.com
> 1.13.2
770 * Mon Apr
09 2012 J. D. User
<jduser@noreply.com
> 1.13.1
773 * Wed Mar
14 2012 J. D. User
<jduser@noreply.com
> 1.13.0
776 * Mon Dec
12 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
777 - we
do support Microsoft Lync Server
2010 now.
779 * Tue Dec
06 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
780 - update GPL2 license name
782 * Sat Nov
12 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
783 - add BR gmime
-devel
for Fedora to have at least one verification platform
785 * Sun Nov
06 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
786 - fix Mandriva
2011 unresolvable BR
788 * Mon Oct
31 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
791 * Sat Oct
01 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
792 - add NSIS package
for mingw builds
794 * Sat Oct
01 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
797 * Wed Sep
28 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
798 - remove BR mingw32
-mozilla
-nss
-devel
, not needed
for SSPI.
800 * Mon Sep
19 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
801 - update mingw32 build
802 - update descriptions
804 * Mon Aug
29 2011 J. D. User
<jduser@noreply.com
> 1.12.0
807 * Wed Jun
22 2011 J. D. User
<jduser@noreply.com
> 1.11.2-*git
*
808 - add gstreamer
-devel to
enable Voice
& Video features
810 * Sat Dec
11 2010 J. D. User
<jduser@noreply.com
> 1.11.2-*git
*
811 - add optional subpackage
for telepathy connection manager
813 * Tue Nov
02 2010 J. D. User
<jduser@noreply.com
> 1.11.2
816 * Sun Oct
24 2010 J. D. User
<jduser@noreply.com
> 1.11.1
819 * Fri Oct
15 2010 J. D. User
<jduser@noreply.com
> 1.11.0-*git
*
820 - add mingw32 build configuration
822 * Sun Oct
03 2010 J. D. User
<jduser@noreply.com
> 1.11.0
825 * Thu Sep
02 2010 J. D. User
<jduser@noreply.com
> pre
-1.11.0-*git
*
826 - Mandriva config
for OBS has changed
828 * Tue May
04 2010 J. D. User
<jduser@noreply.com
> 1.10.0-*git
*
829 - add libnice build information discovered through OBS testing
831 * Mon Apr
12 2010 J. D. User
<jduser@noreply.com
> 1.10.0-*git
*
832 - add NSS build information discovered through OBS testing
834 * Sun Apr
04 2010 pier11
<pier11@operamail.com
> 1.10.0
837 * Fri Apr
02 2010 J. D. User
<jduser@noreply.com
> pre
-1.10.0-*git
*
838 - Mandriva has too old libtool version
840 * Fri Apr
02 2010 J. D. User
<jduser@noreply.com
> pre
-1.10.0-*git
*
841 - SLE11
, openSUSE
11.0/1 don't have pidgin
/protocols
/scalable directory
843 * Thu Apr
01 2010 pier11
<pier11@operamail.com
> pre
-1.10.0-*git
*
844 - OBS tests of pre
-1.10.0 git
-snapshot
4fa20cd65e5be0e469d4aa55d861f11c5b08b816
846 * Sun Mar
28 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
847 - added
--enable/--disable build options
849 * Sun Mar
28 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
850 - removed
--with
-krb5 configure option as it is autodetected now
852 * Tue Mar
23 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
855 * Sat Mar
20 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
856 - add BR glib2
-devel
>= 2.12.0
858 * Wed Mar
17 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
861 * Tue Mar
16 2010 J. D. User
<jduser@noreply.com
> 1.9.1
864 * Thu Mar
11 2010 J. D. User
<jduser@noreply.com
> 1.9.0-*git
*
865 - add BR libxml2
-devel
867 * Wed Mar
10 2010 pier11
<pier11@operamail.com
> 1.9.0
869 - dropped SLE
10 due to libpurple min version increase
870 - updated target distros
in comment line
872 * Mon Mar
08 2010 J. D. User
<jduser@noreply.com
> 1.9.0-*git
*
873 - increased libpurple build requisite to
>= 2.4.0
875 * Sun Mar
07 2010 pier11
<pier11@operamail.com
> pre
-1.9.0-*git
*
876 - OBS tests of pre
-1.9.0 git
-snapshot
61ea0856855483b9e18f23a87afe47437e526f0e
878 * Sun Mar
07 2010 J. D. User
<jduser@noreply.com
> 1.8.1-*git
*
879 - sync with RPM SPEC from contrib
/rpm
881 * Mon Feb
08 2010 pier11
<pier11@operamail.com
> 1.8.0
882 - source is an original
1.8.0 with patch
: git
(upstream
) 9c34cc3557daa3d61a002002492c71d0343c8cae
883 - temp hack
- renamed
source in spec from .bz2 to .gz as the latter was prepared with the patch.
885 * Sun Nov
22 2009 pier11
<pier11@operamail.com
> 1.7.1
886 - reinstated
enable-quality
-check
888 * Wed Nov
04 2009 John Beranek
<john@redux.org.uk
> 1.7.0
889 - Spec file modifications to allow SLES
/D
10 and Mandriva
2009.1 builds
891 * Tue Nov
03 2009 John Beranek
<john@redux.org.uk
> 1.7.0
892 - Spec file modifications
for openSUSE build service
894 * Sun Oct
11 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
895 - move non
-Pidgin files to new sub
-package purple
-sipe
897 * Sun Oct
11 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
898 - remove directory
for emoticon theme icons
900 * Sun Oct
11 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
901 - libpurple protocol plugins are located under %
%{_libdir}/purple
-2
903 * Mon Sep
28 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
904 - added directory
for emoticon theme icons
906 * Wed Sep
09 2009 J. D. User
<jduser@noreply.com
> 1.6.3
909 * Fri Aug
28 2009 J. D. User
<jduser@noreply.com
> 1.6.2-*git
*
910 - reduce libpurple
-devel requirement to
>= 2.3.1
912 * Mon Aug
24 2009 J. D. User
<jduser@noreply.com
> 1.6.2
915 * Fri Aug
21 2009 J. D. User
<jduser@noreply.com
> 1.6.1-*git
*
916 - reduce libpurple
-devel requirement to
>= 2.4.1
918 * Mon Aug
17 2009 J. D. User
<jduser@noreply.com
> 1.6.1-*git
*
919 - com_err.h only required
for kerberos
921 * Tue Aug
11 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
922 - require libpurple
-devel
>= 2.5.0
924 * Sun Aug
09 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
925 - refactor configure parameters
926 - make kerberos configurable
927 - don't hard code prefix
for git builds
929 * Sun Aug
09 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
930 - removed unnecessary zlib
-devel
932 * Sat Aug
08 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
933 - fix prefix
for git builds
935 * Sat Aug
01 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
936 - append
-Wno
-unused
-parameter
for GCC
<4.4 compilation errors
938 * Thu Jul
30 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
939 - remove duplicate GPL2
941 * Thu Jul
30 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
942 - use "
--with git" to build from git
943 - corrected download
URL for release archive
944 - add missing BR gettext
-devel
946 * Wed Jul
29 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
947 - use default rpmbuild CFLAGS also
for git builds
948 - merge with SPEC files created by mricon
& jberanek
950 * Tue Jul
28 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
951 - initial RPM SPEC example generated