purple: update to latest 3.x.x xfer interfaces
[siplcs.git] / contrib / opensuse-build-service / pidgin-sipe.spec
blobe3a6635bae775636411db208ed6374ac711dd5b0
2 # OBS SPEC file to generate a RPM for pidgin-sipe.
4 # It has support for:
6 # RedHat family (CentOS, Fedora, RHEL, ScientificLinux)
7 # SUSE family (openSUSE, SLED, SLES)
8 # Mageia
9 # Windows (mingw32, mingw64)
12 # Build options
13 %undefine build_telepathy
15 # Check for mingw32 cross compilation build
17 # Manually add this repository to your private OBS project:
19 # <repository name="mingw32">
20 # <path repository="openSUSE_13.2" project="windows:mingw:win32"/>
21 # <arch>i586</arch>
22 # </repository>
24 %if "%{_repository}" == "mingw32"
25 %define purple_sipe_mingw32 1
26 %define mingw_prefix mingw32-
27 %define mingw_cache %{_mingw32_cache}
28 %define mingw_configure %{_mingw32_configure}
29 %define mingw_datadir %{_mingw32_datadir}
30 %define mingw_debug_package %{_mingw32_debug_package}
31 %define mingw_ldflags MINGW32_LDFLAGS
32 %define mingw_libdir %{_mingw32_libdir}
33 %define mingw_make %{_mingw32_make}
34 %define mingw_makeinstall %{_mingw32_makeinstall}
35 %define __strip %{_mingw32_strip}
36 %define __objdump %{_mingw32_objdump}
37 %define _use_internal_dependency_generator 0
38 %define __find_requires %{_mingw32_findrequires}
39 %define __find_provides %{_mingw32_findprovides}
40 %define __os_install_post %{_mingw32_debug_install_post} \
41 %{_mingw32_install_post}
42 %endif
44 # Check for mingw64 cross compilation build
46 # Manually add this repository to your private OBS project:
48 # <repository name="mingw64">
49 # <path repository="openSUSE_13.2" project="windows:mingw:win64"/>
50 # <arch>i586</arch>
51 # </repository>
53 %if "%{_repository}" == "mingw64"
54 %define purple_sipe_mingw64 1
55 %define mingw_prefix mingw64-
56 %define mingw_cache %{_mingw64_cache}
57 %define mingw_configure %{_mingw64_configure}
58 %define mingw_datadir %{_mingw64_datadir}
59 %define mingw_debug_package %{_mingw64_debug_package}
60 %define mingw_ldflags MINGW64_LDFLAGS
61 %define mingw_libdir %{_mingw64_libdir}
62 %define mingw_make %{_mingw64_make}
63 %define mingw_makeinstall %{_mingw64_makeinstall}
64 %define __strip %{_mingw64_strip}
65 %define __objdump %{_mingw64_objdump}
66 %define _use_internal_dependency_generator 0
67 %define __find_requires %{_mingw64_findrequires}
68 %define __find_provides %{_mingw64_findprovides}
69 %define __os_install_post %{_mingw64_debug_install_post} \
70 %{_mingw64_install_post}
71 %endif
73 %define purple_plugin %{?mingw_prefix:%{mingw_prefix}}libpurple-plugin-sipe
74 %define telepathy_plugin %{?mingw_prefix:%{mingw_prefix}}telepathy-plugin-sipe
75 %define nsis_package %{?mingw_prefix:%{mingw_prefix}}pidgin-sipe-nsis
76 %define common_files sipe-common
77 %define empathy_files empathy-sipe
78 %define ktp_files ktp-accounts-kcm-sipe
81 %if 0%{?mageia}
82 %if %{mageia} > 6
83 %define has_freerdp 1
84 %define has_gssntlmssp 1
85 %else
86 %define has_appstream_legacy 1
87 %endif
88 %define has_appstream 1
89 %define has_gstreamer 1
90 %endif
92 %if 0%{?suse_version}
93 %if 0%{?is_opensuse}
94 %define has_appstream 1
95 %define has_appstream_legacy 1
96 %if 0%{?suse_version} >= 1500
97 %define has_freerdp 1
98 %else
99 %define build_empathy 1
100 %endif
101 %endif
102 %define has_gstreamer 1
103 %define build_telepathy 1
104 %endif
106 %if 0%{?suse_version}
107 %define pkg_group Productivity/Networking/Instant Messenger
108 %else
109 %define pkg_group Applications/Communications
110 %endif
112 # workaround for Fedora Rawhide
113 %if 0%{?fedora_version}
114 %if 0%{?fedora}
115 %else
116 %define fedora %{?fedora_version}
117 %endif
118 %endif
120 %if 0%{?fedora}
121 %define has_appstream 1
122 %if %{fedora} <= 29
123 %define build_empathy 1
124 %endif
125 %if %{fedora} <= 26
126 %define has_appstream_legacy 1
127 %endif
128 %if %{fedora} > 25
129 %define has_freerdp 1
130 %endif
131 %define has_gssntlmssp 1
132 %define has_gstreamer 1
133 %define build_telepathy 1
134 %define build_ktp 1
135 %endif
137 %if 0%{?centos_version} || 0%{?scientificlinux_version}
138 %define has_krb5devel 1
139 %define rhel_base_version %{?centos_version}%{?scientificlinux_version}
140 %if %{rhel_base_version} >= 700
141 %define has_gstreamer 1
142 %endif
143 %endif
145 %if 0%{?purple_sipe_mingw32}
146 Name: mingw32-pidgin-sipe
147 %else
148 %if 0%{?purple_sipe_mingw64}
149 Name: mingw64-pidgin-sipe
150 %else
151 Name: pidgin-sipe
152 %endif
153 %endif
154 Summary: Pidgin protocol plugin to connect to MS Office Communicator
155 Version: 1.24.0
156 Release: 1
157 Source: pidgin-sipe-%{version}.tar.gz
158 Group: %{pkg_group}
159 License: GPL-2.0-or-later
160 URL: http://sipe.sourceforge.net/
162 BuildRoot: %{_tmppath}/%{name}-%{version}-build
164 %if 0%{?mingw_prefix:1}
166 # Windows cross-compilation build setup
168 BuildArch: noarch
169 #!BuildIgnore: post-build-checks
171 BuildRequires: libtool
172 BuildRequires: intltool
173 BuildRequires: %{mingw_prefix}filesystem >= 23
174 BuildRequires: %{mingw_prefix}cross-gcc
175 BuildRequires: %{mingw_prefix}cross-binutils
176 BuildRequires: %{mingw_prefix}gettext-runtime
177 BuildRequires: %{mingw_prefix}cross-pkg-config
178 BuildRequires: %{mingw_prefix}glib2-devel >= 2.18.0
179 BuildRequires: %{mingw_prefix}libxml2-devel
180 BuildRequires: %{mingw_prefix}mozilla-nss-devel
181 BuildRequires: %{mingw_prefix}libpurple-devel >= 2.7.0
182 BuildRequires: %{mingw_prefix}cross-nsis
184 # For directory ownership
185 BuildRequires: %{mingw_prefix}pidgin
187 # Make sure telepathy is disabled for Windows builds
188 %undefine build_telepathy
190 %else
192 # Standard Linux build setup
194 BuildRequires: gcc
195 BuildRequires: libtool
196 BuildRequires: intltool
197 BuildRequires: pkgconfig(dbus-1)
198 BuildRequires: pkgconfig(glib-2.0) >= 2.18.0
199 BuildRequires: pkgconfig(gmodule-2.0) >= 2.18.0
200 BuildRequires: pkgconfig(libxml-2.0)
201 BuildRequires: pkgconfig(nss)
202 BuildRequires: pkgconfig(purple) >= 2.7.0
203 %if 0%{?mageia}
204 # It seems linking against -lpurple is severely broken on Mageia...
205 BuildRequires: pkgconfig(libgadu)
206 %endif
207 %if 0%{?has_appstream:1}
208 %if 0%{?suse_version}
209 BuildRequires: AppStream
210 %else
211 BuildRequires: appstream
212 %endif
213 %endif
214 %if 0%{?has_gstreamer:1}
215 BuildRequires: pkgconfig(farstream-0.2)
216 BuildRequires: pkgconfig(gio-2.0)
217 BuildRequires: pkgconfig(gstreamer-1.0)
218 BuildRequires: pkgconfig(gstreamer-rtp-1.0)
219 BuildRequires: pkgconfig(nice) >= 0.1.0
220 # Requirements for appshare server
221 %if 0%{?has_freerdp:1}
222 BuildRequires: pkgconfig(freerdp-shadow2)
223 %endif
224 %endif
225 # Requirements for telepathy backend
226 %if 0%{?build_telepathy:1}
227 BuildRequires: gmime-devel
228 BuildRequires: pkgconfig(dbus-glib-1)
229 BuildRequires: pkgconfig(gio-2.0) >= 2.32.0
230 BuildRequires: pkgconfig(glib-2.0) >= 2.32.0
231 BuildRequires: pkgconfig(gobject-2.0)
232 BuildRequires: pkgconfig(telepathy-glib) >= 0.24.0
233 %endif
235 # Configurable components
236 # Use "--without kerberos" to disable krb5
237 %if !0%{?_without_kerberos:1}
238 %if 0%{?has_krb5devel:1}
239 BuildRequires: krb5-devel
240 %else
241 BuildRequires: pkgconfig(krb5)
242 %endif
243 %if 0%{?has_gssntlmssp:1}
244 BuildRequires: gssntlmssp-devel >= 0.5.0
245 Requires: gssntlmssp >= 0.5.0
246 %endif
247 %endif
249 # For directory ownership
250 BuildRequires: pidgin
251 Requires: pidgin
252 %if 0%{?build_telepathy:1}
253 %if 0%{?build_empathy:1}
254 BuildRequires: empathy
255 %endif
256 %endif
258 # End Windows cross-compilation/Linux build setup
259 %endif
261 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
264 %description
265 A third-party plugin for the Pidgin multi-protocol instant messenger.
266 It implements the extended version of SIP/SIMPLE used by various products:
268 * Skype for Business
269 * Microsoft Office 365
270 * Microsoft Business Productivity Online Suite (BPOS)
271 * Microsoft Lync Server
272 * Microsoft Office Communications Server (OCS 2007/2007 R2)
273 * Microsoft Live Communications Server (LCS 2003/2005)
275 With this plugin you should be able to replace your Microsoft Office
276 Communicator client with Pidgin.
278 This package provides the icon set for Pidgin.
281 %package -n %{purple_plugin}
282 Summary: Libpurple protocol plugin to connect to MS Office Communicator
283 Group: %{pkg_group}
284 License: GPL-2.0-or-later
285 Obsoletes: purple-sipe
286 %if 0%{?build_telepathy:1}
287 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
288 %endif
290 %description -n %{purple_plugin}
291 A third-party plugin for the Pidgin multi-protocol instant messenger.
292 It implements the extended version of SIP/SIMPLE used by various products:
294 * Skype for Business
295 * Microsoft Office 365
296 * Microsoft Business Productivity Online Suite (BPOS)
297 * Microsoft Lync Server
298 * Microsoft Office Communications Server (OCS 2007/2007 R2)
299 * Microsoft Live Communications Server (LCS 2003/2005)
301 This package provides the protocol plugin for libpurple clients.
304 %if 0%{?build_telepathy:1}
305 %if 0%{?build_empathy:1}
306 %package -n %{empathy_files}
307 Summary: Telepathy connection manager to connect to MS Office Communicator
308 Group: %{pkg_group}
309 License: GPL-2.0-or-later
310 Requires: empathy
311 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
313 %description -n %{empathy_files}
314 A Telepathy connection manager that implements the extended version of
315 SIP/SIMPLE used by various products:
317 * Skype for Business
318 * Microsoft Office 365
319 * Microsoft Business Productivity Online Suite (BPOS)
320 * Microsoft Lync Server
321 * Microsoft Office Communications Server (OCS 2007/2007 R2)
322 * Microsoft Live Communications Server (LCS 2003/2005)
324 This package provides the icon set for Empathy.
325 %endif
328 %if 0%{?build_ktp:1}
329 %package -n %{ktp_files}
330 Summary: Telepathy connection manager to connect to MS Office Communicator
331 Group: %{pkg_group}
332 License: GPL-2.0-or-later
333 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
335 %description -n %{ktp_files}
336 A Telepathy connection manager that implements the extended version of
337 SIP/SIMPLE used by various products:
339 * Skype for Business
340 * Microsoft Office 365
341 * Microsoft Business Productivity Online Suite (BPOS)
342 * Microsoft Lync Server
343 * Microsoft Office Communications Server (OCS 2007/2007 R2)
344 * Microsoft Live Communications Server (LCS 2003/2005)
346 This package provides the profile for KTP account manager.
347 %endif
350 %package -n %{telepathy_plugin}
351 Summary: Telepathy connection manager to connect to MS Office Communicator
352 Group: %{pkg_group}
353 License: GPL-2.0-or-later
354 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
356 %description -n %{telepathy_plugin}
357 A Telepathy connection manager that implements the extended version of
358 SIP/SIMPLE used by various products:
360 * Skype for Business
361 * Microsoft Office 365
362 * Microsoft Business Productivity Online Suite (BPOS)
363 * Microsoft Lync Server
364 * Microsoft Office Communications Server (OCS 2007/2007 R2)
365 * Microsoft Live Communications Server (LCS 2003/2005)
367 This package provides the protocol support for Telepathy clients.
370 %package -n %{common_files}
371 Summary: Common files for SIPE protocol plugins
372 Group: %{pkg_group}
373 License: GPL-2.0-or-later
374 BuildArch: noarch
376 %description -n %{common_files}
377 This package provides common files for the SIPE protocol plugins:
379 * Localisation
380 %endif
383 %if 0%{?mingw_prefix:1}
384 %package -n %{nsis_package}
385 Summary: Windows Pidgin protocol plugin to connect to MS Office Communicator
386 Group: %{pkg_group}
387 License: GPL-2.0-or-later
389 %description -n %{nsis_package}
390 A third-party plugin for the Pidgin multi-protocol instant messenger.
391 It implements the extended version of SIP/SIMPLE used by various products:
393 * Skype for Business
394 * Microsoft Office 365
395 * Microsoft Business Productivity Online Suite (BPOS)
396 * Microsoft Lync Server
397 * Microsoft Office Communications Server (OCS 2007/2007 R2)
398 * Microsoft Live Communications Server (LCS 2003/2005)
400 This package contains the NSIS installer package of the protocol plugin
401 for Pidgin on Windows.
402 %endif
405 %{mingw_debug_package}
408 %prep
409 %setup -q -n pidgin-sipe-%{version}
411 %build
412 %if 0%{?mingw_prefix:1}
414 # Windows cross-compilation build
416 %{?env_options}
417 echo "lt_cv_deplibs_check_method='pass_all'" >>%{mingw_cache}
418 autoreconf --verbose --install --force
419 %{mingw_ldflags}="-Wl,--exclude-libs=libintl.a -Wl,--exclude-libs=libiconv.a -lws2_32"
420 %{mingw_configure} \
421 --enable-purple \
422 %if 0%{?build_telepathy:1}
423 --enable-telepathy
424 %else
425 --disable-telepathy
426 %endif
427 %{mingw_make} %{?_smp_mflags} || %{mingw_make}
429 %else
431 # Standard Linux build
433 # Special case handling for Mageia
434 %if 0%{?mageia}
435 %configure2_5x \
436 --with-krb5 \
437 --disable-telepathy
438 %make_build
439 %make_build check
441 # All other Linuxes
442 %else
443 %configure \
444 %if !0%{?has_appstream:1}
445 --without-appstream \
446 %endif
447 %if !0%{?_without_kerberos:1}
448 --with-krb5 \
449 %endif
450 --enable-purple \
451 %if 0%{?build_telepathy:1}
452 --enable-telepathy
453 %else
454 --disable-telepathy
455 %endif
456 make %{?_smp_mflags}
457 make %{?_smp_mflags} check
458 %endif
460 # End Windows cross-compilation/Linux build setup
461 %endif
464 %install
465 %if 0%{?mingw_prefix:1}
467 # Windows cross-compilation install
469 %{mingw_makeinstall}
470 rm -f %{buildroot}%{mingw_libdir}/purple-2/*.dll.a
472 # generate .dbgsym file
473 rm -f %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym
474 mv \
475 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll \
476 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym
477 %{__strip} --strip-unneeded \
478 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym \
479 -o %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll \
481 # generate NSIS installer package
482 perl contrib/opensuse-build-service/generate_nsi.pl po/LINGUAS \
483 <contrib/opensuse-build-service/pidgin-sipe.nsi.template \
484 >%{buildroot}/pidgin-sipe.nsi
486 set -e; \
487 cd %{buildroot}; \
488 makensis \
489 -DPIDGIN_VERSION=UNKNOWN \
490 -DVERSION=%{version} \
491 -DMINGW_LIBDIR=%{buildroot}%{mingw_libdir} \
492 -DMINGW_DATADIR=%{buildroot}%{mingw_datadir} \
493 pidgin-sipe.nsi \
495 rm -f %{buildroot}/pidgin-sipe.nsi
497 %else
499 # Standard Linux install
501 %make_install
503 # End Windows cross-compilation/Linux build setup
504 %endif
506 find %{buildroot} -type f -name "*.la" -delete -print
507 # Pidgin doesn't have 24 or 32 pixel icons
508 rm -f \
509 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
510 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
511 %if 0%{?has_appstream_legacy:1}
512 mv %{buildroot}/%{_datadir}/metainfo %{buildroot}/%{_datadir}/appdata
513 %endif
514 %if 0%{?build_telepathy:1}
515 %if !0%{?build_empathy:1}
516 rm -r %{buildroot}%{_datadir}/empathy
517 %endif
518 %if !0%{?build_ktp:1}
519 rm -r %{buildroot}%{_datadir}/telepathy
520 %endif
521 %endif
522 %find_lang pidgin-sipe
525 %if 0%{?build_telepathy:1}
526 %files -n %{purple_plugin}
527 %else
528 %files -n %{purple_plugin} -f pidgin-sipe.lang
529 %endif
530 %defattr(-,root,root,-)
531 %doc AUTHORS ChangeLog COPYING NEWS README TODO
532 %if 0%{?mingw_prefix:1}
533 %{mingw_libdir}/purple-2/libsipe.dll
534 %{mingw_libdir}/purple-2/libsipe.dll.dbgsym
535 %else
536 %{_libdir}/purple-2/libsipe.so
537 %endif
540 %if 0%{?build_telepathy:1}
541 %if 0%{?build_empathy:1}
542 %files -n %{empathy_files}
543 %defattr(-,root,root,-)
544 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
545 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
546 %endif
549 %if 0%{?build_ktp:1}
550 %files -n %{ktp_files}
551 %defattr(-,root,root,-)
552 %doc AUTHORS COPYING
553 %{_datadir}/telepathy/profiles/sipe.profile
554 %endif
557 %files -n %{telepathy_plugin}
558 %defattr(-,root,root,-)
559 %doc AUTHORS ChangeLog COPYING NEWS README TODO
560 %{_datadir}/dbus-1/services/*.sipe.service
561 %{_libexecdir}/telepathy-sipe
564 %files -n %{common_files} -f pidgin-sipe.lang
565 %defattr(-,root,root,-)
566 %endif
569 %files
570 %defattr(-,root,root,-)
571 %doc AUTHORS COPYING
572 %if 0%{?mingw_prefix:1}
573 %if 0%{?has_appstream:1}
574 %{mingw_datadir}/metainfo/pidgin-sipe.metainfo.xml
575 %endif
576 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.png
577 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
578 %else
579 %if 0%{?has_appstream:1}
580 %if 0%{?has_appstream_legacy:1}
581 %{_datadir}/appdata/%{name}.metainfo.xml
582 %else
583 %{_datadir}/metainfo/%{name}.metainfo.xml
584 %endif
585 %endif
586 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
587 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
588 %endif
591 %if 0%{?mingw_prefix:1}
592 %files -n %{nsis_package}
593 %defattr(-, root, root)
594 /pidgin-sipe-%{version}.exe
595 %endif
598 %changelog
599 * Tue Jul 02 2019 J. D. User <jduser@noreply.com> 1.24.0-*git*
600 - add freerdp & gssntlmssp for Mageia 7+
602 * Sun Jun 30 2019 J. D. User <jduser@noreply.com> 1.24.0-*git*
603 - switch to SPDX identifier GPL-2.0-or-later
605 * Sun Jun 30 2019 J. D. User <jduser@noreply.com> 1.24.0-*git*
606 - newer distros no longer package empathy
608 * Sun Jun 30 2019 J. D. User <jduser@noreply.com> 1.24.0-*git*
609 - raise BR telepathy-glib >= 0.24.0
611 * Sat Nov 10 2018 J. D. User <jduser@noreply.com> 1.24.0
612 - update to 1.24.0
614 * Sat Sep 01 2018 J. D. User <jduser@noreply.com> 1.23.3-*git*
615 - update support for CentOS & Scientific Linux 7
617 * Mon Aug 27 2018 J. D. User <jduser@noreply.com> 1.23.3-*git*
618 - add BR freerdp-shadow2
620 * Mon Aug 20 2018 J. D. User <jduser@noreply.com> 1.23.3
621 - update to 1.23.3
623 * Sat Mar 10 2018 J. D. User <jduser@noreply.com> 1.23.2
624 - update to 1.23.2
626 * Sun Feb 25 2018 J. D. User <jduser@noreply.com> 1.23.1
627 - update to 1.23.1
629 * Sun Feb 18 2018 J. D. User <jduser@noreply.com> 1.23.0-*git*
630 - remove obsolete clean section
632 * Sun Feb 18 2018 J. D. User <jduser@noreply.com> 1.23.0-*git*
633 - add BR gcc
635 * Mon Nov 06 2017 J. D. User <jduser@noreply.com> 1.23.0-*git*
636 - add BR appstream
638 * Sun Nov 05 2017 J. D. User <jduser@noreply.com> 1.23.0-*git*
639 - add support for new AppStream metadata file location
641 * Sat Oct 28 2017 J. D. User <jduser@noreply.com> 1.23.0
642 - update to 1.23.0
643 - raise BR glib-2.0 >= 2.18.0
644 - raise BR purple >= 2.7.0
646 * Fri Aug 11 2017 J. D. User <jduser@noreply.com> 1.22.1-*git*
647 - add BR dbus-1
648 - fix incorrect BR gstreamer-0.10 when gstreamer-1.0 is selected
650 * Sun Jun 11 2017 J. D. User <jduser@noreply.com> 1.22.1
651 - update to 1.22.1
653 * Wed Feb 01 2017 J. D. User <jduser@noreply.com> 1.22.0
654 - update to 1.22.0
656 * Sun Dec 18 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
657 - add BR gio-2.0
659 * Wed Jun 15 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
660 - add BR farstream-0.2
662 * Sat May 28 2016 J. D. User <jduser@noreply.com> 1.21.1
663 - update to 1.21.1
665 * Sat Apr 23 2016 J. D. User <jduser@noreply.com> 1.21.0
666 - update to 1.21.0
668 * Tue Apr 05 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
669 - align with Fedora SPEC file
671 * Fri Jan 01 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
672 - add AppStream metadata file
674 * Sun Nov 08 2015 J. D. User <jduser@noreply.com> 1.20.1-*git*
675 - add dependency on pkgconfig(gstreamer-1.0) for F22+ & Leap 42.1+
677 * Sat Oct 24 2015 J. D. User <jduser@noreply.com> 1.20.1
678 - update to 1.20.1
680 * Thu Sep 03 2015 J. D. User <jduser@noreply.com> 1.20.0-*git*
681 - we also support "Skype for Business"
683 * Sat Aug 29 2015 J. D. User <jduser@noreply.com> 1.20.0
684 - update to 1.20.0
686 * Sat Apr 04 2015 J. D. User <jduser@noreply.com> 1.19.1
687 - update to 1.19.1
689 * Sat Feb 07 2015 J. D. User <jduser@noreply.com> 1.19.0
690 - update to 1.19.0
692 * Tue Jan 06 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
693 - add dependency on gssntlmssp(-devel) >= 0.5.0 for F21+
695 * Mon Jan 05 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
696 - remove support for obsolete distributions
697 - Fedora < 19
698 - Mandriva
699 - OpenSUSE < 13.x
701 * Mon Dec 29 2014 J. D. User <jduser@noreply.com> 1.18.5
702 - update to 1.18.5
704 * Thu Dec 18 2014 J. D. User <jduser@noreply.com> 1.18.4-*git*
705 - improve support for CentOS & Scientific Linux
707 * Sat Oct 18 2014 J. D. User <jduser@noreply.com> 1.18.4
708 - update to 1.18.4
710 * Sat Aug 16 2014 J. D. User <jduser@noreply.com> 1.18.3
711 - update to 1.18.3
713 * Sat Jun 07 2014 J. D. User <jduser@noreply.com> 1.18.2
714 - update to 1.18.2
716 * Sat Apr 12 2014 J. D. User <jduser@noreply.com> 1.18.1
717 - update to 1.18.1
719 * Tue Mar 04 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
720 - F20+/openSUSE 12.2+ require libnice gstreamer-0.10 plugin
722 * Sat Jan 11 2014 J. D. User <jduser@noreply.com> 1.18.0
723 - update to 1.18.0
725 * Wed Dec 11 2013 J. D. User <jduser@noreply.com> 1.17.3
726 - update to 1.17.3
728 * Sat Nov 30 2013 J. D. User <jduser@noreply.com> 1.17.2
729 - update to 1.17.2
731 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
732 - update to 1.17.1
734 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
735 - update to 1.17.0
737 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
738 - update to 1.16.1
740 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
741 - update to 1.16.0
743 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
744 - update to 1.15.1
746 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
747 - update package description texts
749 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
750 - update to 1.15.0
752 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
753 - update to 1.14.1
755 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
756 - update to 1.14.0
758 * Tue Sep 25 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
759 - change BR gstreamer-devel to pkgconfig(gstreamer-0.10)
761 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
762 - BR telepathy-glib-devel >= 0.18.0
764 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
765 - BR telepathy-glib-devel >= 0.14.0
767 * Sun Sep 02 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
768 - really disable telepathy for Windows cross-compilation builds
770 * Thu Aug 30 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
771 - updates to enable telepathy build
773 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
774 - update to 1.13.3
776 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
777 - update to 1.13.2
779 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
780 - update to 1.13.1
782 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
783 - update to 1.13.0
785 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
786 - we do support Microsoft Lync Server 2010 now.
788 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
789 - update GPL2 license name
791 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
792 - add BR gmime-devel for Fedora to have at least one verification platform
794 * Sun Nov 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
795 - fix Mandriva 2011 unresolvable BR
797 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
798 - add BR nss-devel
800 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
801 - add NSIS package for mingw builds
803 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
804 - add mingw64 build
806 * Wed Sep 28 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
807 - remove BR mingw32-mozilla-nss-devel, not needed for SSPI.
809 * Mon Sep 19 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
810 - update mingw32 build
811 - update descriptions
813 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
814 - update to 1.12.0
816 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
817 - add gstreamer-devel to enable Voice & Video features
819 * Sat Dec 11 2010 J. D. User <jduser@noreply.com> 1.11.2-*git*
820 - add optional subpackage for telepathy connection manager
822 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
823 - update to 1.11.2
825 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
826 - update to 1.11.1
828 * Fri Oct 15 2010 J. D. User <jduser@noreply.com> 1.11.0-*git*
829 - add mingw32 build configuration
831 * Sun Oct 03 2010 J. D. User <jduser@noreply.com> 1.11.0
832 - update to 1.11.0
834 * Thu Sep 02 2010 J. D. User <jduser@noreply.com> pre-1.11.0-*git*
835 - Mandriva config for OBS has changed
837 * Tue May 04 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
838 - add libnice build information discovered through OBS testing
840 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
841 - add NSS build information discovered through OBS testing
843 * Sun Apr 04 2010 pier11 <pier11@operamail.com> 1.10.0
844 - release
846 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
847 - Mandriva has too old libtool version
849 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
850 - SLE11, openSUSE 11.0/1 don't have pidgin/protocols/scalable directory
852 * Thu Apr 01 2010 pier11 <pier11@operamail.com> pre-1.10.0-*git*
853 - OBS tests of pre-1.10.0 git-snapshot 4fa20cd65e5be0e469d4aa55d861f11c5b08b816
855 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
856 - added --enable/--disable build options
858 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
859 - removed --with-krb5 configure option as it is autodetected now
861 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
862 - add SVG icon
864 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
865 - add BR glib2-devel >= 2.12.0
867 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
868 - add tests to build
870 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
871 - update to 1.9.1
873 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
874 - add BR libxml2-devel
876 * Wed Mar 10 2010 pier11 <pier11@operamail.com> 1.9.0
877 - release
878 - dropped SLE 10 due to libpurple min version increase
879 - updated target distros in comment line
881 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
882 - increased libpurple build requisite to >= 2.4.0
884 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.9.0-*git*
885 - OBS tests of pre-1.9.0 git-snapshot 61ea0856855483b9e18f23a87afe47437e526f0e
887 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
888 - sync with RPM SPEC from contrib/rpm
890 * Mon Feb 08 2010 pier11 <pier11@operamail.com> 1.8.0
891 - source is an original 1.8.0 with patch: git(upstream) 9c34cc3557daa3d61a002002492c71d0343c8cae
892 - temp hack - renamed source in spec from .bz2 to .gz as the latter was prepared with the patch.
894 * Sun Nov 22 2009 pier11 <pier11@operamail.com> 1.7.1
895 - reinstated enable-quality-check
897 * Wed Nov 04 2009 John Beranek <john@redux.org.uk> 1.7.0
898 - Spec file modifications to allow SLES/D 10 and Mandriva 2009.1 builds
900 * Tue Nov 03 2009 John Beranek <john@redux.org.uk> 1.7.0
901 - Spec file modifications for openSUSE build service
903 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
904 - move non-Pidgin files to new sub-package purple-sipe
906 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
907 - remove directory for emoticon theme icons
909 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
910 - libpurple protocol plugins are located under %%{_libdir}/purple-2
912 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
913 - added directory for emoticon theme icons
915 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
916 - update to 1.6.3
918 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
919 - reduce libpurple-devel requirement to >= 2.3.1
921 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
922 - update to 1.6.2
924 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
925 - reduce libpurple-devel requirement to >= 2.4.1
927 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
928 - com_err.h only required for kerberos
930 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
931 - require libpurple-devel >= 2.5.0
933 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
934 - refactor configure parameters
935 - make kerberos configurable
936 - don't hard code prefix for git builds
938 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
939 - removed unnecessary zlib-devel
941 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
942 - fix prefix for git builds
944 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
945 - append -Wno-unused-parameter for GCC <4.4 compilation errors
947 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
948 - remove duplicate GPL2
950 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
951 - use "--with git" to build from git
952 - corrected download URL for release archive
953 - add missing BR gettext-devel
955 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
956 - use default rpmbuild CFLAGS also for git builds
957 - merge with SPEC files created by mricon & jberanek
959 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
960 - initial RPM SPEC example generated