2 # OBS SPEC file to generate a RPM for pidgin-sipe.
6 # RedHat family (CentOS, Fedora, RHEL, ScientificLinux)
7 # SUSE family (openSUSE, SLED, SLES)
9 # Windows (mingw32, mingw64)
13 %undefine build_telepathy
15 # Check for mingw32 cross compilation build
17 # Manually add this repository to your private OBS project:
19 # <repository name="mingw32">
20 # <path repository="openSUSE_13.2" project="windows:mingw:win32"/>
24 %if "
%{_repository}"
== "mingw32"
25 %define purple_sipe_mingw32
1
26 %define mingw_prefix mingw32
-
27 %define mingw_cache
%{_mingw32_cache}
28 %define mingw_configure
%{_mingw32_configure}
29 %define mingw_datadir
%{_mingw32_datadir}
30 %define mingw_debug_package
%{_mingw32_debug_package}
31 %define mingw_ldflags MINGW32_LDFLAGS
32 %define mingw_libdir
%{_mingw32_libdir}
33 %define mingw_make
%{_mingw32_make}
34 %define mingw_makeinstall
%{_mingw32_makeinstall}
35 %define __strip
%{_mingw32_strip}
36 %define __objdump
%{_mingw32_objdump}
37 %define _use_internal_dependency_generator
0
38 %define __find_requires
%{_mingw32_findrequires}
39 %define __find_provides
%{_mingw32_findprovides}
40 %define __os_install_post
%{_mingw32_debug_install_post} \
41 %{_mingw32_install_post}
44 # Check for mingw64 cross compilation build
46 # Manually add this repository to your private OBS project:
48 # <repository name="mingw64">
49 # <path repository="openSUSE_13.2" project="windows:mingw:win64"/>
53 %if "
%{_repository}"
== "mingw64"
54 %define purple_sipe_mingw64
1
55 %define mingw_prefix mingw64
-
56 %define mingw_cache
%{_mingw64_cache}
57 %define mingw_configure
%{_mingw64_configure}
58 %define mingw_datadir
%{_mingw64_datadir}
59 %define mingw_debug_package
%{_mingw64_debug_package}
60 %define mingw_ldflags MINGW64_LDFLAGS
61 %define mingw_libdir
%{_mingw64_libdir}
62 %define mingw_make
%{_mingw64_make}
63 %define mingw_makeinstall
%{_mingw64_makeinstall}
64 %define __strip
%{_mingw64_strip}
65 %define __objdump
%{_mingw64_objdump}
66 %define _use_internal_dependency_generator
0
67 %define __find_requires
%{_mingw64_findrequires}
68 %define __find_provides
%{_mingw64_findprovides}
69 %define __os_install_post
%{_mingw64_debug_install_post} \
70 %{_mingw64_install_post}
73 %define purple_plugin
%{?mingw_prefix:%{mingw_prefix}}libpurple
-plugin
-sipe
74 %define telepathy_plugin
%{?mingw_prefix:%{mingw_prefix}}telepathy
-plugin
-sipe
75 %define nsis_package
%{?mingw_prefix:%{mingw_prefix}}pidgin
-sipe
-nsis
76 %define common_files sipe
-common
77 %define empathy_files empathy
-sipe
78 %define ktp_files ktp
-accounts
-kcm
-sipe
84 %define has_appstream
1
85 %define has_appstream_legacy
1
86 %define has_gstreamer
1
91 %define has_appstream
1
92 %define has_appstream_legacy
1
94 %define has_gstreamer
1
95 %define build_telepathy
1
99 %define pkg_group Productivity
/Networking
/Instant Messenger
101 %define pkg_group Applications
/Communications
104 # workaround for Fedora Rawhide
105 %if 0%{?fedora_version}
108 %define fedora
%{?fedora_version}
113 %define has_appstream
1
115 %define has_appstream_legacy
1
117 %define has_gssntlmssp
1
118 %define has_gstreamer
1
119 %define build_telepathy
1
123 %if 0%{?centos_version} || 0%{?scientificlinux_version}
124 %define has_krb5devel
1
125 %define rhel_base_version
%{?centos_version}%{?scientificlinux_version}
126 %if %{rhel_base_version} >= 700
127 # pidgin has been removed, but libpurple still exists
132 %if 0%{?purple_sipe_mingw32}
133 Name: mingw32
-pidgin
-sipe
135 %if 0%{?purple_sipe_mingw64}
136 Name: mingw64
-pidgin
-sipe
141 Summary: Pidgin protocol plugin to connect to MS Office Communicator
144 Source: pidgin
-sipe
-%{version}.tar.gz
147 URL: http
://sipe.sourceforge.net
/
149 BuildRoot: %{_tmppath}/%{name}-%{version}-build
151 %if 0%{?mingw_prefix:1}
153 # Windows cross-compilation build setup
156 #!BuildIgnore: post-build-checks
158 BuildRequires
: libtool
159 BuildRequires
: intltool
160 BuildRequires
: %{mingw_prefix}filesystem
>= 23
161 BuildRequires
: %{mingw_prefix}cross
-gcc
162 BuildRequires
: %{mingw_prefix}cross
-binutils
163 BuildRequires
: %{mingw_prefix}gettext
-runtime
164 BuildRequires
: %{mingw_prefix}cross
-pkg
-config
165 BuildRequires
: %{mingw_prefix}glib2
-devel
>= 2.18.0
166 BuildRequires
: %{mingw_prefix}libxml2
-devel
167 BuildRequires
: %{mingw_prefix}mozilla
-nss
-devel
168 BuildRequires
: %{mingw_prefix}libpurple
-devel
>= 2.7.0
169 BuildRequires
: %{mingw_prefix}cross
-nsis
171 # For directory ownership
172 BuildRequires
: %{mingw_prefix}pidgin
174 # Make sure telepathy is disabled for Windows builds
175 %undefine build_telepathy
179 # Standard Linux build setup
182 BuildRequires
: libtool
183 BuildRequires
: intltool
184 BuildRequires
: pkgconfig
(dbus
-1)
185 BuildRequires
: pkgconfig
(glib
-2.0) >= 2.18.0
186 BuildRequires
: pkgconfig
(gmodule
-2.0) >= 2.18.0
187 BuildRequires
: pkgconfig
(libxml
-2.0)
188 BuildRequires
: pkgconfig
(nss
)
189 BuildRequires
: pkgconfig
(purple
) >= 2.7.0
191 # It seems linking against -lpurple is severely broken on Mageia...
192 BuildRequires
: pkgconfig
(libgadu
)
194 %if 0%{?has_appstream:1}
195 %if 0%{?suse_version}
196 BuildRequires
: AppStream
198 BuildRequires
: appstream
201 %if 0%{?has_gstreamer:1}
202 BuildRequires
: pkgconfig
(farstream
-0.2)
203 BuildRequires
: pkgconfig
(gio
-2.0)
204 BuildRequires
: pkgconfig
(gstreamer
-1.0)
205 BuildRequires
: pkgconfig
(gstreamer
-rtp
-1.0)
206 BuildRequires
: pkgconfig
(nice
) >= 0.1.0
208 # Requirements for telepathy backend
209 %if 0%{?build_telepathy:1}
210 BuildRequires
: gmime
-devel
211 BuildRequires
: pkgconfig
(dbus
-glib
-1)
212 BuildRequires
: pkgconfig
(gio
-2.0) >= 2.32.0
213 BuildRequires
: pkgconfig
(glib
-2.0) >= 2.32.0
214 BuildRequires
: pkgconfig
(gobject
-2.0)
215 BuildRequires
: pkgconfig
(telepathy
-glib
) >= 0.18.0
218 # Configurable components
219 # Use "--without kerberos" to disable krb5
220 %if !0%{?_without_kerberos:1}
221 %if 0%{?has_krb5devel:1}
222 BuildRequires
: krb5
-devel
224 BuildRequires
: pkgconfig
(krb5
)
226 %if 0%{?has_gssntlmssp:1}
227 BuildRequires
: gssntlmssp
-devel
>= 0.5.0
228 Requires: gssntlmssp
>= 0.5.0
232 # For directory ownership
234 BuildRequires
: pidgin
237 %if 0%{?build_telepathy:1}
238 BuildRequires
: empathy
241 # End Windows cross-compilation/Linux build setup
244 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
248 A third
-party plugin
for the Pidgin multi
-protocol instant messenger.
249 It implements the extended version of SIP
/SIMPLE used by various products
:
252 * Microsoft Office
365
253 * Microsoft Business Productivity Online Suite
(BPOS
)
254 * Microsoft Lync Server
255 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
256 * Microsoft Live Communications Server
(LCS
2003/2005)
258 With this plugin you should be able to replace your Microsoft Office
259 Communicator client with Pidgin.
261 This package provides the icon
set for Pidgin.
264 %package -n
%{purple_plugin}
265 Summary: Libpurple protocol plugin to connect to MS Office Communicator
268 Obsoletes
: purple
-sipe
269 %if 0%{?build_telepathy:1}
270 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
273 %description -n
%{purple_plugin}
274 A third
-party plugin
for the Pidgin multi
-protocol instant messenger.
275 It implements the extended version of SIP
/SIMPLE used by various products
:
278 * Microsoft Office
365
279 * Microsoft Business Productivity Online Suite
(BPOS
)
280 * Microsoft Lync Server
281 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
282 * Microsoft Live Communications Server
(LCS
2003/2005)
284 This package provides the protocol plugin
for libpurple clients.
287 %if 0%{?build_telepathy:1}
288 %package -n
%{empathy_files}
289 Summary: Telepathy connection manager to connect to MS Office Communicator
293 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
295 %description -n
%{empathy_files}
296 A Telepathy connection manager that implements the extended version of
297 SIP
/SIMPLE used by various products
:
300 * Microsoft Office
365
301 * Microsoft Business Productivity Online Suite
(BPOS
)
302 * Microsoft Lync Server
303 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
304 * Microsoft Live Communications Server
(LCS
2003/2005)
306 This package provides the icon
set for Empathy.
310 %package -n
%{ktp_files}
311 Summary: Telepathy connection manager to connect to MS Office Communicator
314 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
316 %description -n
%{ktp_files}
317 A Telepathy connection manager that implements the extended version of
318 SIP
/SIMPLE used by various products
:
321 * Microsoft Office
365
322 * Microsoft Business Productivity Online Suite
(BPOS
)
323 * Microsoft Lync Server
324 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
325 * Microsoft Live Communications Server
(LCS
2003/2005)
327 This package provides the profile
for KTP account manager.
331 %package -n
%{telepathy_plugin}
332 Summary: Telepathy connection manager to connect to MS Office Communicator
335 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
337 %description -n
%{telepathy_plugin}
338 A Telepathy connection manager that implements the extended version of
339 SIP
/SIMPLE used by various products
:
342 * Microsoft Office
365
343 * Microsoft Business Productivity Online Suite
(BPOS
)
344 * Microsoft Lync Server
345 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
346 * Microsoft Live Communications Server
(LCS
2003/2005)
348 This package provides the protocol support
for Telepathy clients.
351 %package -n
%{common_files}
352 Summary: Common files
for SIPE protocol plugins
357 %description -n
%{common_files}
358 This package provides common files
for the SIPE protocol plugins
:
364 %if 0%{?mingw_prefix:1}
365 %package -n
%{nsis_package}
366 Summary: Windows Pidgin protocol plugin to connect to MS Office Communicator
370 %description -n
%{nsis_package}
371 A third
-party plugin
for the Pidgin multi
-protocol instant messenger.
372 It implements the extended version of SIP
/SIMPLE used by various products
:
375 * Microsoft Office
365
376 * Microsoft Business Productivity Online Suite
(BPOS
)
377 * Microsoft Lync Server
378 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
379 * Microsoft Live Communications Server
(LCS
2003/2005)
381 This package contains the NSIS installer package of the protocol plugin
382 for Pidgin on Windows.
386 %{mingw_debug_package}
390 %setup -q
-n pidgin
-sipe
-%{version}
393 %if 0%{?mingw_prefix:1}
395 # Windows cross-compilation build
398 echo "lt_cv_deplibs_check_method
='pass_all'"
>>%{mingw_cache}
399 autoreconf
--verbose
--install --force
400 %{mingw_ldflags}="
-Wl
,--exclude
-libs
=libintl.a
-Wl
,--exclude
-libs
=libiconv.a
-lws2_32"
403 %if 0%{?build_telepathy:1}
408 %{mingw_make} %{?_smp_mflags} || %{mingw_make}
412 # Standard Linux build
414 # Special case handling for Mageia
425 %if !0%{?has_appstream:1}
426 --without
-appstream \
428 %if !0%{?_without_kerberos:1}
432 %if 0%{?build_telepathy:1}
438 make %{?_smp_mflags} check
441 # End Windows cross-compilation/Linux build setup
446 %if 0%{?mingw_prefix:1}
448 # Windows cross-compilation install
451 rm -f
%{buildroot}%{mingw_libdir}/purple
-2/*.dll.a
453 # generate .dbgsym file
454 rm -f
%{buildroot}%{mingw_libdir}/purple
-2/libsipe.dll.dbgsym
456 %{buildroot}%{mingw_libdir}/purple
-2/libsipe.dll \
457 %{buildroot}%{mingw_libdir}/purple
-2/libsipe.dll.dbgsym
458 %{__strip} --strip
-unneeded \
459 %{buildroot}%{mingw_libdir}/purple
-2/libsipe.dll.dbgsym \
460 -o
%{buildroot}%{mingw_libdir}/purple
-2/libsipe.dll \
462 # generate NSIS installer package
463 perl contrib
/opensuse
-build
-service
/generate_nsi.pl po
/LINGUAS \
464 <contrib
/opensuse
-build
-service
/pidgin
-sipe.nsi.template \
465 >%{buildroot}/pidgin
-sipe.nsi
470 -DPIDGIN_VERSION
=UNKNOWN \
471 -DVERSION
=%{version} \
472 -DMINGW_LIBDIR
=%{buildroot}%{mingw_libdir} \
473 -DMINGW_DATADIR
=%{buildroot}%{mingw_datadir} \
476 rm -f
%{buildroot}/pidgin
-sipe.nsi
480 # Standard Linux install
484 # End Windows cross-compilation/Linux build setup
487 find
%{buildroot} -type f
-name "
*.la"
-delete
-print
488 # Pidgin doesn't have 24 or 32 pixel icons
490 %{buildroot}%{_datadir}/pixmaps
/pidgin
/protocols
/24/sipe.png \
491 %{buildroot}%{_datadir}/pixmaps
/pidgin
/protocols
/32/sipe.png
492 %if 0%{?has_appstream_legacy:1}
493 mv
%{buildroot}/%{_datadir}/metainfo %{buildroot}/%{_datadir}/appdata
496 # We don't have Pidgin, so we can't package icons at all
497 rm -r
%{buildroot}/%{_datadir}/pixmaps
/pidgin
499 %if 0%{?build_telepathy:1}
500 %if !0%{?build_ktp:1}
501 rm -r
%{buildroot}%{_datadir}/telepathy
504 %find_lang pidgin
-sipe
507 %if 0%{?build_telepathy:1}
508 %files -n
%{purple_plugin}
510 %files -n
%{purple_plugin} -f pidgin
-sipe.lang
512 %defattr(-,root
,root
,-)
513 %doc AUTHORS ChangeLog COPYING NEWS README TODO
514 %if 0%{?mingw_prefix:1}
515 %{mingw_libdir}/purple
-2/libsipe.dll
516 %{mingw_libdir}/purple
-2/libsipe.dll.dbgsym
518 %{_libdir}/purple
-2/libsipe.so
522 %if 0%{?build_telepathy:1}
523 %files -n
%{empathy_files}
524 %defattr(-,root
,root
,-)
525 %{_datadir}/empathy
/icons
/hicolor
/*/apps
/im
-sipe.png
526 %{_datadir}/empathy
/icons
/hicolor
/*/apps
/im
-sipe.svg
530 %files -n
%{ktp_files}
531 %defattr(-,root
,root
,-)
533 %{_datadir}/telepathy
/profiles
/sipe.profile
537 %files -n
%{telepathy_plugin}
538 %defattr(-,root
,root
,-)
539 %doc AUTHORS ChangeLog COPYING NEWS README TODO
540 %{_datadir}/dbus
-1/services
/*.sipe.service
541 %{_libexecdir}/telepathy
-sipe
544 %files -n
%{common_files} -f pidgin
-sipe.lang
545 %defattr(-,root
,root
,-)
550 %defattr(-,root
,root
,-)
552 %if 0%{?mingw_prefix:1}
553 %if 0%{?has_appstream:1}
554 %{mingw_datadir}/metainfo
/pidgin
-sipe.metainfo.xml
556 %{mingw_datadir}/pixmaps
/pidgin
/protocols
/*/sipe.png
557 %{mingw_datadir}/pixmaps
/pidgin
/protocols
/*/sipe.svg
560 %if 0%{?has_appstream:1}
561 %if 0%{?has_appstream_legacy:1}
562 %{_datadir}/appdata/%{name}.metainfo.xml
564 %{_datadir}/metainfo/%{name}.metainfo.xml
567 %{_datadir}/pixmaps
/pidgin
/protocols
/*/sipe.png
568 %{_datadir}/pixmaps
/pidgin
/protocols
/*/sipe.svg
573 %if 0%{?mingw_prefix:1}
574 %files -n
%{nsis_package}
575 %defattr(-, root
, root
)
576 /pidgin
-sipe
-%{version}.exe
581 * Sun Feb
18 2018 J. D. User
<jduser@noreply.com
> 1.23.0-*git
*
582 - remove obsolete clean section
584 * Sun Feb
18 2018 J. D. User
<jduser@noreply.com
> 1.23.0-*git
*
587 * Mon Nov
06 2017 J. D. User
<jduser@noreply.com
> 1.23.0-*git
*
590 * Sun Nov
05 2017 J. D. User
<jduser@noreply.com
> 1.23.0-*git
*
591 - add support
for new AppStream metadata file location
593 * Sat Oct
28 2017 J. D. User
<jduser@noreply.com
> 1.23.0
595 - raise BR glib
-2.0 >= 2.18.0
596 - raise BR purple
>= 2.7.0
598 * Fri Aug
11 2017 J. D. User
<jduser@noreply.com
> 1.22.1-*git
*
600 - fix incorrect BR gstreamer
-0.10 when gstreamer
-1.0 is selected
602 * Sun Jun
11 2017 J. D. User
<jduser@noreply.com
> 1.22.1
605 * Wed Feb
01 2017 J. D. User
<jduser@noreply.com
> 1.22.0
608 * Sun Dec
18 2016 J. D. User
<jduser@noreply.com
> 1.21.1-*git
*
611 * Wed Jun
15 2016 J. D. User
<jduser@noreply.com
> 1.21.1-*git
*
612 - add BR farstream
-0.2
614 * Sat May
28 2016 J. D. User
<jduser@noreply.com
> 1.21.1
617 * Sat Apr
23 2016 J. D. User
<jduser@noreply.com
> 1.21.0
620 * Tue Apr
05 2016 J. D. User
<jduser@noreply.com
> 1.20.1-*git
*
621 - align with Fedora SPEC file
623 * Fri Jan
01 2016 J. D. User
<jduser@noreply.com
> 1.20.1-*git
*
624 - add AppStream metadata file
626 * Sun Nov
08 2015 J. D. User
<jduser@noreply.com
> 1.20.1-*git
*
627 - add dependency on pkgconfig
(gstreamer
-1.0) for F22
+ & Leap
42.1+
629 * Sat Oct
24 2015 J. D. User
<jduser@noreply.com
> 1.20.1
632 * Thu Sep
03 2015 J. D. User
<jduser@noreply.com
> 1.20.0-*git
*
633 - we also support "Skype
for Business"
635 * Sat Aug
29 2015 J. D. User
<jduser@noreply.com
> 1.20.0
638 * Sat Apr
04 2015 J. D. User
<jduser@noreply.com
> 1.19.1
641 * Sat Feb
07 2015 J. D. User
<jduser@noreply.com
> 1.19.0
644 * Tue Jan
06 2015 J. D. User
<jduser@noreply.com
> 1.18.5-*git
*
645 - add dependency on gssntlmssp
(-devel
) >= 0.5.0 for F21
+
647 * Mon Jan
05 2015 J. D. User
<jduser@noreply.com
> 1.18.5-*git
*
648 - remove support
for obsolete distributions
653 * Mon Dec
29 2014 J. D. User
<jduser@noreply.com
> 1.18.5
656 * Thu Dec
18 2014 J. D. User
<jduser@noreply.com
> 1.18.4-*git
*
657 - improve support
for CentOS
& Scientific Linux
659 * Sat Oct
18 2014 J. D. User
<jduser@noreply.com
> 1.18.4
662 * Sat Aug
16 2014 J. D. User
<jduser@noreply.com
> 1.18.3
665 * Sat Jun
07 2014 J. D. User
<jduser@noreply.com
> 1.18.2
668 * Sat Apr
12 2014 J. D. User
<jduser@noreply.com
> 1.18.1
671 * Tue Mar
04 2014 J. D. User
<jduser@noreply.com
> 1.18.0-*git
*
672 - F20
+/openSUSE
12.2+ require libnice gstreamer
-0.10 plugin
674 * Sat Jan
11 2014 J. D. User
<jduser@noreply.com
> 1.18.0
677 * Wed Dec
11 2013 J. D. User
<jduser@noreply.com
> 1.17.3
680 * Sat Nov
30 2013 J. D. User
<jduser@noreply.com
> 1.17.2
683 * Sat Nov
16 2013 J. D. User
<jduser@noreply.com
> 1.17.1
686 * Sat Sep
21 2013 J. D. User
<jduser@noreply.com
> 1.17.0
689 * Sat Jul
13 2013 J. D. User
<jduser@noreply.com
> 1.16.1
692 * Fri Jun
14 2013 J. D. User
<jduser@noreply.com
> 1.16.0
695 * Sun Apr
07 2013 J. D. User
<jduser@noreply.com
> 1.15.1
698 * Fri Mar
29 2013 J. D. User
<jduser@noreply.com
> 1.15.0-*git
*
699 - update package description texts
701 * Sat Mar
09 2013 J. D. User
<jduser@noreply.com
> 1.15.0
704 * Wed Dec
26 2012 J. D. User
<jduser@noreply.com
> 1.14.1
707 * Sun Dec
16 2012 J. D. User
<jduser@noreply.com
> 1.14.0
710 * Tue Sep
25 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
711 - change BR gstreamer
-devel to pkgconfig
(gstreamer
-0.10)
713 * Sun Sep
09 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
714 - BR telepathy
-glib
-devel
>= 0.18.0
716 * Wed Sep
05 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
717 - BR telepathy
-glib
-devel
>= 0.14.0
719 * Sun Sep
02 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
720 - really disable telepathy
for Windows cross
-compilation builds
722 * Thu Aug
30 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
723 - updates to
enable telepathy build
725 * Sun Aug
19 2012 J. D. User
<jduser@noreply.com
> 1.13.3
728 * Sun Jun
10 2012 J. D. User
<jduser@noreply.com
> 1.13.2
731 * Mon Apr
09 2012 J. D. User
<jduser@noreply.com
> 1.13.1
734 * Wed Mar
14 2012 J. D. User
<jduser@noreply.com
> 1.13.0
737 * Mon Dec
12 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
738 - we
do support Microsoft Lync Server
2010 now.
740 * Tue Dec
06 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
741 - update GPL2 license name
743 * Sat Nov
12 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
744 - add BR gmime
-devel
for Fedora to have at least one verification platform
746 * Sun Nov
06 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
747 - fix Mandriva
2011 unresolvable BR
749 * Mon Oct
31 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
752 * Sat Oct
01 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
753 - add NSIS package
for mingw builds
755 * Sat Oct
01 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
758 * Wed Sep
28 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
759 - remove BR mingw32
-mozilla
-nss
-devel
, not needed
for SSPI.
761 * Mon Sep
19 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
762 - update mingw32 build
763 - update descriptions
765 * Mon Aug
29 2011 J. D. User
<jduser@noreply.com
> 1.12.0
768 * Wed Jun
22 2011 J. D. User
<jduser@noreply.com
> 1.11.2-*git
*
769 - add gstreamer
-devel to
enable Voice
& Video features
771 * Sat Dec
11 2010 J. D. User
<jduser@noreply.com
> 1.11.2-*git
*
772 - add optional subpackage
for telepathy connection manager
774 * Tue Nov
02 2010 J. D. User
<jduser@noreply.com
> 1.11.2
777 * Sun Oct
24 2010 J. D. User
<jduser@noreply.com
> 1.11.1
780 * Fri Oct
15 2010 J. D. User
<jduser@noreply.com
> 1.11.0-*git
*
781 - add mingw32 build configuration
783 * Sun Oct
03 2010 J. D. User
<jduser@noreply.com
> 1.11.0
786 * Thu Sep
02 2010 J. D. User
<jduser@noreply.com
> pre
-1.11.0-*git
*
787 - Mandriva config
for OBS has changed
789 * Tue May
04 2010 J. D. User
<jduser@noreply.com
> 1.10.0-*git
*
790 - add libnice build information discovered through OBS testing
792 * Mon Apr
12 2010 J. D. User
<jduser@noreply.com
> 1.10.0-*git
*
793 - add NSS build information discovered through OBS testing
795 * Sun Apr
04 2010 pier11
<pier11@operamail.com
> 1.10.0
798 * Fri Apr
02 2010 J. D. User
<jduser@noreply.com
> pre
-1.10.0-*git
*
799 - Mandriva has too old libtool version
801 * Fri Apr
02 2010 J. D. User
<jduser@noreply.com
> pre
-1.10.0-*git
*
802 - SLE11
, openSUSE
11.0/1 don't have pidgin
/protocols
/scalable directory
804 * Thu Apr
01 2010 pier11
<pier11@operamail.com
> pre
-1.10.0-*git
*
805 - OBS tests of pre
-1.10.0 git
-snapshot
4fa20cd65e5be0e469d4aa55d861f11c5b08b816
807 * Sun Mar
28 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
808 - added
--enable/--disable build options
810 * Sun Mar
28 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
811 - removed
--with
-krb5 configure option as it is autodetected now
813 * Tue Mar
23 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
816 * Sat Mar
20 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
817 - add BR glib2
-devel
>= 2.12.0
819 * Wed Mar
17 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
822 * Tue Mar
16 2010 J. D. User
<jduser@noreply.com
> 1.9.1
825 * Thu Mar
11 2010 J. D. User
<jduser@noreply.com
> 1.9.0-*git
*
826 - add BR libxml2
-devel
828 * Wed Mar
10 2010 pier11
<pier11@operamail.com
> 1.9.0
830 - dropped SLE
10 due to libpurple min version increase
831 - updated target distros
in comment line
833 * Mon Mar
08 2010 J. D. User
<jduser@noreply.com
> 1.9.0-*git
*
834 - increased libpurple build requisite to
>= 2.4.0
836 * Sun Mar
07 2010 pier11
<pier11@operamail.com
> pre
-1.9.0-*git
*
837 - OBS tests of pre
-1.9.0 git
-snapshot
61ea0856855483b9e18f23a87afe47437e526f0e
839 * Sun Mar
07 2010 J. D. User
<jduser@noreply.com
> 1.8.1-*git
*
840 - sync with RPM SPEC from contrib
/rpm
842 * Mon Feb
08 2010 pier11
<pier11@operamail.com
> 1.8.0
843 - source is an original
1.8.0 with patch
: git
(upstream
) 9c34cc3557daa3d61a002002492c71d0343c8cae
844 - temp hack
- renamed
source in spec from .bz2 to .gz as the latter was prepared with the patch.
846 * Sun Nov
22 2009 pier11
<pier11@operamail.com
> 1.7.1
847 - reinstated
enable-quality
-check
849 * Wed Nov
04 2009 John Beranek
<john@redux.org.uk
> 1.7.0
850 - Spec file modifications to allow SLES
/D
10 and Mandriva
2009.1 builds
852 * Tue Nov
03 2009 John Beranek
<john@redux.org.uk
> 1.7.0
853 - Spec file modifications
for openSUSE build service
855 * Sun Oct
11 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
856 - move non
-Pidgin files to new sub
-package purple
-sipe
858 * Sun Oct
11 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
859 - remove directory
for emoticon theme icons
861 * Sun Oct
11 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
862 - libpurple protocol plugins are located under %
%{_libdir}/purple
-2
864 * Mon Sep
28 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
865 - added directory
for emoticon theme icons
867 * Wed Sep
09 2009 J. D. User
<jduser@noreply.com
> 1.6.3
870 * Fri Aug
28 2009 J. D. User
<jduser@noreply.com
> 1.6.2-*git
*
871 - reduce libpurple
-devel requirement to
>= 2.3.1
873 * Mon Aug
24 2009 J. D. User
<jduser@noreply.com
> 1.6.2
876 * Fri Aug
21 2009 J. D. User
<jduser@noreply.com
> 1.6.1-*git
*
877 - reduce libpurple
-devel requirement to
>= 2.4.1
879 * Mon Aug
17 2009 J. D. User
<jduser@noreply.com
> 1.6.1-*git
*
880 - com_err.h only required
for kerberos
882 * Tue Aug
11 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
883 - require libpurple
-devel
>= 2.5.0
885 * Sun Aug
09 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
886 - refactor configure parameters
887 - make kerberos configurable
888 - don't hard code prefix
for git builds
890 * Sun Aug
09 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
891 - removed unnecessary zlib
-devel
893 * Sat Aug
08 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
894 - fix prefix
for git builds
896 * Sat Aug
01 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
897 - append
-Wno
-unused
-parameter
for GCC
<4.4 compilation errors
899 * Thu Jul
30 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
900 - remove duplicate GPL2
902 * Thu Jul
30 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
903 - use "
--with git" to build from git
904 - corrected download
URL for release archive
905 - add missing BR gettext
-devel
907 * Wed Jul
29 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
908 - use default rpmbuild CFLAGS also
for git builds
909 - merge with SPEC files created by mricon
& jberanek
911 * Tue Jul
28 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
912 - initial RPM SPEC example generated