contrib: remove obsolete %clean section
[siplcs.git] / contrib / rpm / pidgin-sipe.spec
blob334613c4fff35d4363e211061e6f3e26fd2a2cdc
2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box for any current Fedora or RHEL release.
5 %if 0%{?_with_git:1}
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git 20171022gitfe34eaec
14 # Increment when you generate several RPMs on the same day...
15 %define gitcount 0
16 #------------------------------- BUILD FROM GIT -------------------------------
17 %endif
19 %define purple_plugin purple-sipe
20 %define telepathy_plugin telepathy-sipe
21 %define common_files sipe-common
22 %define empathy_files empathy-sipe
23 %define ktp_files ktp-accounts-kcm-sipe
24 %define pkg_group Applications/Communications
26 Name: pidgin-sipe
27 Summary: Pidgin protocol plugin to connect to MS Office Communicator
28 Version: 1.23.0
29 %if 0%{?_with_git:1}
30 Release: %{gitcount}.%{git}%{?dist}
31 Source0: %{name}-%{git}.tar.bz2
32 # git package overrides official released package
33 Epoch: 1
34 %else
35 Release: 1%{?dist}
36 Source0: https://downloads.sourceforge.net/project/sipe/sipe/%{name}-%{version}/%{name}-%{version}.tar.bz2
37 %endif
38 Group: %{pkg_group}
39 License: GPLv2+
40 URL: http://sipe.sourceforge.net/
42 BuildRequires: pkgconfig(dbus-1)
43 BuildRequires: pkgconfig(glib-2.0) >= 2.18.0
44 BuildRequires: pkgconfig(gmodule-2.0) >= 2.18.0
45 BuildRequires: pkgconfig(libxml-2.0)
46 BuildRequires: pkgconfig(nss)
47 BuildRequires: pkgconfig(purple) >= 2.7.0
48 %if 0%{?_with_git:1}
49 BuildRequires: autoconf
50 BuildRequires: automake
51 %endif
52 BuildRequires: appstream
53 BuildRequires: gcc
54 BuildRequires: gettext
55 BuildRequires: intltool
56 BuildRequires: libtool
57 # Use "--without vv" to disable Voice & Video features
58 %if !0%{?_without_vv:1}
59 BuildRequires: pkgconfig(purple) >= 2.8.0
60 BuildRequires: pkgconfig(farstream-0.2)
61 BuildRequires: pkgconfig(gio-2.0)
62 BuildRequires: pkgconfig(gstreamer-1.0)
63 BuildRequires: pkgconfig(gstreamer-rtp-1.0)
64 BuildRequires: pkgconfig(nice) >= 0.1.0
65 %endif
66 # Use "--without telepathy" to disable telepathy
67 %if !0%{?_without_telepathy:1}
68 BuildRequires: gmime-devel
69 BuildRequires: pkgconfig(dbus-glib-1)
70 BuildRequires: pkgconfig(gio-2.0) >= 2.32.0
71 BuildRequires: pkgconfig(glib-2.0) >= 2.32.0
72 BuildRequires: pkgconfig(gobject-2.0)
73 BuildRequires: pkgconfig(telepathy-glib) >= 0.18.0
74 %endif
76 # Configurable components
77 # Use "--without kerberos" to disable krb5
78 %if !0%{?_without_kerberos:1}
79 BuildRequires: pkgconfig(krb5)
80 %if 0%{?fedora} || 0%{?rhel} >= 7
81 BuildRequires: gssntlmssp-devel >= 0.5.0
82 %define requires_gssntlmssp 1
83 %endif
84 %endif
86 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
89 %description
90 A third-party plugin for the Pidgin multi-protocol instant messenger.
91 It implements the extended version of SIP/SIMPLE used by various products:
93 * Skype for Business
94 * Microsoft Office 365
95 * Microsoft Business Productivity Online Suite (BPOS)
96 * Microsoft Lync Server
97 * Microsoft Office Communications Server (OCS 2007/2007 R2)
98 * Microsoft Live Communications Server (LCS 2003/2005)
100 With this plugin you should be able to replace your Microsoft Office
101 Communicator client with Pidgin.
103 This package provides the icon set for Pidgin.
106 %package -n %{purple_plugin}
107 Summary: Libpurple protocol plugin to connect to MS Office Communicator
108 Group: %{pkg_group}
109 License: GPLv2+
110 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
112 %if 0%{?requires_gssntlmssp}
113 Requires: gssntlmssp >= 0.5.0
114 %endif
116 %description -n %{purple_plugin}
117 A third-party plugin for the Pidgin multi-protocol instant messenger.
118 It implements the extended version of SIP/SIMPLE used by various products:
120 * Skype for Business
121 * Microsoft Office 365
122 * Microsoft Business Productivity Online Suite (BPOS)
123 * Microsoft Lync Server
124 * Microsoft Office Communications Server (OCS 2007/2007 R2)
125 * Microsoft Live Communications Server (LCS 2003/2005)
127 This package provides the protocol plugin for libpurple clients.
130 %if !0%{?_without_telepathy:1}
131 %package -n %{empathy_files}
132 Summary: Telepathy connection manager to connect to MS Office Communicator
133 Group: %{pkg_group}
134 License: GPLv2+
135 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
137 %description -n %{empathy_files}
138 A Telepathy connection manager that implements the extended version of
139 SIP/SIMPLE used by various products:
141 * Skype for Business
142 * Microsoft Office 365
143 * Microsoft Business Productivity Online Suite (BPOS)
144 * Microsoft Lync Server
145 * Microsoft Office Communications Server (OCS 2007/2007 R2)
146 * Microsoft Live Communications Server (LCS 2003/2005)
148 This package provides the icon set for Empathy.
151 %package -n %{ktp_files}
152 Summary: Telepathy connection manager to connect to MS Office Communicator
153 Group: %{pkg_group}
154 License: GPLv2+
155 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
157 %description -n %{ktp_files}
158 A Telepathy connection manager that implements the extended version of
159 SIP/SIMPLE used by various products:
161 * Skype for Business
162 * Microsoft Office 365
163 * Microsoft Business Productivity Online Suite (BPOS)
164 * Microsoft Lync Server
165 * Microsoft Office Communications Server (OCS 2007/2007 R2)
166 * Microsoft Live Communications Server (LCS 2003/2005)
168 This package provides the profile for KTP account manager.
171 %package -n %{telepathy_plugin}
172 Summary: Telepathy connection manager to connect to MS Office Communicator
173 Group: %{pkg_group}
174 License: GPLv2+
175 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
177 %if 0%{?requires_gssntlmssp}
178 Requires: gssntlmssp >= 0.5.0
179 %endif
181 %description -n %{telepathy_plugin}
182 A Telepathy connection manager that implements the extended version of
183 SIP/SIMPLE used by various products:
185 * Skype for Business
186 * Microsoft Office 365
187 * Microsoft Business Productivity Online Suite (BPOS)
188 * Microsoft Lync Server
189 * Microsoft Office Communications Server (OCS 2007/2007 R2)
190 * Microsoft Live Communications Server (LCS 2003/2005)
192 This package provides the protocol support for Telepathy clients.
193 %endif
196 %package -n %{common_files}
197 Summary: Common files for SIPE protocol plugins
198 Group: %{pkg_group}
199 License: GPLv2+
200 BuildArch: noarch
202 %description -n %{common_files}
203 This package provides common files for the SIPE protocol plugins:
205 * Localisation
208 %prep
209 %if 0%{?_with_git:1}
210 %setup -q -n %{name}-%{git}
211 %else
212 %setup -q
213 %endif
216 %build
217 %if 0%{?_with_git:1}
218 ./autogen.sh
219 %endif
220 %configure \
221 %if 0%{?_without_vv:1}
222 --without-vv \
223 %endif
224 %if !0%{?_without_kerberos:1}
225 --with-krb5 \
226 %endif
227 --enable-purple \
228 %if !0%{?_without_telepathy:1}
229 --enable-telepathy
230 %else
231 --disable-telepathy
232 %endif
233 make %{?_smp_mflags}
236 %install
237 %make_install
238 find %{buildroot} -type f -name "*.la" -delete -print
239 # Pidgin doesn't have 24 or 32 pixel icons
240 rm -f \
241 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
242 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
243 %find_lang %{name}
246 %check
247 make %{?_smp_mflags} check
250 %files -n %{purple_plugin}
251 %defattr(-,root,root,-)
252 %doc AUTHORS ChangeLog COPYING NEWS README TODO
253 %{_libdir}/purple-2/libsipe.so
256 %if !0%{?_without_telepathy:1}
257 %files -n %{empathy_files}
258 %defattr(-,root,root,-)
259 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
260 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
263 %files -n %{ktp_files}
264 %defattr(-,root,root,-)
265 %doc AUTHORS COPYING
266 %{_datadir}/telepathy/profiles/sipe.profile
269 %files -n %{telepathy_plugin}
270 %defattr(-,root,root,-)
271 %doc AUTHORS ChangeLog COPYING NEWS README TODO
272 %{_datadir}/dbus-1/services/*.sipe.service
273 %{_libexecdir}/telepathy-sipe
274 %endif
277 %files -n %{common_files} -f %{name}.lang
278 %defattr(-,root,root,-)
281 %files
282 %defattr(-,root,root,-)
283 %{_datadir}/metainfo/%{name}.metainfo.xml
284 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
285 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
288 %changelog
289 * Sun Feb 18 2018 J. D. User <jduser@noreply.com> 1.23.0-*git*
290 - remove obsolete clean section
292 * Sun Feb 18 2018 J. D. User <jduser@noreply.com> 1.23.0-*git*
293 - change source URL to https://
295 * Sun Feb 18 2018 J. D. User <jduser@noreply.com> 1.23.0-*git*
296 - add BR gcc
298 * Mon Nov 06 2017 J. D. User <jduser@noreply.com> 1.23.0-*git*
299 - add BR appstream
301 * Sun Nov 05 2017 J. D. User <jduser@noreply.com> 1.23.0-*git*
302 - add support for new AppStream metadata file location
304 * Sat Oct 28 2017 J. D. User <jduser@noreply.com> 1.23.0
305 - update to 1.23.0
306 - raise BR glib-2.0 >= 2.18.0
307 - raise BR purple >= 2.7.0
309 * Fri Aug 11 2017 J. D. User <jduser@noreply.com> 1.22.1-*git*
310 - add BR dbus-1
312 * Sun Jun 11 2017 J. D. User <jduser@noreply.com> 1.22.1
313 - update to 1.22.1
315 * Wed Feb 01 2017 J. D. User <jduser@noreply.com> 1.22.0
316 - update to 1.22.0
318 * Sun Dec 18 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
319 - add BR gio-2.0
321 * Wed Jun 15 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
322 - add BR farstream-0.2
324 * Sat May 28 2016 J. D. User <jduser@noreply.com> 1.21.1
325 - update to 1.21.1
327 * Sat Apr 23 2016 J. D. User <jduser@noreply.com> 1.21.0
328 - update to 1.21.0
330 * Tue Apr 05 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
331 - align with Fedora SPEC file
333 * Fri Jan 01 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
334 - add AppStream metadata file
336 * Sun Nov 08 2015 J. D. User <jduser@noreply.com> 1.20.1-*git*
337 - add dependency on pkgconfig(gstreamer-1.0) for F22+
339 * Sat Oct 24 2015 J. D. User <jduser@noreply.com> 1.20.1
340 - update to 1.20.1
342 * Thu Sep 03 2015 J. D. User <jduser@noreply.com> 1.20.0-*git*
343 - we also support "Skype for Business"
345 * Sat Aug 29 2015 J. D. User <jduser@noreply.com> 1.20.0
346 - update to 1.20.0
348 * Sat Apr 04 2015 J. D. User <jduser@noreply.com> 1.19.1
349 - update to 1.19.1
351 * Sat Feb 07 2015 J. D. User <jduser@noreply.com> 1.19.0
352 - update to 1.19.0
354 * Tue Jan 06 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
355 - add dependency on gssntlmssp(-devel) >= 0.5.0 for F21+
356 - enable Voice & Video features by default
357 - move dependency on libnice-gstreamer to correct packages
359 * Mon Dec 29 2014 J. D. User <jduser@noreply.com> 1.18.5
360 - update to 1.18.5
362 * Sat Oct 18 2014 J. D. User <jduser@noreply.com> 1.18.4
363 - update to 1.18.4
365 * Sat Aug 16 2014 J. D. User <jduser@noreply.com> 1.18.3
366 - update to 1.18.3
368 * Sat Jun 07 2014 J. D. User <jduser@noreply.com> 1.18.2
369 - update to 1.18.2
371 * Sat Apr 12 2014 J. D. User <jduser@noreply.com> 1.18.1
372 - update to 1.18.1
374 * Sat Mar 08 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
375 - New Fedora packaging guidelines suggest to use pkgconfig() for BRs
377 * Tue Mar 04 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
378 - F20+ require libnice-gstreamer for correct operation
380 * Sat Jan 11 2014 J. D. User <jduser@noreply.com> 1.18.0
381 - update to 1.18.0
383 * Wed Dec 11 2013 J. D. User <jduser@noreply.com> 1.17.3
384 - update to 1.17.3
386 * Sat Nov 30 2013 J. D. User <jduser@noreply.com> 1.17.2
387 - update to 1.17.2
389 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
390 - update to 1.17.1
392 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
393 - update to 1.17.0
395 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
396 - update to 1.16.1
398 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
399 - update to 1.16.0
401 * Thu May 16 2013 J. D. User <jduser@noreply.com> 1.15.1-*git*
402 - BR glib-2.0 >= 2.28.0 no longer required for Voice & Video features
404 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
405 - update to 1.15.1
407 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
408 - update package description texts
410 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
411 - update to 1.15.0
413 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
414 - update to 1.14.1
416 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
417 - update to 1.14.0
419 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
420 - BR telepathy-glib-devel >= 0.18.0
422 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
423 - BR telepathy-glib-devel >= 0.14.0
425 * Mon Aug 27 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
426 - add ktp-accounts-kcm-sipe package
428 * Sun Aug 26 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
429 - telepathy now requires glib-2.0 >= 2.22.0
430 - use "--without telepathy" to disable telepathy packages
432 * Fri Aug 24 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
433 - add empathy-sipe package
435 * Wed Aug 22 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
436 - add telepathy-sipe & sipe-common packages
438 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
439 - update to 1.13.3
441 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
442 - update to 1.13.2
444 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
445 - update to 1.13.1
447 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
448 - update to 1.13.0
450 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
451 - we do support Microsoft Lync Server 2010 now.
453 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
454 - update GPL2 license name
456 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
457 - add BR gmime-devel
459 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
460 - add BR nss-devel
462 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
463 - update to 1.12.0
465 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
466 - add "--with vv" option to enable Voice & Video features
468 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
469 - update to 1.11.2
471 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
472 - update to 1.11.1
474 * Mon Oct 04 2010 J. D. User <jduser@noreply.com> 1.11.0
475 - update to 1.11.0
477 * Thu Sep 02 2010 J. D. User <jduser@noreply.com> 1.10.1-*git*
478 - add (commented out) BR libnice-devel
480 * Sun Jun 27 2010 J. D. User <jduser@noreply.com> 1.10.1
481 - update to 1.10.1
483 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
484 - add (commented out) BR nss-devel
486 * Sun Apr 04 2010 J. D. User <jduser@noreply.com> 1.10.0
487 - update to 1.10.0
489 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
490 - changed --with/--without options to --enable/--disable
492 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
493 - removed --with-krb5 configure option as it is autodetected now
495 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
496 - add SVG icon
498 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
499 - add BR glib2-devel >= 2.12.0
501 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
502 - add tests to build
504 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
505 - update to 1.9.1
507 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
508 - add BR libxml2-devel
510 * Wed Mar 10 2010 J. D. User <jduser@noreply.com> 1.9.0
511 - update to 1.9.0
513 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
514 - increased libpurple build requisite to >= 2.4.0
516 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
517 - sync with RPM SPEC from contrib/OBS
519 * Sat Mar 06 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
520 - update package summary & description
522 * Tue Feb 16 2010 J. D. User <jduser@noreply.com> 1.8.1
523 - update to 1.8.1
525 * Sun Feb 07 2010 J. D. User <jduser@noreply.com> 1.8.0
526 - update to 1.8.0
528 * Thu Jan 14 2010 J. D. User <jduser@noreply.com> 1.7.1-*git*
529 - autogen.sh no longer runs configure
531 * Tue Dec 29 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
532 - add configure parameters for purple and telepathy
534 * Sat Dec 12 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
535 - add Epoch: for git packages to avoid update clash with official packages
537 * Thu Nov 19 2009 J. D. User <jduser@noreply.com> 1.7.1
538 - update to 1.7.1
540 * Wed Oct 28 2009 J. D. User <jduser@noreply.com> 1.7.0-*git*
541 - add missing Group: to purple-sipe
543 * Mon Oct 19 2009 J. D. User <jduser@noreply.com> 1.7.0
544 - update to 1.7.0
546 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
547 - move non-Pidgin files to new sub-package purple-sipe
549 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
550 - remove directory for emoticon theme icons
552 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
553 - libpurple protocol plugins are located under %%{_libdir}/purple-2
555 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
556 - added directory for emoticon theme icons
558 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
559 - update to 1.6.3
561 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
562 - reduce libpurple-devel requirement to >= 2.3.1
564 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
565 - update to 1.6.2
567 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
568 - reduce libpurple-devel requirement to >= 2.4.1
570 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
571 - com_err.h only required for kerberos
573 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
574 - require libpurple-devel >= 2.5.0
576 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
577 - refactor configure parameters
578 - make kerberos configurable
579 - don't hard code prefix for git builds
581 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
582 - removed unnecessary zlib-devel
584 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
585 - fix prefix for git builds
587 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
588 - append -Wno-unused-parameter for GCC <4.4 compilation errors
590 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
591 - remove duplicate GPL2
593 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
594 - use "--with git" to build from git
595 - corrected download URL for release archive
596 - add missing BR gettext-devel
598 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
599 - use default rpmbuild CFLAGS also for git builds
600 - merge with SPEC files created by mricon & jberanek
602 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
603 - initial RPM SPEC example generated