purple: fix build with libpurple 2.14.0
[siplcs.git] / contrib / rpm / pidgin-sipe.spec
blobf6c1b81832a85c0e085891992634793ec4bbf7a5
2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box for any current Fedora or RHEL release.
5 %if 0%{?_with_git:1}
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git 20171022gitfe34eaec
14 # Increment when you generate several RPMs on the same day...
15 %define gitcount 0
16 #------------------------------- BUILD FROM GIT -------------------------------
17 %endif
19 %define purple_plugin purple-sipe
20 %define telepathy_plugin telepathy-sipe
21 %define common_files sipe-common
22 %define empathy_files empathy-sipe
23 %define ktp_files ktp-accounts-kcm-sipe
24 %define pkg_group Applications/Communications
26 Name: pidgin-sipe
27 Summary: Pidgin protocol plugin to connect to MS Office Communicator
28 Version: 1.23.2
29 %if 0%{?_with_git:1}
30 Release: %{gitcount}.%{git}%{?dist}
31 Source0: %{name}-%{git}.tar.bz2
32 # git package overrides official released package
33 Epoch: 1
34 %else
35 Release: 1%{?dist}
36 Source0: https://downloads.sourceforge.net/project/sipe/sipe/%{name}-%{version}/%{name}-%{version}.tar.bz2
37 %endif
38 Group: %{pkg_group}
39 License: GPLv2+
40 URL: http://sipe.sourceforge.net/
42 BuildRequires: pkgconfig(dbus-1)
43 BuildRequires: pkgconfig(glib-2.0) >= 2.18.0
44 BuildRequires: pkgconfig(gmodule-2.0) >= 2.18.0
45 BuildRequires: pkgconfig(libxml-2.0)
46 BuildRequires: pkgconfig(nss)
47 BuildRequires: pkgconfig(purple) >= 2.7.0
48 %if 0%{?_with_git:1}
49 BuildRequires: autoconf
50 BuildRequires: automake
51 %endif
52 BuildRequires: appstream
53 BuildRequires: gcc
54 BuildRequires: gettext
55 BuildRequires: intltool
56 BuildRequires: libtool
57 # Use "--without vv" to disable Voice & Video features
58 %if !0%{?_without_vv:1}
59 BuildRequires: pkgconfig(purple) >= 2.8.0
60 BuildRequires: pkgconfig(farstream-0.2)
61 BuildRequires: pkgconfig(gio-2.0)
62 BuildRequires: pkgconfig(gstreamer-1.0)
63 BuildRequires: pkgconfig(gstreamer-rtp-1.0)
64 BuildRequires: pkgconfig(nice) >= 0.1.0
65 %endif
66 # Use "--without telepathy" to disable telepathy
67 %if !0%{?_without_telepathy:1}
68 BuildRequires: gmime-devel
69 BuildRequires: pkgconfig(dbus-glib-1)
70 BuildRequires: pkgconfig(gio-2.0) >= 2.32.0
71 BuildRequires: pkgconfig(glib-2.0) >= 2.32.0
72 BuildRequires: pkgconfig(gobject-2.0)
73 BuildRequires: pkgconfig(telepathy-glib) >= 0.18.0
74 %endif
76 # Configurable components
77 # Use "--without kerberos" to disable krb5
78 %if !0%{?_without_kerberos:1}
79 BuildRequires: pkgconfig(krb5)
80 %if 0%{?fedora} || 0%{?rhel} >= 7
81 BuildRequires: gssntlmssp-devel >= 0.5.0
82 %define requires_gssntlmssp 1
83 %endif
84 %endif
86 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
89 %description
90 A third-party plugin for the Pidgin multi-protocol instant messenger.
91 It implements the extended version of SIP/SIMPLE used by various products:
93 * Skype for Business
94 * Microsoft Office 365
95 * Microsoft Business Productivity Online Suite (BPOS)
96 * Microsoft Lync Server
97 * Microsoft Office Communications Server (OCS 2007/2007 R2)
98 * Microsoft Live Communications Server (LCS 2003/2005)
100 With this plugin you should be able to replace your Microsoft Office
101 Communicator client with Pidgin.
103 This package provides the icon set for Pidgin.
106 %package -n %{purple_plugin}
107 Summary: Libpurple protocol plugin to connect to MS Office Communicator
108 Group: %{pkg_group}
109 License: GPLv2+
110 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
112 %if 0%{?requires_gssntlmssp}
113 Requires: gssntlmssp >= 0.5.0
114 %endif
116 %description -n %{purple_plugin}
117 A third-party plugin for the Pidgin multi-protocol instant messenger.
118 It implements the extended version of SIP/SIMPLE used by various products:
120 * Skype for Business
121 * Microsoft Office 365
122 * Microsoft Business Productivity Online Suite (BPOS)
123 * Microsoft Lync Server
124 * Microsoft Office Communications Server (OCS 2007/2007 R2)
125 * Microsoft Live Communications Server (LCS 2003/2005)
127 This package provides the protocol plugin for libpurple clients.
130 %if !0%{?_without_telepathy:1}
131 %package -n %{empathy_files}
132 Summary: Telepathy connection manager to connect to MS Office Communicator
133 Group: %{pkg_group}
134 License: GPLv2+
135 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
137 %description -n %{empathy_files}
138 A Telepathy connection manager that implements the extended version of
139 SIP/SIMPLE used by various products:
141 * Skype for Business
142 * Microsoft Office 365
143 * Microsoft Business Productivity Online Suite (BPOS)
144 * Microsoft Lync Server
145 * Microsoft Office Communications Server (OCS 2007/2007 R2)
146 * Microsoft Live Communications Server (LCS 2003/2005)
148 This package provides the icon set for Empathy.
151 %package -n %{ktp_files}
152 Summary: Telepathy connection manager to connect to MS Office Communicator
153 Group: %{pkg_group}
154 License: GPLv2+
155 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
157 %description -n %{ktp_files}
158 A Telepathy connection manager that implements the extended version of
159 SIP/SIMPLE used by various products:
161 * Skype for Business
162 * Microsoft Office 365
163 * Microsoft Business Productivity Online Suite (BPOS)
164 * Microsoft Lync Server
165 * Microsoft Office Communications Server (OCS 2007/2007 R2)
166 * Microsoft Live Communications Server (LCS 2003/2005)
168 This package provides the profile for KTP account manager.
171 %package -n %{telepathy_plugin}
172 Summary: Telepathy connection manager to connect to MS Office Communicator
173 Group: %{pkg_group}
174 License: GPLv2+
175 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
177 %if 0%{?requires_gssntlmssp}
178 Requires: gssntlmssp >= 0.5.0
179 %endif
181 %description -n %{telepathy_plugin}
182 A Telepathy connection manager that implements the extended version of
183 SIP/SIMPLE used by various products:
185 * Skype for Business
186 * Microsoft Office 365
187 * Microsoft Business Productivity Online Suite (BPOS)
188 * Microsoft Lync Server
189 * Microsoft Office Communications Server (OCS 2007/2007 R2)
190 * Microsoft Live Communications Server (LCS 2003/2005)
192 This package provides the protocol support for Telepathy clients.
193 %endif
196 %package -n %{common_files}
197 Summary: Common files for SIPE protocol plugins
198 Group: %{pkg_group}
199 License: GPLv2+
200 BuildArch: noarch
202 %description -n %{common_files}
203 This package provides common files for the SIPE protocol plugins:
205 * Localisation
208 %prep
209 %if 0%{?_with_git:1}
210 %setup -q -n %{name}-%{git}
211 %else
212 %setup -q
213 %endif
216 %build
217 %if 0%{?_with_git:1}
218 ./autogen.sh
219 %endif
220 %configure \
221 %if 0%{?_without_vv:1}
222 --without-vv \
223 %endif
224 %if !0%{?_without_kerberos:1}
225 --with-krb5 \
226 %endif
227 --enable-purple \
228 %if !0%{?_without_telepathy:1}
229 --enable-telepathy
230 %else
231 --disable-telepathy
232 %endif
233 make %{?_smp_mflags}
236 %install
237 %make_install
238 find %{buildroot} -type f -name "*.la" -delete -print
239 # Pidgin doesn't have 24 or 32 pixel icons
240 rm -f \
241 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
242 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
243 %find_lang %{name}
246 %check
247 make %{?_smp_mflags} check
250 %files -n %{purple_plugin}
251 %defattr(-,root,root,-)
252 %doc AUTHORS ChangeLog COPYING NEWS README TODO
253 %{_libdir}/purple-2/libsipe.so
256 %if !0%{?_without_telepathy:1}
257 %files -n %{empathy_files}
258 %defattr(-,root,root,-)
259 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
260 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
263 %files -n %{ktp_files}
264 %defattr(-,root,root,-)
265 %doc AUTHORS COPYING
266 %{_datadir}/telepathy/profiles/sipe.profile
269 %files -n %{telepathy_plugin}
270 %defattr(-,root,root,-)
271 %doc AUTHORS ChangeLog COPYING NEWS README TODO
272 %{_datadir}/dbus-1/services/*.sipe.service
273 %{_libexecdir}/telepathy-sipe
274 %endif
277 %files -n %{common_files} -f %{name}.lang
278 %defattr(-,root,root,-)
281 %files
282 %defattr(-,root,root,-)
283 %{_datadir}/metainfo/%{name}.metainfo.xml
284 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
285 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
288 %changelog
289 * Sat Mar 10 2018 J. D. User <jduser@noreply.com> 1.23.2
290 - update to 1.23.2
292 * Sun Feb 25 2018 J. D. User <jduser@noreply.com> 1.23.1
293 - update to 1.23.1
295 * Sun Feb 18 2018 J. D. User <jduser@noreply.com> 1.23.0-*git*
296 - remove obsolete clean section
298 * Sun Feb 18 2018 J. D. User <jduser@noreply.com> 1.23.0-*git*
299 - change source URL to https://
301 * Sun Feb 18 2018 J. D. User <jduser@noreply.com> 1.23.0-*git*
302 - add BR gcc
304 * Mon Nov 06 2017 J. D. User <jduser@noreply.com> 1.23.0-*git*
305 - add BR appstream
307 * Sun Nov 05 2017 J. D. User <jduser@noreply.com> 1.23.0-*git*
308 - add support for new AppStream metadata file location
310 * Sat Oct 28 2017 J. D. User <jduser@noreply.com> 1.23.0
311 - update to 1.23.0
312 - raise BR glib-2.0 >= 2.18.0
313 - raise BR purple >= 2.7.0
315 * Fri Aug 11 2017 J. D. User <jduser@noreply.com> 1.22.1-*git*
316 - add BR dbus-1
318 * Sun Jun 11 2017 J. D. User <jduser@noreply.com> 1.22.1
319 - update to 1.22.1
321 * Wed Feb 01 2017 J. D. User <jduser@noreply.com> 1.22.0
322 - update to 1.22.0
324 * Sun Dec 18 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
325 - add BR gio-2.0
327 * Wed Jun 15 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
328 - add BR farstream-0.2
330 * Sat May 28 2016 J. D. User <jduser@noreply.com> 1.21.1
331 - update to 1.21.1
333 * Sat Apr 23 2016 J. D. User <jduser@noreply.com> 1.21.0
334 - update to 1.21.0
336 * Tue Apr 05 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
337 - align with Fedora SPEC file
339 * Fri Jan 01 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
340 - add AppStream metadata file
342 * Sun Nov 08 2015 J. D. User <jduser@noreply.com> 1.20.1-*git*
343 - add dependency on pkgconfig(gstreamer-1.0) for F22+
345 * Sat Oct 24 2015 J. D. User <jduser@noreply.com> 1.20.1
346 - update to 1.20.1
348 * Thu Sep 03 2015 J. D. User <jduser@noreply.com> 1.20.0-*git*
349 - we also support "Skype for Business"
351 * Sat Aug 29 2015 J. D. User <jduser@noreply.com> 1.20.0
352 - update to 1.20.0
354 * Sat Apr 04 2015 J. D. User <jduser@noreply.com> 1.19.1
355 - update to 1.19.1
357 * Sat Feb 07 2015 J. D. User <jduser@noreply.com> 1.19.0
358 - update to 1.19.0
360 * Tue Jan 06 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
361 - add dependency on gssntlmssp(-devel) >= 0.5.0 for F21+
362 - enable Voice & Video features by default
363 - move dependency on libnice-gstreamer to correct packages
365 * Mon Dec 29 2014 J. D. User <jduser@noreply.com> 1.18.5
366 - update to 1.18.5
368 * Sat Oct 18 2014 J. D. User <jduser@noreply.com> 1.18.4
369 - update to 1.18.4
371 * Sat Aug 16 2014 J. D. User <jduser@noreply.com> 1.18.3
372 - update to 1.18.3
374 * Sat Jun 07 2014 J. D. User <jduser@noreply.com> 1.18.2
375 - update to 1.18.2
377 * Sat Apr 12 2014 J. D. User <jduser@noreply.com> 1.18.1
378 - update to 1.18.1
380 * Sat Mar 08 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
381 - New Fedora packaging guidelines suggest to use pkgconfig() for BRs
383 * Tue Mar 04 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
384 - F20+ require libnice-gstreamer for correct operation
386 * Sat Jan 11 2014 J. D. User <jduser@noreply.com> 1.18.0
387 - update to 1.18.0
389 * Wed Dec 11 2013 J. D. User <jduser@noreply.com> 1.17.3
390 - update to 1.17.3
392 * Sat Nov 30 2013 J. D. User <jduser@noreply.com> 1.17.2
393 - update to 1.17.2
395 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
396 - update to 1.17.1
398 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
399 - update to 1.17.0
401 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
402 - update to 1.16.1
404 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
405 - update to 1.16.0
407 * Thu May 16 2013 J. D. User <jduser@noreply.com> 1.15.1-*git*
408 - BR glib-2.0 >= 2.28.0 no longer required for Voice & Video features
410 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
411 - update to 1.15.1
413 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
414 - update package description texts
416 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
417 - update to 1.15.0
419 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
420 - update to 1.14.1
422 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
423 - update to 1.14.0
425 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
426 - BR telepathy-glib-devel >= 0.18.0
428 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
429 - BR telepathy-glib-devel >= 0.14.0
431 * Mon Aug 27 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
432 - add ktp-accounts-kcm-sipe package
434 * Sun Aug 26 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
435 - telepathy now requires glib-2.0 >= 2.22.0
436 - use "--without telepathy" to disable telepathy packages
438 * Fri Aug 24 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
439 - add empathy-sipe package
441 * Wed Aug 22 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
442 - add telepathy-sipe & sipe-common packages
444 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
445 - update to 1.13.3
447 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
448 - update to 1.13.2
450 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
451 - update to 1.13.1
453 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
454 - update to 1.13.0
456 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
457 - we do support Microsoft Lync Server 2010 now.
459 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
460 - update GPL2 license name
462 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
463 - add BR gmime-devel
465 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
466 - add BR nss-devel
468 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
469 - update to 1.12.0
471 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
472 - add "--with vv" option to enable Voice & Video features
474 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
475 - update to 1.11.2
477 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
478 - update to 1.11.1
480 * Mon Oct 04 2010 J. D. User <jduser@noreply.com> 1.11.0
481 - update to 1.11.0
483 * Thu Sep 02 2010 J. D. User <jduser@noreply.com> 1.10.1-*git*
484 - add (commented out) BR libnice-devel
486 * Sun Jun 27 2010 J. D. User <jduser@noreply.com> 1.10.1
487 - update to 1.10.1
489 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
490 - add (commented out) BR nss-devel
492 * Sun Apr 04 2010 J. D. User <jduser@noreply.com> 1.10.0
493 - update to 1.10.0
495 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
496 - changed --with/--without options to --enable/--disable
498 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
499 - removed --with-krb5 configure option as it is autodetected now
501 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
502 - add SVG icon
504 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
505 - add BR glib2-devel >= 2.12.0
507 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
508 - add tests to build
510 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
511 - update to 1.9.1
513 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
514 - add BR libxml2-devel
516 * Wed Mar 10 2010 J. D. User <jduser@noreply.com> 1.9.0
517 - update to 1.9.0
519 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
520 - increased libpurple build requisite to >= 2.4.0
522 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
523 - sync with RPM SPEC from contrib/OBS
525 * Sat Mar 06 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
526 - update package summary & description
528 * Tue Feb 16 2010 J. D. User <jduser@noreply.com> 1.8.1
529 - update to 1.8.1
531 * Sun Feb 07 2010 J. D. User <jduser@noreply.com> 1.8.0
532 - update to 1.8.0
534 * Thu Jan 14 2010 J. D. User <jduser@noreply.com> 1.7.1-*git*
535 - autogen.sh no longer runs configure
537 * Tue Dec 29 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
538 - add configure parameters for purple and telepathy
540 * Sat Dec 12 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
541 - add Epoch: for git packages to avoid update clash with official packages
543 * Thu Nov 19 2009 J. D. User <jduser@noreply.com> 1.7.1
544 - update to 1.7.1
546 * Wed Oct 28 2009 J. D. User <jduser@noreply.com> 1.7.0-*git*
547 - add missing Group: to purple-sipe
549 * Mon Oct 19 2009 J. D. User <jduser@noreply.com> 1.7.0
550 - update to 1.7.0
552 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
553 - move non-Pidgin files to new sub-package purple-sipe
555 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
556 - remove directory for emoticon theme icons
558 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
559 - libpurple protocol plugins are located under %%{_libdir}/purple-2
561 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
562 - added directory for emoticon theme icons
564 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
565 - update to 1.6.3
567 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
568 - reduce libpurple-devel requirement to >= 2.3.1
570 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
571 - update to 1.6.2
573 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
574 - reduce libpurple-devel requirement to >= 2.4.1
576 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
577 - com_err.h only required for kerberos
579 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
580 - require libpurple-devel >= 2.5.0
582 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
583 - refactor configure parameters
584 - make kerberos configurable
585 - don't hard code prefix for git builds
587 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
588 - removed unnecessary zlib-devel
590 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
591 - fix prefix for git builds
593 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
594 - append -Wno-unused-parameter for GCC <4.4 compilation errors
596 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
597 - remove duplicate GPL2
599 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
600 - use "--with git" to build from git
601 - corrected download URL for release archive
602 - add missing BR gettext-devel
604 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
605 - use default rpmbuild CFLAGS also for git builds
606 - merge with SPEC files created by mricon & jberanek
608 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
609 - initial RPM SPEC example generated