2 # OBS SPEC file to generate a RPM for pidgin-sipe.
6 # RedHat family (CentOS, Fedora, RHEL, ScientificLinux)
7 # SUSE family (openSUSE, SLED, SLES)
9 # Windows (mingw32, mingw64)
13 %undefine build_telepathy
15 # Check for mingw32 cross compilation build
17 # Manually add this repository to your private OBS project:
19 # <repository name="mingw32">
20 # <path repository="openSUSE_13.2" project="windows:mingw:win32"/>
24 %if "
%{_repository}"
== "mingw32"
25 %define purple_sipe_mingw32
1
26 %define mingw_prefix mingw32
-
27 %define mingw_cache
%{_mingw32_cache}
28 %define mingw_configure
%{_mingw32_configure}
29 %define mingw_datadir
%{_mingw32_datadir}
30 %define mingw_debug_package
%{_mingw32_debug_package}
31 %define mingw_ldflags MINGW32_LDFLAGS
32 %define mingw_libdir
%{_mingw32_libdir}
33 %define mingw_make
%{_mingw32_make}
34 %define mingw_makeinstall
%{_mingw32_makeinstall}
35 %define __strip
%{_mingw32_strip}
36 %define __objdump
%{_mingw32_objdump}
37 %define _use_internal_dependency_generator
0
38 %define __find_requires
%{_mingw32_findrequires}
39 %define __find_provides
%{_mingw32_findprovides}
40 %define __os_install_post
%{_mingw32_debug_install_post} \
41 %{_mingw32_install_post}
44 # Check for mingw64 cross compilation build
46 # Manually add this repository to your private OBS project:
48 # <repository name="mingw64">
49 # <path repository="openSUSE_13.2" project="windows:mingw:win64"/>
53 %if "
%{_repository}"
== "mingw64"
54 %define purple_sipe_mingw64
1
55 %define mingw_prefix mingw64
-
56 %define mingw_cache
%{_mingw64_cache}
57 %define mingw_configure
%{_mingw64_configure}
58 %define mingw_datadir
%{_mingw64_datadir}
59 %define mingw_debug_package
%{_mingw64_debug_package}
60 %define mingw_ldflags MINGW64_LDFLAGS
61 %define mingw_libdir
%{_mingw64_libdir}
62 %define mingw_make
%{_mingw64_make}
63 %define mingw_makeinstall
%{_mingw64_makeinstall}
64 %define __strip
%{_mingw64_strip}
65 %define __objdump
%{_mingw64_objdump}
66 %define _use_internal_dependency_generator
0
67 %define __find_requires
%{_mingw64_findrequires}
68 %define __find_provides
%{_mingw64_findprovides}
69 %define __os_install_post
%{_mingw64_debug_install_post} \
70 %{_mingw64_install_post}
73 %define purple_plugin
%{?mingw_prefix:%{mingw_prefix}}libpurple
-plugin
-sipe
74 %define telepathy_plugin
%{?mingw_prefix:%{mingw_prefix}}telepathy
-plugin
-sipe
75 %define nsis_package
%{?mingw_prefix:%{mingw_prefix}}pidgin
-sipe
-nsis
76 %define common_files sipe
-common
77 %define empathy_files empathy
-sipe
78 %define ktp_files ktp
-accounts
-kcm
-sipe
82 %define has_appstream
1
83 %define has_appstream_legacy
1
84 %define has_gstreamer
1
89 %define has_appstream
1
90 %define has_appstream_legacy
1
91 %if 0%{?suse_version} >= 1500
95 %define has_gstreamer
1
96 %define build_telepathy
1
100 %define pkg_group Productivity
/Networking
/Instant Messenger
102 %define pkg_group Applications
/Communications
105 # workaround for Fedora Rawhide
106 %if 0%{?fedora_version}
109 %define fedora
%{?fedora_version}
114 %define has_appstream
1
116 %define has_appstream_legacy
1
119 %define has_freerdp
1
121 %define has_gssntlmssp
1
122 %define has_gstreamer
1
123 %define build_telepathy
1
127 %if 0%{?centos_version} || 0%{?scientificlinux_version}
128 %define has_krb5devel
1
129 %define rhel_base_version
%{?centos_version}%{?scientificlinux_version}
130 %if %{rhel_base_version} >= 700
131 %define has_gstreamer
1
135 %if 0%{?purple_sipe_mingw32}
136 Name: mingw32
-pidgin
-sipe
138 %if 0%{?purple_sipe_mingw64}
139 Name: mingw64
-pidgin
-sipe
144 Summary: Pidgin protocol plugin to connect to MS Office Communicator
147 Source: pidgin
-sipe
-%{version}.tar.gz
150 URL: http
://sipe.sourceforge.net
/
152 BuildRoot: %{_tmppath}/%{name}-%{version}-build
154 %if 0%{?mingw_prefix:1}
156 # Windows cross-compilation build setup
159 #!BuildIgnore: post-build-checks
161 BuildRequires
: libtool
162 BuildRequires
: intltool
163 BuildRequires
: %{mingw_prefix}filesystem
>= 23
164 BuildRequires
: %{mingw_prefix}cross
-gcc
165 BuildRequires
: %{mingw_prefix}cross
-binutils
166 BuildRequires
: %{mingw_prefix}gettext
-runtime
167 BuildRequires
: %{mingw_prefix}cross
-pkg
-config
168 BuildRequires
: %{mingw_prefix}glib2
-devel
>= 2.18.0
169 BuildRequires
: %{mingw_prefix}libxml2
-devel
170 BuildRequires
: %{mingw_prefix}mozilla
-nss
-devel
171 BuildRequires
: %{mingw_prefix}libpurple
-devel
>= 2.7.0
172 BuildRequires
: %{mingw_prefix}cross
-nsis
174 # For directory ownership
175 BuildRequires
: %{mingw_prefix}pidgin
177 # Make sure telepathy is disabled for Windows builds
178 %undefine build_telepathy
182 # Standard Linux build setup
185 BuildRequires
: libtool
186 BuildRequires
: intltool
187 BuildRequires
: pkgconfig
(dbus
-1)
188 BuildRequires
: pkgconfig
(glib
-2.0) >= 2.18.0
189 BuildRequires
: pkgconfig
(gmodule
-2.0) >= 2.18.0
190 BuildRequires
: pkgconfig
(libxml
-2.0)
191 BuildRequires
: pkgconfig
(nss
)
192 BuildRequires
: pkgconfig
(purple
) >= 2.7.0
194 # It seems linking against -lpurple is severely broken on Mageia...
195 BuildRequires
: pkgconfig
(libgadu
)
197 %if 0%{?has_appstream:1}
198 %if 0%{?suse_version}
199 BuildRequires
: AppStream
201 BuildRequires
: appstream
204 %if 0%{?has_gstreamer:1}
205 BuildRequires
: pkgconfig
(farstream
-0.2)
206 BuildRequires
: pkgconfig
(gio
-2.0)
207 BuildRequires
: pkgconfig
(gstreamer
-1.0)
208 BuildRequires
: pkgconfig
(gstreamer
-rtp
-1.0)
209 BuildRequires
: pkgconfig
(nice
) >= 0.1.0
210 # Requirements for appshare server
211 %if 0%{?has_freerdp:1}
212 BuildRequires
: pkgconfig
(freerdp
-shadow2
)
215 # Requirements for telepathy backend
216 %if 0%{?build_telepathy:1}
217 BuildRequires
: gmime
-devel
218 BuildRequires
: pkgconfig
(dbus
-glib
-1)
219 BuildRequires
: pkgconfig
(gio
-2.0) >= 2.32.0
220 BuildRequires
: pkgconfig
(glib
-2.0) >= 2.32.0
221 BuildRequires
: pkgconfig
(gobject
-2.0)
222 BuildRequires
: pkgconfig
(telepathy
-glib
) >= 0.18.0
225 # Configurable components
226 # Use "--without kerberos" to disable krb5
227 %if !0%{?_without_kerberos:1}
228 %if 0%{?has_krb5devel:1}
229 BuildRequires
: krb5
-devel
231 BuildRequires
: pkgconfig
(krb5
)
233 %if 0%{?has_gssntlmssp:1}
234 BuildRequires
: gssntlmssp
-devel
>= 0.5.0
235 Requires: gssntlmssp
>= 0.5.0
239 # For directory ownership
240 BuildRequires
: pidgin
242 %if 0%{?build_telepathy:1}
243 BuildRequires
: empathy
246 # End Windows cross-compilation/Linux build setup
249 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
253 A third
-party plugin
for the Pidgin multi
-protocol instant messenger.
254 It implements the extended version of SIP
/SIMPLE used by various products
:
257 * Microsoft Office
365
258 * Microsoft Business Productivity Online Suite
(BPOS
)
259 * Microsoft Lync Server
260 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
261 * Microsoft Live Communications Server
(LCS
2003/2005)
263 With this plugin you should be able to replace your Microsoft Office
264 Communicator client with Pidgin.
266 This package provides the icon
set for Pidgin.
269 %package -n
%{purple_plugin}
270 Summary: Libpurple protocol plugin to connect to MS Office Communicator
273 Obsoletes
: purple
-sipe
274 %if 0%{?build_telepathy:1}
275 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
278 %description -n
%{purple_plugin}
279 A third
-party plugin
for the Pidgin multi
-protocol instant messenger.
280 It implements the extended version of SIP
/SIMPLE used by various products
:
283 * Microsoft Office
365
284 * Microsoft Business Productivity Online Suite
(BPOS
)
285 * Microsoft Lync Server
286 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
287 * Microsoft Live Communications Server
(LCS
2003/2005)
289 This package provides the protocol plugin
for libpurple clients.
292 %if 0%{?build_telepathy:1}
293 %package -n
%{empathy_files}
294 Summary: Telepathy connection manager to connect to MS Office Communicator
298 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
300 %description -n
%{empathy_files}
301 A Telepathy connection manager that implements the extended version of
302 SIP
/SIMPLE used by various products
:
305 * Microsoft Office
365
306 * Microsoft Business Productivity Online Suite
(BPOS
)
307 * Microsoft Lync Server
308 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
309 * Microsoft Live Communications Server
(LCS
2003/2005)
311 This package provides the icon
set for Empathy.
315 %package -n
%{ktp_files}
316 Summary: Telepathy connection manager to connect to MS Office Communicator
319 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
321 %description -n
%{ktp_files}
322 A Telepathy connection manager that implements the extended version of
323 SIP
/SIMPLE used by various products
:
326 * Microsoft Office
365
327 * Microsoft Business Productivity Online Suite
(BPOS
)
328 * Microsoft Lync Server
329 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
330 * Microsoft Live Communications Server
(LCS
2003/2005)
332 This package provides the profile
for KTP account manager.
336 %package -n
%{telepathy_plugin}
337 Summary: Telepathy connection manager to connect to MS Office Communicator
340 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
342 %description -n
%{telepathy_plugin}
343 A Telepathy connection manager that implements the extended version of
344 SIP
/SIMPLE used by various products
:
347 * Microsoft Office
365
348 * Microsoft Business Productivity Online Suite
(BPOS
)
349 * Microsoft Lync Server
350 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
351 * Microsoft Live Communications Server
(LCS
2003/2005)
353 This package provides the protocol support
for Telepathy clients.
356 %package -n
%{common_files}
357 Summary: Common files
for SIPE protocol plugins
362 %description -n
%{common_files}
363 This package provides common files
for the SIPE protocol plugins
:
369 %if 0%{?mingw_prefix:1}
370 %package -n
%{nsis_package}
371 Summary: Windows Pidgin protocol plugin to connect to MS Office Communicator
375 %description -n
%{nsis_package}
376 A third
-party plugin
for the Pidgin multi
-protocol instant messenger.
377 It implements the extended version of SIP
/SIMPLE used by various products
:
380 * Microsoft Office
365
381 * Microsoft Business Productivity Online Suite
(BPOS
)
382 * Microsoft Lync Server
383 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
384 * Microsoft Live Communications Server
(LCS
2003/2005)
386 This package contains the NSIS installer package of the protocol plugin
387 for Pidgin on Windows.
391 %{mingw_debug_package}
395 %setup -q
-n pidgin
-sipe
-%{version}
398 %if 0%{?mingw_prefix:1}
400 # Windows cross-compilation build
403 echo "lt_cv_deplibs_check_method
='pass_all'"
>>%{mingw_cache}
404 autoreconf
--verbose
--install --force
405 %{mingw_ldflags}="
-Wl
,--exclude
-libs
=libintl.a
-Wl
,--exclude
-libs
=libiconv.a
-lws2_32"
408 %if 0%{?build_telepathy:1}
413 %{mingw_make} %{?_smp_mflags} || %{mingw_make}
417 # Standard Linux build
419 # Special case handling for Mageia
430 %if !0%{?has_appstream:1}
431 --without
-appstream \
433 %if !0%{?_without_kerberos:1}
437 %if 0%{?build_telepathy:1}
443 make %{?_smp_mflags} check
446 # End Windows cross-compilation/Linux build setup
451 %if 0%{?mingw_prefix:1}
453 # Windows cross-compilation install
456 rm -f
%{buildroot}%{mingw_libdir}/purple
-2/*.dll.a
458 # generate .dbgsym file
459 rm -f
%{buildroot}%{mingw_libdir}/purple
-2/libsipe.dll.dbgsym
461 %{buildroot}%{mingw_libdir}/purple
-2/libsipe.dll \
462 %{buildroot}%{mingw_libdir}/purple
-2/libsipe.dll.dbgsym
463 %{__strip} --strip
-unneeded \
464 %{buildroot}%{mingw_libdir}/purple
-2/libsipe.dll.dbgsym \
465 -o
%{buildroot}%{mingw_libdir}/purple
-2/libsipe.dll \
467 # generate NSIS installer package
468 perl contrib
/opensuse
-build
-service
/generate_nsi.pl po
/LINGUAS \
469 <contrib
/opensuse
-build
-service
/pidgin
-sipe.nsi.template \
470 >%{buildroot}/pidgin
-sipe.nsi
475 -DPIDGIN_VERSION
=UNKNOWN \
476 -DVERSION
=%{version} \
477 -DMINGW_LIBDIR
=%{buildroot}%{mingw_libdir} \
478 -DMINGW_DATADIR
=%{buildroot}%{mingw_datadir} \
481 rm -f
%{buildroot}/pidgin
-sipe.nsi
485 # Standard Linux install
489 # End Windows cross-compilation/Linux build setup
492 find
%{buildroot} -type f
-name "
*.la"
-delete
-print
493 # Pidgin doesn't have 24 or 32 pixel icons
495 %{buildroot}%{_datadir}/pixmaps
/pidgin
/protocols
/24/sipe.png \
496 %{buildroot}%{_datadir}/pixmaps
/pidgin
/protocols
/32/sipe.png
497 %if 0%{?has_appstream_legacy:1}
498 mv
%{buildroot}/%{_datadir}/metainfo %{buildroot}/%{_datadir}/appdata
500 %if 0%{?build_telepathy:1}
501 %if !0%{?build_ktp:1}
502 rm -r
%{buildroot}%{_datadir}/telepathy
505 %find_lang pidgin
-sipe
508 %if 0%{?build_telepathy:1}
509 %files -n
%{purple_plugin}
511 %files -n
%{purple_plugin} -f pidgin
-sipe.lang
513 %defattr(-,root
,root
,-)
514 %doc AUTHORS ChangeLog COPYING NEWS README TODO
515 %if 0%{?mingw_prefix:1}
516 %{mingw_libdir}/purple
-2/libsipe.dll
517 %{mingw_libdir}/purple
-2/libsipe.dll.dbgsym
519 %{_libdir}/purple
-2/libsipe.so
523 %if 0%{?build_telepathy:1}
524 %files -n
%{empathy_files}
525 %defattr(-,root
,root
,-)
526 %{_datadir}/empathy
/icons
/hicolor
/*/apps
/im
-sipe.png
527 %{_datadir}/empathy
/icons
/hicolor
/*/apps
/im
-sipe.svg
531 %files -n
%{ktp_files}
532 %defattr(-,root
,root
,-)
534 %{_datadir}/telepathy
/profiles
/sipe.profile
538 %files -n
%{telepathy_plugin}
539 %defattr(-,root
,root
,-)
540 %doc AUTHORS ChangeLog COPYING NEWS README TODO
541 %{_datadir}/dbus
-1/services
/*.sipe.service
542 %{_libexecdir}/telepathy
-sipe
545 %files -n
%{common_files} -f pidgin
-sipe.lang
546 %defattr(-,root
,root
,-)
551 %defattr(-,root
,root
,-)
553 %if 0%{?mingw_prefix:1}
554 %if 0%{?has_appstream:1}
555 %{mingw_datadir}/metainfo
/pidgin
-sipe.metainfo.xml
557 %{mingw_datadir}/pixmaps
/pidgin
/protocols
/*/sipe.png
558 %{mingw_datadir}/pixmaps
/pidgin
/protocols
/*/sipe.svg
560 %if 0%{?has_appstream:1}
561 %if 0%{?has_appstream_legacy:1}
562 %{_datadir}/appdata/%{name}.metainfo.xml
564 %{_datadir}/metainfo/%{name}.metainfo.xml
567 %{_datadir}/pixmaps
/pidgin
/protocols
/*/sipe.png
568 %{_datadir}/pixmaps
/pidgin
/protocols
/*/sipe.svg
572 %if 0%{?mingw_prefix:1}
573 %files -n
%{nsis_package}
574 %defattr(-, root
, root
)
575 /pidgin
-sipe
-%{version}.exe
580 * Sat Sep
01 2018 J. D. User
<jduser@noreply.com
> 1.23.3-*git
*
581 - update support
for CentOS
& Scientific Linux
7
583 * Mon Aug
27 2018 J. D. User
<jduser@noreply.com
> 1.23.3-*git
*
584 - add BR freerdp
-shadow2
586 * Mon Aug
20 2018 J. D. User
<jduser@noreply.com
> 1.23.3
589 * Sat Mar
10 2018 J. D. User
<jduser@noreply.com
> 1.23.2
592 * Sun Feb
25 2018 J. D. User
<jduser@noreply.com
> 1.23.1
595 * Sun Feb
18 2018 J. D. User
<jduser@noreply.com
> 1.23.0-*git
*
596 - remove obsolete clean section
598 * Sun Feb
18 2018 J. D. User
<jduser@noreply.com
> 1.23.0-*git
*
601 * Mon Nov
06 2017 J. D. User
<jduser@noreply.com
> 1.23.0-*git
*
604 * Sun Nov
05 2017 J. D. User
<jduser@noreply.com
> 1.23.0-*git
*
605 - add support
for new AppStream metadata file location
607 * Sat Oct
28 2017 J. D. User
<jduser@noreply.com
> 1.23.0
609 - raise BR glib
-2.0 >= 2.18.0
610 - raise BR purple
>= 2.7.0
612 * Fri Aug
11 2017 J. D. User
<jduser@noreply.com
> 1.22.1-*git
*
614 - fix incorrect BR gstreamer
-0.10 when gstreamer
-1.0 is selected
616 * Sun Jun
11 2017 J. D. User
<jduser@noreply.com
> 1.22.1
619 * Wed Feb
01 2017 J. D. User
<jduser@noreply.com
> 1.22.0
622 * Sun Dec
18 2016 J. D. User
<jduser@noreply.com
> 1.21.1-*git
*
625 * Wed Jun
15 2016 J. D. User
<jduser@noreply.com
> 1.21.1-*git
*
626 - add BR farstream
-0.2
628 * Sat May
28 2016 J. D. User
<jduser@noreply.com
> 1.21.1
631 * Sat Apr
23 2016 J. D. User
<jduser@noreply.com
> 1.21.0
634 * Tue Apr
05 2016 J. D. User
<jduser@noreply.com
> 1.20.1-*git
*
635 - align with Fedora SPEC file
637 * Fri Jan
01 2016 J. D. User
<jduser@noreply.com
> 1.20.1-*git
*
638 - add AppStream metadata file
640 * Sun Nov
08 2015 J. D. User
<jduser@noreply.com
> 1.20.1-*git
*
641 - add dependency on pkgconfig
(gstreamer
-1.0) for F22
+ & Leap
42.1+
643 * Sat Oct
24 2015 J. D. User
<jduser@noreply.com
> 1.20.1
646 * Thu Sep
03 2015 J. D. User
<jduser@noreply.com
> 1.20.0-*git
*
647 - we also support "Skype
for Business"
649 * Sat Aug
29 2015 J. D. User
<jduser@noreply.com
> 1.20.0
652 * Sat Apr
04 2015 J. D. User
<jduser@noreply.com
> 1.19.1
655 * Sat Feb
07 2015 J. D. User
<jduser@noreply.com
> 1.19.0
658 * Tue Jan
06 2015 J. D. User
<jduser@noreply.com
> 1.18.5-*git
*
659 - add dependency on gssntlmssp
(-devel
) >= 0.5.0 for F21
+
661 * Mon Jan
05 2015 J. D. User
<jduser@noreply.com
> 1.18.5-*git
*
662 - remove support
for obsolete distributions
667 * Mon Dec
29 2014 J. D. User
<jduser@noreply.com
> 1.18.5
670 * Thu Dec
18 2014 J. D. User
<jduser@noreply.com
> 1.18.4-*git
*
671 - improve support
for CentOS
& Scientific Linux
673 * Sat Oct
18 2014 J. D. User
<jduser@noreply.com
> 1.18.4
676 * Sat Aug
16 2014 J. D. User
<jduser@noreply.com
> 1.18.3
679 * Sat Jun
07 2014 J. D. User
<jduser@noreply.com
> 1.18.2
682 * Sat Apr
12 2014 J. D. User
<jduser@noreply.com
> 1.18.1
685 * Tue Mar
04 2014 J. D. User
<jduser@noreply.com
> 1.18.0-*git
*
686 - F20
+/openSUSE
12.2+ require libnice gstreamer
-0.10 plugin
688 * Sat Jan
11 2014 J. D. User
<jduser@noreply.com
> 1.18.0
691 * Wed Dec
11 2013 J. D. User
<jduser@noreply.com
> 1.17.3
694 * Sat Nov
30 2013 J. D. User
<jduser@noreply.com
> 1.17.2
697 * Sat Nov
16 2013 J. D. User
<jduser@noreply.com
> 1.17.1
700 * Sat Sep
21 2013 J. D. User
<jduser@noreply.com
> 1.17.0
703 * Sat Jul
13 2013 J. D. User
<jduser@noreply.com
> 1.16.1
706 * Fri Jun
14 2013 J. D. User
<jduser@noreply.com
> 1.16.0
709 * Sun Apr
07 2013 J. D. User
<jduser@noreply.com
> 1.15.1
712 * Fri Mar
29 2013 J. D. User
<jduser@noreply.com
> 1.15.0-*git
*
713 - update package description texts
715 * Sat Mar
09 2013 J. D. User
<jduser@noreply.com
> 1.15.0
718 * Wed Dec
26 2012 J. D. User
<jduser@noreply.com
> 1.14.1
721 * Sun Dec
16 2012 J. D. User
<jduser@noreply.com
> 1.14.0
724 * Tue Sep
25 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
725 - change BR gstreamer
-devel to pkgconfig
(gstreamer
-0.10)
727 * Sun Sep
09 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
728 - BR telepathy
-glib
-devel
>= 0.18.0
730 * Wed Sep
05 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
731 - BR telepathy
-glib
-devel
>= 0.14.0
733 * Sun Sep
02 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
734 - really disable telepathy
for Windows cross
-compilation builds
736 * Thu Aug
30 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
737 - updates to
enable telepathy build
739 * Sun Aug
19 2012 J. D. User
<jduser@noreply.com
> 1.13.3
742 * Sun Jun
10 2012 J. D. User
<jduser@noreply.com
> 1.13.2
745 * Mon Apr
09 2012 J. D. User
<jduser@noreply.com
> 1.13.1
748 * Wed Mar
14 2012 J. D. User
<jduser@noreply.com
> 1.13.0
751 * Mon Dec
12 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
752 - we
do support Microsoft Lync Server
2010 now.
754 * Tue Dec
06 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
755 - update GPL2 license name
757 * Sat Nov
12 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
758 - add BR gmime
-devel
for Fedora to have at least one verification platform
760 * Sun Nov
06 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
761 - fix Mandriva
2011 unresolvable BR
763 * Mon Oct
31 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
766 * Sat Oct
01 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
767 - add NSIS package
for mingw builds
769 * Sat Oct
01 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
772 * Wed Sep
28 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
773 - remove BR mingw32
-mozilla
-nss
-devel
, not needed
for SSPI.
775 * Mon Sep
19 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
776 - update mingw32 build
777 - update descriptions
779 * Mon Aug
29 2011 J. D. User
<jduser@noreply.com
> 1.12.0
782 * Wed Jun
22 2011 J. D. User
<jduser@noreply.com
> 1.11.2-*git
*
783 - add gstreamer
-devel to
enable Voice
& Video features
785 * Sat Dec
11 2010 J. D. User
<jduser@noreply.com
> 1.11.2-*git
*
786 - add optional subpackage
for telepathy connection manager
788 * Tue Nov
02 2010 J. D. User
<jduser@noreply.com
> 1.11.2
791 * Sun Oct
24 2010 J. D. User
<jduser@noreply.com
> 1.11.1
794 * Fri Oct
15 2010 J. D. User
<jduser@noreply.com
> 1.11.0-*git
*
795 - add mingw32 build configuration
797 * Sun Oct
03 2010 J. D. User
<jduser@noreply.com
> 1.11.0
800 * Thu Sep
02 2010 J. D. User
<jduser@noreply.com
> pre
-1.11.0-*git
*
801 - Mandriva config
for OBS has changed
803 * Tue May
04 2010 J. D. User
<jduser@noreply.com
> 1.10.0-*git
*
804 - add libnice build information discovered through OBS testing
806 * Mon Apr
12 2010 J. D. User
<jduser@noreply.com
> 1.10.0-*git
*
807 - add NSS build information discovered through OBS testing
809 * Sun Apr
04 2010 pier11
<pier11@operamail.com
> 1.10.0
812 * Fri Apr
02 2010 J. D. User
<jduser@noreply.com
> pre
-1.10.0-*git
*
813 - Mandriva has too old libtool version
815 * Fri Apr
02 2010 J. D. User
<jduser@noreply.com
> pre
-1.10.0-*git
*
816 - SLE11
, openSUSE
11.0/1 don't have pidgin
/protocols
/scalable directory
818 * Thu Apr
01 2010 pier11
<pier11@operamail.com
> pre
-1.10.0-*git
*
819 - OBS tests of pre
-1.10.0 git
-snapshot
4fa20cd65e5be0e469d4aa55d861f11c5b08b816
821 * Sun Mar
28 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
822 - added
--enable/--disable build options
824 * Sun Mar
28 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
825 - removed
--with
-krb5 configure option as it is autodetected now
827 * Tue Mar
23 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
830 * Sat Mar
20 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
831 - add BR glib2
-devel
>= 2.12.0
833 * Wed Mar
17 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
836 * Tue Mar
16 2010 J. D. User
<jduser@noreply.com
> 1.9.1
839 * Thu Mar
11 2010 J. D. User
<jduser@noreply.com
> 1.9.0-*git
*
840 - add BR libxml2
-devel
842 * Wed Mar
10 2010 pier11
<pier11@operamail.com
> 1.9.0
844 - dropped SLE
10 due to libpurple min version increase
845 - updated target distros
in comment line
847 * Mon Mar
08 2010 J. D. User
<jduser@noreply.com
> 1.9.0-*git
*
848 - increased libpurple build requisite to
>= 2.4.0
850 * Sun Mar
07 2010 pier11
<pier11@operamail.com
> pre
-1.9.0-*git
*
851 - OBS tests of pre
-1.9.0 git
-snapshot
61ea0856855483b9e18f23a87afe47437e526f0e
853 * Sun Mar
07 2010 J. D. User
<jduser@noreply.com
> 1.8.1-*git
*
854 - sync with RPM SPEC from contrib
/rpm
856 * Mon Feb
08 2010 pier11
<pier11@operamail.com
> 1.8.0
857 - source is an original
1.8.0 with patch
: git
(upstream
) 9c34cc3557daa3d61a002002492c71d0343c8cae
858 - temp hack
- renamed
source in spec from .bz2 to .gz as the latter was prepared with the patch.
860 * Sun Nov
22 2009 pier11
<pier11@operamail.com
> 1.7.1
861 - reinstated
enable-quality
-check
863 * Wed Nov
04 2009 John Beranek
<john@redux.org.uk
> 1.7.0
864 - Spec file modifications to allow SLES
/D
10 and Mandriva
2009.1 builds
866 * Tue Nov
03 2009 John Beranek
<john@redux.org.uk
> 1.7.0
867 - Spec file modifications
for openSUSE build service
869 * Sun Oct
11 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
870 - move non
-Pidgin files to new sub
-package purple
-sipe
872 * Sun Oct
11 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
873 - remove directory
for emoticon theme icons
875 * Sun Oct
11 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
876 - libpurple protocol plugins are located under %
%{_libdir}/purple
-2
878 * Mon Sep
28 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
879 - added directory
for emoticon theme icons
881 * Wed Sep
09 2009 J. D. User
<jduser@noreply.com
> 1.6.3
884 * Fri Aug
28 2009 J. D. User
<jduser@noreply.com
> 1.6.2-*git
*
885 - reduce libpurple
-devel requirement to
>= 2.3.1
887 * Mon Aug
24 2009 J. D. User
<jduser@noreply.com
> 1.6.2
890 * Fri Aug
21 2009 J. D. User
<jduser@noreply.com
> 1.6.1-*git
*
891 - reduce libpurple
-devel requirement to
>= 2.4.1
893 * Mon Aug
17 2009 J. D. User
<jduser@noreply.com
> 1.6.1-*git
*
894 - com_err.h only required
for kerberos
896 * Tue Aug
11 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
897 - require libpurple
-devel
>= 2.5.0
899 * Sun Aug
09 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
900 - refactor configure parameters
901 - make kerberos configurable
902 - don't hard code prefix
for git builds
904 * Sun Aug
09 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
905 - removed unnecessary zlib
-devel
907 * Sat Aug
08 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
908 - fix prefix
for git builds
910 * Sat Aug
01 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
911 - append
-Wno
-unused
-parameter
for GCC
<4.4 compilation errors
913 * Thu Jul
30 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
914 - remove duplicate GPL2
916 * Thu Jul
30 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
917 - use "
--with git" to build from git
918 - corrected download
URL for release archive
919 - add missing BR gettext
-devel
921 * Wed Jul
29 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
922 - use default rpmbuild CFLAGS also
for git builds
923 - merge with SPEC files created by mricon
& jberanek
925 * Tue Jul
28 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
926 - initial RPM SPEC example generated