2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box on Fedora 10+ or RHEL5+.
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git
20160405git4fedafa
14 # Increment when you generate several RPMs on the same day...
16 #------------------------------- BUILD FROM GIT -------------------------------
19 %define purple_plugin purple
-sipe
20 %define telepathy_plugin telepathy
-sipe
21 %define common_files sipe
-common
22 %define empathy_files empathy
-sipe
23 %define ktp_files ktp
-accounts
-kcm
-sipe
24 %define pkg_group Applications
/Communications
27 Summary: Pidgin protocol plugin to connect to MS Office Communicator
30 Release: %{gitcount}.%{git}%{?dist}
31 Source0: %{name}-%{git}.tar.bz2
32 # git package overrides official released package
36 Source0: http
://downloads.sourceforge.net
/project
/sipe
/sipe
/%{name}-%{version}/%{name}-%{version}.tar.bz2
40 URL: http
://sipe.sourceforge.net
/
42 BuildRequires
: pkgconfig
(glib
-2.0) >= 2.12.0
43 BuildRequires
: pkgconfig
(gmodule
-2.0) >= 2.12.0
44 BuildRequires
: pkgconfig
(libxml
-2.0)
45 BuildRequires
: pkgconfig
(nss
)
46 BuildRequires
: pkgconfig
(purple
) >= 2.4.0
48 BuildRequires
: autoconf
49 BuildRequires
: automake
51 BuildRequires
: gettext
52 BuildRequires
: intltool
53 BuildRequires
: libtool
54 # Use "--without vv" to disable Voice & Video features
55 %if !0%{?_without_vv:1}
56 BuildRequires
: pkgconfig
(purple
) >= 2.8.0
57 BuildRequires
: pkgconfig
(nice
) >= 0.1.0
59 BuildRequires
: pkgconfig
(gstreamer
-1.0)
62 # Dependency required when gstreamer support is split into two packages
63 %define requires_libnice_gstreamer
1
65 BuildRequires
: pkgconfig
(gstreamer
-0.10)
68 # Use "--without telepathy" to disable telepathy
69 %if !0%{?_without_telepathy:1}
70 BuildRequires
: pkgconfig
(telepathy
-glib
) >= 0.18.0
71 BuildRequires
: pkgconfig
(glib
-2.0) >= 2.28.0
72 BuildRequires
: pkgconfig
(gio
-2.0) >= 2.32.0
73 BuildRequires
: pkgconfig
(gobject
-2.0)
74 BuildRequires
: pkgconfig
(dbus
-glib
-1)
75 BuildRequires
: gmime
-devel
78 # Configurable components
79 # Use "--without kerberos" to disable krb5
80 %if !0%{?_without_kerberos:1}
81 BuildRequires
: krb5
-devel
83 BuildRequires
: gssntlmssp
-devel
>= 0.5.0
84 %define requires_gssntlmssp
1
88 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
92 A third
-party plugin
for the Pidgin multi
-protocol instant messenger.
93 It implements the extended version of SIP
/SIMPLE used by various products
:
96 * Microsoft Office
365
97 * Microsoft Business Productivity Online Suite
(BPOS
)
98 * Microsoft Lync Server
99 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
100 * Microsoft Live Communications Server
(LCS
2003/2005)
103 With this plugin you should be able to replace your Microsoft Office
104 Communicator client with Pidgin.
106 This package provides the icon
set for Pidgin.
109 %package -n
%{purple_plugin}
110 Summary: Libpurple protocol plugin to connect to MS Office Communicator
113 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
115 %if 0%{?requires_libnice_gstreamer}
116 Requires: libnice
-gstreamer
118 %if 0%{?requires_gssntlmssp}
119 Requires: gssntlmssp
>= 0.5.0
122 %description -n
%{purple_plugin}
123 A third
-party plugin
for the Pidgin multi
-protocol instant messenger.
124 It implements the extended version of SIP
/SIMPLE used by various products
:
127 * Microsoft Office
365
128 * Microsoft Business Productivity Online Suite
(BPOS
)
129 * Microsoft Lync Server
130 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
131 * Microsoft Live Communications Server
(LCS
2003/2005)
134 This package provides the protocol plugin
for libpurple clients.
137 %if !0%{?_without_telepathy:1}
138 %package -n
%{empathy_files}
139 Summary: Telepathy connection manager to connect to MS Office Communicator
142 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
144 %description -n
%{empathy_files}
145 A Telepathy connection manager that implements the extended version of
146 SIP
/SIMPLE used by various products
:
149 * Microsoft Office
365
150 * Microsoft Business Productivity Online Suite
(BPOS
)
151 * Microsoft Lync Server
152 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
153 * Microsoft Live Communications Server
(LCS
2003/2005)
156 This package provides the icon
set for Empathy.
159 %package -n
%{ktp_files}
160 Summary: Telepathy connection manager to connect to MS Office Communicator
163 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
165 %description -n
%{ktp_files}
166 A Telepathy connection manager that implements the extended version of
167 SIP
/SIMPLE used by various products
:
170 * Microsoft Office
365
171 * Microsoft Business Productivity Online Suite
(BPOS
)
172 * Microsoft Lync Server
173 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
174 * Microsoft Live Communications Server
(LCS
2003/2005)
177 This package provides the profile
for KTP account manager.
180 %package -n
%{telepathy_plugin}
181 Summary: Telepathy connection manager to connect to MS Office Communicator
184 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
186 %if 0%{?requires_libnice_gstreamer}
187 # @TODO: remove comment when telepathy plugin supports Voice & Video features
188 #Requires: libnice-gstreamer
190 %if 0%{?requires_gssntlmssp}
191 Requires: gssntlmssp
>= 0.5.0
194 %description -n
%{telepathy_plugin}
195 A Telepathy connection manager that implements the extended version of
196 SIP
/SIMPLE used by various products
:
199 * Microsoft Office
365
200 * Microsoft Business Productivity Online Suite
(BPOS
)
201 * Microsoft Lync Server
202 * Microsoft Office Communications Server
(OCS
2007/2007 R2
)
203 * Microsoft Live Communications Server
(LCS
2003/2005)
206 This package provides the protocol support
for Telepathy clients.
210 %package -n
%{common_files}
211 Summary: Common files
for SIPE protocol plugins
216 %description -n
%{common_files}
217 This package provides common files
for the SIPE protocol plugins
:
224 %setup -q
-n
%{name}-%{git}
235 %if 0%{?_without_vv:1}
238 %if !0%{?_without_kerberos:1}
242 %if !0%{?_without_telepathy:1}
248 make %{?_smp_mflags} check
253 find
%{buildroot} -type f
-name "
*.la"
-delete
-print
254 # Pidgin doesn't have 24 or 32 pixel icons
256 %{buildroot}%{_datadir}/pixmaps
/pidgin
/protocols
/24/sipe.png \
257 %{buildroot}%{_datadir}/pixmaps
/pidgin
/protocols
/32/sipe.png
265 %files -n
%{purple_plugin}
266 %defattr(-,root
,root
,-)
267 %doc AUTHORS ChangeLog COPYING NEWS README TODO
268 %{_libdir}/purple
-2/libsipe.so
271 %if !0%{?_without_telepathy:1}
272 %files -n
%{empathy_files}
273 %defattr(-,root
,root
,-)
274 %{_datadir}/empathy
/icons
/hicolor
/*/apps
/im
-sipe.png
275 %{_datadir}/empathy
/icons
/hicolor
/*/apps
/im
-sipe.svg
278 %files -n
%{ktp_files}
279 %defattr(-,root
,root
,-)
281 %{_datadir}/telepathy
/profiles
/sipe.profile
284 %files -n
%{telepathy_plugin}
285 %defattr(-,root
,root
,-)
286 %doc AUTHORS ChangeLog COPYING NEWS README TODO
287 %{_datadir}/dbus
-1/services
/*.sipe.service
288 %{_libexecdir}/telepathy
-sipe
292 %files -n
%{common_files} -f %{name}.lang
293 %defattr(-,root
,root
,-)
297 %defattr(-,root
,root
,-)
298 %{_datadir}/appdata/%{name}.metainfo.xml
299 %{_datadir}/pixmaps
/pidgin
/protocols
/*/sipe.png
300 %{_datadir}/pixmaps
/pidgin
/protocols
/*/sipe.svg
304 * Sat May
28 2016 J. D. User
<jduser@noreply.com
> 1.21.1
307 * Sat Apr
23 2016 J. D. User
<jduser@noreply.com
> 1.21.0
310 * Tue Apr
05 2016 J. D. User
<jduser@noreply.com
> 1.20.1-*git
*
311 - align with Fedora SPEC file
313 * Fri Jan
01 2016 J. D. User
<jduser@noreply.com
> 1.20.1-*git
*
314 - add AppStream metadata file
316 * Sun Nov
08 2015 J. D. User
<jduser@noreply.com
> 1.20.1-*git
*
317 - add dependency on pkgconfig
(gstreamer
-1.0) for F22
+
319 * Sat Oct
24 2015 J. D. User
<jduser@noreply.com
> 1.20.1
322 * Thu Sep
03 2015 J. D. User
<jduser@noreply.com
> 1.20.0-*git
*
323 - we also support "Skype
for Business"
325 * Sat Aug
29 2015 J. D. User
<jduser@noreply.com
> 1.20.0
328 * Sat Apr
04 2015 J. D. User
<jduser@noreply.com
> 1.19.1
331 * Sat Feb
07 2015 J. D. User
<jduser@noreply.com
> 1.19.0
334 * Tue Jan
06 2015 J. D. User
<jduser@noreply.com
> 1.18.5-*git
*
335 - add dependency on gssntlmssp
(-devel
) >= 0.5.0 for F21
+
336 - enable Voice
& Video features by default
337 - move dependency on libnice
-gstreamer to correct packages
339 * Mon Dec
29 2014 J. D. User
<jduser@noreply.com
> 1.18.5
342 * Sat Oct
18 2014 J. D. User
<jduser@noreply.com
> 1.18.4
345 * Sat Aug
16 2014 J. D. User
<jduser@noreply.com
> 1.18.3
348 * Sat Jun
07 2014 J. D. User
<jduser@noreply.com
> 1.18.2
351 * Sat Apr
12 2014 J. D. User
<jduser@noreply.com
> 1.18.1
354 * Sat Mar
08 2014 J. D. User
<jduser@noreply.com
> 1.18.0-*git
*
355 - New Fedora packaging guidelines suggest to use pkgconfig
() for BRs
357 * Tue Mar
04 2014 J. D. User
<jduser@noreply.com
> 1.18.0-*git
*
358 - F20
+ require libnice
-gstreamer
for correct operation
360 * Sat Jan
11 2014 J. D. User
<jduser@noreply.com
> 1.18.0
363 * Wed Dec
11 2013 J. D. User
<jduser@noreply.com
> 1.17.3
366 * Sat Nov
30 2013 J. D. User
<jduser@noreply.com
> 1.17.2
369 * Sat Nov
16 2013 J. D. User
<jduser@noreply.com
> 1.17.1
372 * Sat Sep
21 2013 J. D. User
<jduser@noreply.com
> 1.17.0
375 * Sat Jul
13 2013 J. D. User
<jduser@noreply.com
> 1.16.1
378 * Fri Jun
14 2013 J. D. User
<jduser@noreply.com
> 1.16.0
381 * Thu May
16 2013 J. D. User
<jduser@noreply.com
> 1.15.1-*git
*
382 - BR glib
-2.0 >= 2.28.0 no longer required
for Voice
& Video features
384 * Sun Apr
07 2013 J. D. User
<jduser@noreply.com
> 1.15.1
387 * Fri Mar
29 2013 J. D. User
<jduser@noreply.com
> 1.15.0-*git
*
388 - update package description texts
390 * Sat Mar
09 2013 J. D. User
<jduser@noreply.com
> 1.15.0
393 * Wed Dec
26 2012 J. D. User
<jduser@noreply.com
> 1.14.1
396 * Sun Dec
16 2012 J. D. User
<jduser@noreply.com
> 1.14.0
399 * Sun Sep
09 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
400 - BR telepathy
-glib
-devel
>= 0.18.0
402 * Wed Sep
05 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
403 - BR telepathy
-glib
-devel
>= 0.14.0
405 * Mon Aug
27 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
406 - add ktp
-accounts
-kcm
-sipe package
408 * Sun Aug
26 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
409 - telepathy now requires glib
-2.0 >= 2.22.0
410 - use "
--without telepathy" to disable telepathy packages
412 * Fri Aug
24 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
413 - add empathy
-sipe package
415 * Wed Aug
22 2012 J. D. User
<jduser@noreply.com
> 1.13.3-*git
*
416 - add telepathy
-sipe
& sipe
-common packages
418 * Sun Aug
19 2012 J. D. User
<jduser@noreply.com
> 1.13.3
421 * Sun Jun
10 2012 J. D. User
<jduser@noreply.com
> 1.13.2
424 * Mon Apr
09 2012 J. D. User
<jduser@noreply.com
> 1.13.1
427 * Wed Mar
14 2012 J. D. User
<jduser@noreply.com
> 1.13.0
430 * Mon Dec
12 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
431 - we
do support Microsoft Lync Server
2010 now.
433 * Tue Dec
06 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
434 - update GPL2 license name
436 * Sat Nov
12 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
439 * Mon Oct
31 2011 J. D. User
<jduser@noreply.com
> 1.12.0-*git
*
442 * Mon Aug
29 2011 J. D. User
<jduser@noreply.com
> 1.12.0
445 * Wed Jun
22 2011 J. D. User
<jduser@noreply.com
> 1.11.2-*git
*
446 - add "
--with vv" option to
enable Voice
& Video features
448 * Tue Nov
02 2010 J. D. User
<jduser@noreply.com
> 1.11.2
451 * Sun Oct
24 2010 J. D. User
<jduser@noreply.com
> 1.11.1
454 * Mon Oct
04 2010 J. D. User
<jduser@noreply.com
> 1.11.0
457 * Thu Sep
02 2010 J. D. User
<jduser@noreply.com
> 1.10.1-*git
*
458 - add
(commented out
) BR libnice
-devel
460 * Sun Jun
27 2010 J. D. User
<jduser@noreply.com
> 1.10.1
463 * Mon Apr
12 2010 J. D. User
<jduser@noreply.com
> 1.10.0-*git
*
464 - add
(commented out
) BR nss
-devel
466 * Sun Apr
04 2010 J. D. User
<jduser@noreply.com
> 1.10.0
469 * Sun Mar
28 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
470 - changed
--with
/--without options to
--enable/--disable
472 * Sun Mar
28 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
473 - removed
--with
-krb5 configure option as it is autodetected now
475 * Tue Mar
23 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
478 * Sat Mar
20 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
479 - add BR glib2
-devel
>= 2.12.0
481 * Wed Mar
17 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
484 * Tue Mar
16 2010 J. D. User
<jduser@noreply.com
> 1.9.1
487 * Thu Mar
11 2010 J. D. User
<jduser@noreply.com
> 1.9.0-*git
*
488 - add BR libxml2
-devel
490 * Wed Mar
10 2010 J. D. User
<jduser@noreply.com
> 1.9.0
493 * Mon Mar
08 2010 J. D. User
<jduser@noreply.com
> 1.8.1-*git
*
494 - increased libpurple build requisite to
>= 2.4.0
496 * Sun Mar
07 2010 J. D. User
<jduser@noreply.com
> 1.8.1-*git
*
497 - sync with RPM SPEC from contrib
/OBS
499 * Sat Mar
06 2010 J. D. User
<jduser@noreply.com
> 1.8.1-*git
*
500 - update package summary
& description
502 * Tue Feb
16 2010 J. D. User
<jduser@noreply.com
> 1.8.1
505 * Sun Feb
07 2010 J. D. User
<jduser@noreply.com
> 1.8.0
508 * Thu Jan
14 2010 J. D. User
<jduser@noreply.com
> 1.7.1-*git
*
509 - autogen.sh no longer runs configure
511 * Tue Dec
29 2009 J. D. User
<jduser@noreply.com
> 1.7.1-*git
*
512 - add configure parameters
for purple and telepathy
514 * Sat Dec
12 2009 J. D. User
<jduser@noreply.com
> 1.7.1-*git
*
515 - add Epoch
: for git packages to avoid update clash with official packages
517 * Thu Nov
19 2009 J. D. User
<jduser@noreply.com
> 1.7.1
520 * Wed Oct
28 2009 J. D. User
<jduser@noreply.com
> 1.7.0-*git
*
521 - add missing
Group: to purple
-sipe
523 * Mon Oct
19 2009 J. D. User
<jduser@noreply.com
> 1.7.0
526 * Sun Oct
11 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
527 - move non
-Pidgin files to new sub
-package purple
-sipe
529 * Sun Oct
11 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
530 - remove directory
for emoticon theme icons
532 * Sun Oct
11 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
533 - libpurple protocol plugins are located under %
%{_libdir}/purple
-2
535 * Mon Sep
28 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
536 - added directory
for emoticon theme icons
538 * Wed Sep
09 2009 J. D. User
<jduser@noreply.com
> 1.6.3
541 * Fri Aug
28 2009 J. D. User
<jduser@noreply.com
> 1.6.2-*git
*
542 - reduce libpurple
-devel requirement to
>= 2.3.1
544 * Mon Aug
24 2009 J. D. User
<jduser@noreply.com
> 1.6.2
547 * Fri Aug
21 2009 J. D. User
<jduser@noreply.com
> 1.6.1-*git
*
548 - reduce libpurple
-devel requirement to
>= 2.4.1
550 * Mon Aug
17 2009 J. D. User
<jduser@noreply.com
> 1.6.1-*git
*
551 - com_err.h only required
for kerberos
553 * Tue Aug
11 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
554 - require libpurple
-devel
>= 2.5.0
556 * Sun Aug
09 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
557 - refactor configure parameters
558 - make kerberos configurable
559 - don't hard code prefix
for git builds
561 * Sun Aug
09 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
562 - removed unnecessary zlib
-devel
564 * Sat Aug
08 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
565 - fix prefix
for git builds
567 * Sat Aug
01 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
568 - append
-Wno
-unused
-parameter
for GCC
<4.4 compilation errors
570 * Thu Jul
30 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
571 - remove duplicate GPL2
573 * Thu Jul
30 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
574 - use "
--with git" to build from git
575 - corrected download
URL for release archive
576 - add missing BR gettext
-devel
578 * Wed Jul
29 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
579 - use default rpmbuild CFLAGS also
for git builds
580 - merge with SPEC files created by mricon
& jberanek
582 * Tue Jul
28 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
583 - initial RPM SPEC example generated